forum

Guide osu! Linux

posted
Total Posts
54
show more
WolfiyEdits
worked great thx

(arch 5.8.13, bspwm)
icr0
Is the latest update broken for anyone else (arch)
i restarted osu to update, can't launch it anymore:


0103:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
00fb:fixme:shell:URL_ParseUrl failed to parse L"System.Runtime.Remoting"
00fb:fixme:ntdll:EtwEventRegister ({8e9f5090-2d75-4d03-8a81-e5afbf85daf1}, 0xd90aba, (nil), 0x1114ee0) stub.
0109:fixme:process:FlushProcessWriteBuffers : stub
00fd:fixme:ntdll:EtwEventUnregister (deadbeef) stub.
DonTMover_old
Tnks
DRO4ULA
When I run osu! Updater it gives the error "an error occurred! Please check your internet connection". How do I fix this? (Manjaro)
kevincos5
This works for elementary os?
marshallracer

DRO4ULA wrote:

When I run osu! Updater it gives the error "an error occurred! Please check your internet connection". How do I fix this? (Manjaro)
Check and see if you have lib32-gnutls installed, this is often the reason the updater has no internet connection



kevincos5 wrote:

This works for elementary os?
Yes. As it is based on Ubuntu, installation should be straightforward.
Valorix

marshallracer wrote:

DRO4ULA wrote:

When I run osu! Updater it gives the error "an error occurred! Please check your internet connection". How do I fix this? (Manjaro)
Check and see if you have lib32-gnutls installed, this is often the reason the updater has no internet connection



kevincos5 wrote:

This works for elementary os?
Yes. As it is based on Ubuntu, installation should be straightforward.
Yesterday I upgraded from Fedora 32 to Fedora 33 and I'm having the same issue. For Fedora install command for gnutls is "sudo dnf install gnutls" and it writes this "Package gnutls-3.6.15-1.fc33.i686 is already installed.
Package gnutls-3.6.15-1.fc33.x86_64 is already installed.
".. It is installed, but doesn't work somehow.. I have osu! installed through Lutris script. I tried deleting the Wine prefix and installing it again. Nothing.. I tried this install script https://github.com/yurisuki/osu-install and still nothing. Lutris log shows this "GnuTLS error: No or insufficient priorities were set."

EDIT: I've been able to at least work around this issue. I've made a separate prefix and tried to run it with Proton (just to see, what happens) and it worked. Through Winetricks I downloaded dotnet45 and gdiplus dlls. And that broke it (was getting those gnutls errors). I tried it with just gdiplus dll and it worked. Later I've made new prefix just to clean up mess that I created by trying different stuff. Tried to run it with regular Wine and it works. TLDR: dotnet45 was an issue for me. Deleted it and it was fine.
Note: I did everything in Lutris.
marshallracer
ok, dotnet breaking something does not really surprise me .. but it killing networking is definitely weird and should not happen. Even more confusing as how you got it to run withouut it since osu relies on at least dotnet40 but it could very well be there's something borked in that very specific setup with 45. Maybe I'll give it a shot in a vm to see what happens.
EmoBlitz

RoARene317 wrote:

Since osu! is for Windows and Mac version, the linux version isn't available right now. But for me after a long journey in linux, finally I get the working osu! on linux.

1. Install Lutris (since they already provided the script and do it for you)
Ubuntu user (Ubuntu based OS):

sudo add-apt-repository ppa:lutris-team/lutris
sudo apt-get update
sudo apt-get install lutris

Arch Linux (Arch Linux Based OS):
sudo pamac -S lutris

For other distro can refer to this guide : https://lutris.net/downloads/

2. search osu! and click search lutris.net

3. Click install and go to the Windows Version

4. Just wait this will install:
Microsoft .Net Framework 4.0
Microsoft .Net Framework 4.5
GDI Plus (For Graphical Fixes)
CJK Font
Wine Staging Version
If you get a lot of fixme:error blah blah blah , it's normal as long you don't get fatal error. This process takes along time about 30 minutes so be patient.

5. osu! Installed


Low latency osu! (Thanks PooN)
1. Download the custom audio driver (Download the both)
https://blog.thepoon.fr/assets/articles/2018-06-16-osuLinuxAudioLatency/32bit/winepulse.drv.so (32bit)
https://blog.thepoon.fr/assets/articles/2018-06-16-osuLinuxAudioLatency/64bit/winepulse.drv.so (64bit)

2. Type on terminal :
[file browser apps] /home/[username]/.local/share/lutris/wine/tkg-osu-4.6-x86_64
Replace file browser apps with your own depending on your operating system: Arch = Dolphin Ubuntu = Nautilus

Replace username with your own username


3. Paste the file 32 bit to the lib folder and the 64 bit to the lib64 folder

4. Type on terminal : sudo nano /etc/security/limits.conf

edit and paste this command

echo "@[username] - nice -20
@[username] - rtprio 99" >> /etc/security/limits.conf

Repalce username with your own username

5. Save by Ctrl+X
6. Copy paste this command to terminal
mkdir -p /etc/pulse/daemon.conf.d/
echo "high-priority = yes
nice-level = -15

realtime-scheduling = yes
realtime-priority = 50

resample-method = speex-float-0

default-fragments = 2 # Minimum is 2
default-fragment-size-msec = 2 # You can set this to 1, but that will break OBS audio capture." | sudo tee -a /etc/pulse/daemon.conf.d/10-better-latency.conf

7. Type sudo nano /etc/pulse/default.pa
Find the line that include this command:
load-module module-udev-detect

add tsched=1

save it

8. Back To Lutris and configure osu --> Game Options --> change arguments to STAGING_AUDIO_DURATION=10000


Troubleshoot
1. Stuck at looping on installation

It takes a lot of time depending on your CPU, HDD.

2. osu! takes a long time / not boot

Check the task manager if the cpu usage osu.exe higher than 50% it means program is preparing because there is the big change in your osu folder

3. Where is my osu folder
Default /home/[username]/Games/osu

4. Cross on installation = Image cross

install libpng by apt-get install libpng // pacman -S libpng

5. If problem persist kill wine-server
and osu!.exe

That's it :)

RoARene317 wrote:

Since osu! is for Windows and Mac version, the linux version isn't available right now. But for me after a long journey in linux, finally I get the working osu! on linux.

1. Install Lutris (since they already provided the script and do it for you)
Ubuntu user (Ubuntu based OS):

sudo add-apt-repository ppa:lutris-team/lutris
sudo apt-get update
sudo apt-get install lutris

Arch Linux (Arch Linux Based OS):
sudo pamac -S lutris

For other distro can refer to this guide : https://lutris.net/downloads/

2. search osu! and click search lutris.net

3. Click install and go to the Windows Version

4. Just wait this will install:
Microsoft .Net Framework 4.0
Microsoft .Net Framework 4.5
GDI Plus (For Graphical Fixes)
CJK Font
Wine Staging Version
If you get a lot of fixme:error blah blah blah , it's normal as long you don't get fatal error. This process takes along time about 30 minutes so be patient.

5. osu! Installed


Low latency osu! (Thanks PooN)
1. Download the custom audio driver (Download the both)
https://blog.thepoon.fr/assets/articles/2018-06-16-osuLinuxAudioLatency/32bit/winepulse.drv.so (32bit)
https://blog.thepoon.fr/assets/articles/2018-06-16-osuLinuxAudioLatency/64bit/winepulse.drv.so (64bit)

2. Type on terminal :
[file browser apps] /home/[username]/.local/share/lutris/wine/tkg-osu-4.6-x86_64
Replace file browser apps with your own depending on your operating system: Arch = Dolphin Ubuntu = Nautilus

Replace username with your own username


3. Paste the file 32 bit to the lib folder and the 64 bit to the lib64 folder

4. Type on terminal : sudo nano /etc/security/limits.conf

edit and paste this command

echo "@[username] - nice -20
@[username] - rtprio 99" >> /etc/security/limits.conf

Repalce username with your own username

5. Save by Ctrl+X
6. Copy paste this command to terminal
mkdir -p /etc/pulse/daemon.conf.d/
echo "high-priority = yes
nice-level = -15

realtime-scheduling = yes
realtime-priority = 50

resample-method = speex-float-0

default-fragments = 2 # Minimum is 2
default-fragment-size-msec = 2 # You can set this to 1, but that will break OBS audio capture." | sudo tee -a /etc/pulse/daemon.conf.d/10-better-latency.conf

7. Type sudo nano /etc/pulse/default.pa
Find the line that include this command:
load-module module-udev-detect

add tsched=1

save it

8. Back To Lutris and configure osu --> Game Options --> change arguments to STAGING_AUDIO_DURATION=10000


Troubleshoot
1. Stuck at looping on installation

It takes a lot of time depending on your CPU, HDD.

2. osu! takes a long time / not boot

Check the task manager if the cpu usage osu.exe higher than 50% it means program is preparing because there is the big change in your osu folder

3. Where is my osu folder
Default /home/[username]/Games/osu

4. Cross on installation = Image cross

install libpng by apt-get install libpng // pacman -S libpng

5. If problem persist kill wine-server
and osu!.exe

That's it :)
everybody gangster until you cant get beatmaps to work
Mortis219
sudo mkdir -p /etc/pulse/daemon.conf.d/
PerFect!
ThachAnhHoang
Alright, I have a bit of a note. For those using Fedora and wants to play osu!, you shouldn't update to Fedora 33. Why? The post-install screen doesn't update and keeps showing the "Please check your internet connection" message. Therefore, I suggest that you stay at 32 (but preferably not something before 30) cuz that would be quite old already. Side note, idk if NVIDIA has solved its problems with its drivers on kernel 5.9 yet.
BilalMirza1000
when i run osu! my pc logs out of my account and when i get back in linux everythings closed how do i fix this
ThachAnhHoang
You do realize you cannot have 2 computers with osu! on simultaneously with just 1 account?
battleof3
tsched=1 is incorrect btw, supposed to be tsched=0. We want the interrupt scheduler so our staging duration and pulsewine patches are able to work properly.
Doxxz
Sorry for necro but, did anyone have problems running fcitx? The ctrl + space toggle doesn't work. Can't seem to find how to solve it.
den4k4554
how can i install osu on solus budgie 4.1?
TakayaHQ
F to pay respect
bambinex
Ok so I have a big problem. Everything is installed correctly but whe I lauche the game via Lutris I get the message error 'NoneType' object has no attribute "lower". I can't launch the game help me

Edit: ok I managed to fix error but, why do the game crash after finishing a game ?
Hisakawa
Manjaro user here. Tried OP, works perfectly fine. In order to turn off my mouse acceleration I used the guide from the arch wiki, the one with libinput:


Alternatively, since libinput-1.1.0-1 and xf86-input-libinput-0.15.0-1 you can use a flat acceleration profile. To enable it create the following file:

/etc/X11/xorg.conf.d/50-mouse-acceleration.conf

Section "InputClass"
Identifier "My Mouse"
Driver "libinput"
MatchIsPointer "yes"
Option "AccelProfile" "flat"
Option "AccelSpeed" "0"
EndSection
Jupilian
destroyed my linux mint sound after a restart, I needed to undo manually everything
marshallracer

Jupilian wrote:

destroyed my linux mint sound after a restart, I needed to undo manually everything
This is why PooN's low latency stuff should not be just used as is because it is prone to breaking entire system audio

Recent wine(-staging) versions (from 5.7 onwards) have greatly improved latency over the outdated osu-specific wine packages provided by either PooN or Lutris scripts. For some these may still work but require a lot of effort for very little gain compared to leaving everything at default with recent wine version.

This guide still works perfectly (and is pinned for a reason) and alternatively there's an install script I have on my github that is very much based and said pinned guide
Please sign in to reply.

New reply