[Archived] I can't download any map, it says they are corrupted

posted
Total Posts
23
show more
Topic Starter
Shiroi Lelouch
https://drive.google.com/file/d/1TwFb9F9TNTWinmATcGFK8TNYzsEvwZUQ/view?usp=sharing
https://drive.google.com/file/d/1hs4K1U6Mo5dqB3z7GZyYpVCnb0JHrIGR/view?usp=sharing
And yes i tried the F5 thing and still doesn't work
Death
I thought you said updating was not working? If that's the case you should have a file just called "update.log" and not "update_success.log".
Topic Starter
Shiroi Lelouch
No no, the update worked after some days, i just said that before this error popping up with the beatmaps not loading, it didn't connect to the internet for some odd reason i do not know,i only have the 2 logs i sent you
Death
Ok, a few things here.

Do you have any antivirus software installed that could be preventing the game from importing these maps correctly? Please check to make sure this isn't the case.

Are you running osu! as an administrator? If not, does it work if you do?

Check to see whether or not you have FIPS enabled. If it is enabled, try disabling it. This seems to be a common cause of beatmaps not importing correctly for whatever reason. It also causes the updater to fail too sometimes (not sure how yours would have randomly started working again though). This also usually shows in your runtime.log, which yours didn't, but it won't hurt to check.

To do this, go to Control Panel > Network and Sharing Center > Click on the item listed in connections > Click on the first properties button > Security Tab > Advanced Settings > and uncheck the box in that window, it should say "Enable Federal Processing Standards (FIPS) compliance for this network"

Also go to: Control Panel > Administrative Tools > Local Security Policy > Expand Computer Configuration > Windows Settings > Security Settings > click Security Options > Look for "System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing" and double click on it, hit disable, and apply.

You can also probably google something like "Disable FIPS Mode" to find more detailed versions of what I just wrote. This happened to be the first link that came up when I Googled that and there is a more detailed section on how to make sure it is disabled at the bottom. I also found this, which could be helpful.
Topic Starter
Shiroi Lelouch
It isn't the anti-virus
Yes i am running it as an administrator
I tried the FIPS thing and it was disabled
Death
Try holding shift while starting the game until a configuration window pops up, the hit the "repair osu!" button.
Topic Starter
Shiroi Lelouch
Didn't work either, is it possible it is cause of my windows?
Death
Can you try hitting the "repair folder permissions" button in osu!'s settings? You may or may not also need to be running as an administrator for this to work properly (not entirely sure), so if you aren't still doing so, please do.

Do you have some specific reason to suspect it might be because of your Windows install?

How are you importing beatmaps right now? Are you just clicking on the downloads, are you dragging the file into your osu! window, or are you putting the maps into your songs folder manually?
Topic Starter
Shiroi Lelouch
I tried the ''repair folder permissions'' and still not working, even with as administrator, well because my windows is kinda old and i haven't updated it or made a new one so my pc would run faster in years, so that might be one of the reasons, and right now i go to osu!search and get maps from there, rename them to .zip and extract them manually into the ''Songs'' folder, right now i got all ctb ranked and loved maps and planning to get some unranked and converts too, i mean it's not that bad of a thing it's just too frustrating to deal with
Death
What I mean by "right now" is, which methods have you tried to import your maps that don't work? There are three ways to do it without doing what you are doing right now. Clicking on the downloaded file, dragging them into the window, and placing them directly into your songs folder (without extracting anything) and then hitting F5 on the beatmap selection screen.
Topic Starter
Shiroi Lelouch
I tried that and it doesn't work, idk of the other option to import maps, but the one i'm using right now seems to work idk why
Death
I mentioned 3 ways of importing maps, does that mean none of them work? Really not sure what your last reply means.
Topic Starter
Shiroi Lelouch
Clicking on the downloaded file -> doesn't work
''dragging them into the window'' -> doesn't work
And placing them directly into my Songs folder (without extracting anything) and then hitting F5 -> doesn't work
Death
Just curious... if you download the installer again from https://osu.ppy.sh/home/download, then install the game to a separate location on your computer (you'll have 2 different osu! installations), run the new installation and then try dragging osz files into the game, does that work?
Topic Starter
Shiroi Lelouch
Nope
Death
What location did you install the new version of the game to and where is your original install located? I'm pretty convinced something on your computer is preventing the game from extracting files, which is what it does with osz files.
Topic Starter
Shiroi Lelouch
I've always had it installed in D: -> Osu! since i started playing it, but when i have to install it, it always goes for C: -> Users -> Revi *that's my folder called* ->AppData -> Local -> osu!
But it's nothing in there, neither in localLow and Roaming
Radiohead
your osu! might be corrupted
Death

Hirai Momo wrote:

I've always had it installed in D: -> Osu! since i started playing it, but when i have to install it, it always goes for C: -> Users -> Revi *that's my folder called* ->AppData -> Local -> osu!
But it's nothing in there, neither in localLow and Roaming
By default the game should install in AppData unless you change it, so are you saying the new version of the game that I asked you to install didn't install there? And does that mean when I asked you to run the new installation, you didn't actually run a new installation?
Topic Starter
Shiroi Lelouch
I did run the new installation as you said, it did install there, what i mean is that it didn't work there either, i change the location because i don't have enough space for osu maps, but that can't be the problem since i've always installed it in D: not in C:
Please sign in to reply.

New reply