1. osu! forums
  2. osu!
  3. Skinning
posted
Hello, noob question for you guys.

I never tried to edit a skin before and I'm trying to import the custom colors used in this map
https://osu.ppy.sh/beatmapsets/524966#osu/1114132
onto my skin ( https://www.mediafire.com/file/7rignguruq9ho54/PKEdit.osk/file ).

I thought it would be easy as editing the skin.ini and editing the colors according to the values I can find in the "song setup"->Colours section when editing the map. But it turns out that those values are straight ignored by the skin.

I double checked I don't have the "ignore beatmap for this file" option checked. So is there something else I could be missing?

Thanks for reading
posted
If you want to use your own skin colors (on every map) you need to toggle this option:



If by any chance it doesn't work, start the map -> drag your cursor to the bottom of the screen (during the start of the play) and check whether or not this option is toggled:

posted
Lee, that's not what he's looking for.

Edit -> Pick the map -> File -> Open .osu in Notepad -> Find [Colours]
rest of the procedure should be obvious
posted
h3oCharles, if you additionally would have downloaded the skin to check whether or not the [Colours] tab had the correct values, you'd realize that what you said isn't the issue.

Beatmap colours


Skin colours


As they match, the underlying issue has to be something else. If by any chance this is wrong I'd need more information from the issuer.
posted
Sorry I don't know what happened but I tried again this morning to edit the skin.ini.
This time by copy pasting directly from the .osu file instead of rewriting them from the song setup color picker .... And it worked .... I don't know what went wrong the first time. Maybe it was the fact that I had two copies of the PKEdit theme in my skin folder and I didn't bother to change the "Name" line in the skin.ini file the first time... I have no clues

Point is, it's working. Thank you guys.
Please sign in to reply.