1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
Hello, so i updated my OS to windows 10 and bought a brand new pc, and i just installed osu! but its instantly crashes EVERY TIMEs...

video about the problem: https://youtu.be/CfqoJWrL02Q ( its says: osu! has stopped working )
(ignore the black bars)
Follow this guide to get the crash log from your event viewer and post it here.
+ System

- Provider

[ Name] .NET Runtime

- EventID 1026

[ Qualifiers] 0

Level 2

Task 0

Keywords 0x80000000000000

- TimeCreated

[ SystemTime] 2018-08-04T22:58:52.275364600Z

EventRecordID 2866

Channel Application

Computer DESKTOP-899TDUB


- EventData

Alkalmazás: osu!.exe Keretrendszer verziószáma: v4.0.30319 Leírás: A folyamat egy nem kezelt kivétel miatt meg lett szakítva. Kivétel adatai: System.AccessViolationException a következő helyen: OpenTK.Platform.Windows.Functions.DescribePixelFormat(IntPtr, Int32, Int32, OpenTK.Platform.Windows.PixelFormatDescriptor ByRef) a következő helyen: OpenTK.Platform.Windows.WinGraphicsMode.ChoosePixelFormatPFD(IntPtr, OpenTK.Graphics.GraphicsMode, AccelerationType) a következő helyen: OpenTK.Platform.Windows.WinGraphicsMode.SelectGraphicsMode(OpenTK.Graphics.ColorFormat, Int32, Int32, Int32, OpenTK.Graphics.ColorFormat, Int32, Boolean) a következő helyen: OpenTK.Platform.Windows.WinGLContext.SetGraphicsModePFD(OpenTK.Platform.Windows.WinGraphicsMode, OpenTK.Graphics.GraphicsMode, OpenTK.Platform.Windows.WinWindowInfo) a következő helyen: OpenTK.Platform.Windows.WinGLContext+TemporaryContext..ctor(OpenTK.INativeWindow) a következő helyen: OpenTK.Platform.Windows.WinGLContext..ctor(OpenTK.Graphics.GraphicsMode, OpenTK.Platform.Windows.WinWindowInfo, OpenTK.Graphics.IGraphicsContext, Int32, Int32, OpenTK.Graphics.GraphicsContextFlags) a következő helyen: OpenTK.Platform.Windows.WinFactory.CreateGLContext(OpenTK.Graphics.GraphicsMode, OpenTK.Platform.IWindowInfo, OpenTK.Graphics.IGraphicsContext, Boolean, Int32, Int32, OpenTK.Graphics.GraphicsContextFlags) a következő helyen: OpenTK.Graphics.GraphicsContext..ctor(OpenTK.Graphics.GraphicsMode, OpenTK.Platform.IWindowInfo, OpenTK.Graphics.IGraphicsContext, Int32, Int32, OpenTK.Graphics.GraphicsContextFlags) a következő helyen: #=z0ziB7SDrv_pFBHyhQN9m0EpL4lCs.#=zKj7T6U8=(Int32, Int32, OpenTK.Graphics.GraphicsContextFlags) a következő helyen: #=zVmYOXSMOwJMVKeQQXYMuHhI=.#=zjZBZCeUr0qO_(OpenTK.Graphics.GraphicsContextFlags) a következő helyen: #=zVmYOXSMOwJMVKeQQXYMuHhI=.OnHandleCreated(System.EventArgs) a következő helyen: #=zozFUrtS9rSRu$XCTUgTuMKGmbylb.OnHandleCreated(System.EventArgs) a következő helyen: System.Windows.Forms.Control.WmCreate(System.Windows.Forms.Message ByRef) a következő helyen: System.Windows.Forms.Control.WndProc(System.Windows.Forms.Message ByRef) a következő helyen: System.Windows.Forms.ScrollableControl.WndProc(System.Windows.Forms.Message ByRef) a következő helyen: System.Windows.Forms.Form.WmCreate(System.Windows.Forms.Message ByRef) a következő helyen: System.Windows.Forms.Form.WndProc(System.Windows.Forms.Message ByRef) a következő helyen: #=zdu1Cgb89XHfgZAgcEmHbWdg=.WndProc(System.Windows.Forms.Message ByRef) a következő helyen: System.Windows.Forms.Control+ControlNativeWindow.OnMessage(System.Windows.Forms.Message ByRef) a következő helyen: System.Windows.Forms.Control+ControlNativeWindow.WndProc(System.Windows.Forms.Message ByRef) a következő helyen: System.Windows.Forms.NativeWindow.Callback(IntPtr, Int32, IntPtr, IntPtr)

uhm i did it good or no? xd
Yes, that is what I was looking for. What GPU do you have?

First, have you tried restarting your computer yet? Also, make sure you are using 32bit color depth and not anything else.
i have a rx 560 gpu and yes, i tried to restart my computer... and yes, im using 32bit color depth
Uninstall whatever graphics drivers you currently have installed using Display Driver Uninstaller and remove any other Radeon Software on your computer, then reinstall the newest drivers for your card from AMD's Website.
I did everything, but nothing happened... i still have the same problem.

lawlXD wrote:

I did everything, but nothing happened... i still have the same problem.
Have you tried running Osu! as admin?
yes i tried... but i still have the same problem

Edit: i solved the problem.. the problem was i had an older version of w10, i updated everything now, and its good.. ty for the help btw !
Please sign in to reply.