1. osu! forums
  2. osu!
  3. Help
posted
I got an Acer Aspire E 15, it has MX150 graphics, which are the slightly improved version of the GTX 1030s. I know the thing isn't a beast machine, but it should be way more than enough. In task manager, it shows a max of 60% GPU usage, and like 20% CPU. So it makes no sense the game should be stuttering. Also, another problem is that, while the framelock is off, and it goes above 60 in the menu, when I get into an actual game, it decides to shit the bed and go into 60FPS locked with an unplayable 17ms response time. Very frustrating, any help is much appreciated. (It was taking 100% GPU earlier and not letting me into the game window a bit ago, but it seems to not anymore, so whatever to that, maybe it's relevant.)
posted
A lot of users have this problem recently and we are still discussing why this is happening. Feel free to join the discussions here
posted
damn i missed the pin, i'm blind lol, but the stuttering is only one of my problems.
posted
Yeah, you can check the pinned sub-forum first
posted
As for the game locking to 60fps, make sure Vsync or Gsync is off in your Nvidia control panel and ingame.

Also might be worth to make sure of these things;
Make sure your Nvidia power management settings are set to performance, and the Windows power setting is also set to high performance.

Make sure "Fullscreen optimizations" is disabled in the osu!.exe properties.
posted
I know the vsync is off in the control panel because it would be on in the menu, but I checked just to be sure. And I do have it set as off in game (as is noticeable by the FPS counter in the bottom corner when I'm in the menus.) After everything you said, the problem is still persistent :( on the bright side, the input lag went down to about 8.5ms, and the stuttering seems to be reduced, but I think it's a coincidence.
EDIT: ok so I was wrong, pretty much any setting except for maximum graphics performance and prefer my dedicated graphics card is problematic. With those set, it runs good, save for the stupid forced vsync. But those settings are really taxing on power, so is there some alternative to switching it on and off when playing (big pain in the ass)
posted
im still stuck with the forced vsync. it ONLY happens while im actually playing a beatmap
posted

louisevaliere wrote:

im still stuck with the forced vsync. it ONLY happens while im actually playing a beatmap
Make sure it's not showing 60hz and not 60fps. What is your MS when playing?
posted

Dntm8kmeeatu wrote:

Make sure it's not showing 60hz and not 60fps. What is your MS when playing?
it's about 17ms. Indicative of vsync. Make sure it's not showing either? Well I'm pretty sure it's always 60hz. And I'm pretty sure while playing a map it's always 60fps. At least that's what it says in the bottom right and what it looks like.
posted
But you have no issues when you use Max Performance mode?

If so that's just what you'll have to use.
posted
No? that doesn't change anything except for the stuttering.
posted
I'm losing track of what your issue is in these walls of text, mind re-explaining what the issue is, and what the difference between using Max performance and not is?
posted
So with max performance on (the windows power setting), it does not stutter, it stays a smooth 60fps. Anything below that and it does, with heavy dips in performance. Basically nothing to be concerned about. But regardless, the instant I go into actually playing a beatmap, the frame limit in the bottom right drops from 240 to 60hz. Now I notice this happens on my desktop as well, but without vsync being enabled or massive input lag. I'm pretty sure that vsync is still happening in the laptop from how there isn't screen tearing at all. but vsync is disabled in osu and in NVIDIA control panel. Also I have tried osu compatibility mode with no effect other than slightly increased input lag.
posted
The game switching from 240fps to 60hz is normal, as your screen refresh rate is 60hz. So with max performance on, does the game run at 17ms or something else?

Are you running proper Fullscreen and not Borderless?

What about the power management / performance setting in your Nvidia drivers? I know Nvidia have a Power Saving / Prefer Max Performance option as well
posted
Yep, it's in fullscreen. And yes, it still runs 17ms or so. And yeah I also have it on High performance mode in the NVIDIA settings. What that does is it makes it use the dedicated graphics. If I used the integrated graphics, it would get like 15fps and 40ms response time lmao. Right now it's at 8.3ms, but it doesn't go up when I enable vsync, so it has to be vsync and not just shitty components. Fullscreen optimizations are also disabled with no affect.
Please sign in to reply.