1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Hi, since the new Windows 10 update, whenever I launch the game, I get the welcome logo, then, osu! just kind of freezes up for 10 seconds before showing me the menu.

If my mouse leaves the screen, say, I go to discord, then click back, I again have to wait 10 seconds or so for osu! to become responsive.

I play in full screen mode at 1920x1080. I have a dual monitor set up so normally have osu! on the left and discord on the right.

This did not happen prior to the latest windows 10 update. Anything I could try to remedy this?
posted
This should fix it:
Windows key--->Configuration(the gear)--->System--->Focus Assist--->DISABLE everything!
posted
If the above doesn't work, you can also try disabling discord overlay or the geforce experience in-game overlay as well.

Another option could also be disabling the ms-gamingoverlay from settings on Windows 10 in the Games section.
posted
Discord overlay has always been causing issue with osu, and I've disabled it since.
For some reason discord overlay turn itself back on today and I started having issues again, opening up osu and it immediately freezes.
Went and disabled it, and everything is A-OK.
posted
Yup, it happens that after updating Discord the option gets enabled again, so always check that out whenever there's a new version installed.
posted

Doge Owner wrote:

This should fix it:
Windows key--->Configuration(the gear)--->System--->Focus Assist--->DISABLE everything!
Thank you so much! This fixed it!

I did also have to disable the discord overlay again.
Please sign in to reply.