1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
show more
posted

Andrea wrote:

Have you also tried lowering the frame limiter of osu!? Using unlimited sometimes isn't the best choice.

Also, play in fullscreen and not windowed mode, as that may give you additional lags.
Yeah i'm playing fullscreen, tried locking fps to 240 and at least now it doesn't seem to give me random frame drops, but still i feel like i should be able to get way more fps...

Sinsinchi wrote:

I've had this exact problem before. It solely deals with the capabilities of the laptop. Osu isn't a particularly tasking program to run but it can still lag of course. If closing all unused applications doesn't reduce the lag then the only other thing I can really think of is dedicating more of your memory to ram.
closing all other apps doesn't have any effect, i have 8gb of ram though, it should be more than enough to get way more fps than this, no?

For example, my sister's laptop is a lot weaker than mine and she only gets ~1.5ms. Though her laptop has an amd graphics card, so I think the problem has something to do with nvidia.
posted
I have the same problem with u. I am using a laptop with 1050ti but only get 500fps. Still thinking how to fix it!
posted
Have you also tried disabling nvidia geforce experience or discord overlay in-game? That can also cause some fps issues.
posted

Andrea wrote:

Have you also tried disabling nvidia geforce experience or discord overlay in-game? That can also cause some fps issues.
no change

Oh well, at least all these performance problems over the last 2 years cured my osu addiction...
posted
i have the exact same problem but with a 960m cant go above 380 fps i tried EVERYTHING that is on the internet still have the problem
posted
Odd.. a 9300M GS can get around 60-90.
posted
BUMP
posted
can you link to where you got the laptop? try removing any intel drivers if you have them
posted

Toxi wrote:

can you link to where you got the laptop? try removing any intel drivers if you have them
I got it in a store here in Portugal, i tried that too before but there were some problems because the screen used the intel graphics card or something
posted

Ari0n wrote:

Toxi wrote:

can you link to where you got the laptop? try removing any intel drivers if you have them
I got it in a store here in Portugal, i tried that too before but there were some problems because the screen used the intel graphics card or something
If the screen is using the intel graphics card then the game is running on that. Uninstall all intel graphics drivers, and get the ones from here: http://www.nvidia.com/download/driverResults.aspx/136675/en-us
posted
In my personal opinion, you should not focus on frames per second - but rather on your screen's refresh rate. The real frames per second you see are those your gear can show you, not render. Set frame limiter to exact ammount as your display allows and try to run it. Unnecesarily big ammount of fps may lead the display to simply ignore the frames it cant process. Such mismatch may lead to lost frames in big ammounts.
posted

Toxi wrote:

If the screen is using the intel graphics card then the game is running on that. Uninstall all intel graphics drivers, and get the ones from here: http://www.nvidia.com/download/driverRe ... 6675/en-us
Disabling the intel drivers did give me more fps, but i couldn't have access to the nvidia control panel anymore because it said there was no monitor connected to a nvidia gpu. I think this has something to do with windows 10 and optimus, which chooses the graphics card more appropriate for each situation. I guess it doesn't recognize osu as a program worthy of using the nvidia card... The best solution i saw to this problem is switching to windows 7, but i'm not doing that...
posted

Hypixus wrote:

In my personal opinion, you should not focus on frames per second - but rather on your screen's refresh rate. The real frames per second you see are those your gear can show you, not render. Set frame limiter to exact ammount as your display allows and try to run it. Unnecesarily big ammount of fps may lead the display to simply ignore the frames it cant process. Such mismatch may lead to lost frames in big ammounts.
While in most games this works, if they set their FPS to their refresh rate, they will more than likely be locked at 60fps, which is ~16ms in frame times. That 16ms isnt a problem in most games, but Osu however benefits in having lower frame times. Lower frame times mean that the cursor updates more frequently.



Ari0n wrote:

Toxi wrote:

If the screen is using the intel graphics card then the game is running on that. Uninstall all intel graphics drivers, and get the ones from here: http://www.nvidia.com/download/driverResults.aspx/136675/en-us


Disabling the intel drivers did give me more fps, but i couldn't have access to the nvidia control panel anymore because it said there was no monitor connected to a nvidia gpu. I think this has something to do with windows 10 and optimus, which chooses the graphics card more appropriate for each situation. I guess it doesn't recognize osu as a program worthy of using the nvidia card... The best solution i saw to this problem is switching to windows 7, but i'm not doing that...
Ok, well i would try going on the Nvidia website and downloading the auto-detector. I may have linked you the incorrect drivers. The auto-detector will get you the right Drivers for your system. If that still fails, I would suggest reinstalling windows. The laptop is new so you shouldnt be loosing much data, but if that is still an issue then you could partition your drive so that one section is for windows and the other is for your data.
posted
Have you tried replacing your drivers and other components of you laptop? Try that.
If it isn't working, try windowed mode. I use it alot.
If none of these work, please PM me on the website, thanks, and have a good day! ;)
posted
Reinstalled windows 10, no change... even updated all drivers before installing osu.
posted
not even sure if it's worth bumping this anymore but let's see...
posted
I'm having the same problem with a laptop with the same specs as yours...
posted
UPDATE: Spoke with both osu support and nvidia support.

Basically osu support told me everything is fine with the game and the problem must come from somewhere else.
So I went and spoke with the nvidia support, tried a lot of things, nothing fixed it, they don't know what's causing it either and told me it should be a problem with the game.

- It could be a problem related to windows 10, but since it only seems to occur on laptops, i guess that's not the answer.
- Other thing i read about is nvidia optimus, the game could have some problems with it, i dunno, and the nvidia support said that if that's the case then the devs should be able to fix it.

I'm honestly tired of this, around 2 years performance problems on osu!, i love this game but i just can't play it anymore.

Devs please there are a lot of people with this problem, at least try to fix it, because it looks like you're not giving a shit.

also, with the newest nvidia driver update (399.07), it decreased even more my fps, i can't even get more than 200 now
posted

Ari0n wrote:

UPDATE: Spoke with both osu support and nvidia support.

Basically osu support told me everything is fine with the game and the problem must come from somewhere else.
So I went and spoke with the nvidia support, tried a lot of things, nothing fixed it, they don't know what's causing it either and told me it should be a problem with the game.

- It could be a problem related to windows 10, but since it only seems to occur on laptops, i guess that's not the answer.
- Other thing i read about is nvidia optimus, the game could have some problems with it, i dunno, and the nvidia support said that if that's the case then the devs should be able to fix it.

I'm honestly tired of this, around 2 years performance problems on osu!, i love this game but i just can't play it anymore.

Devs please there are a lot of people with this problem, at least try to fix it, because it looks like you're not giving a shit.

also, with the newest nvidia driver update (399.07), it decreased even more my fps, i can't even get more than 200 now
Try to install LTSB windows, i have in this lower frametime(my first run was crashed but when i did disable dpi scalling in compatibility settings osu start run), but get the same problem when install last windows, also laptop, and as i know its general problem of new laptops.
Please sign in to reply.