1. osu! forums
  2. osu!
  3. Help
posted
Started these lag spikes about 13 days ago after turning my PC on. Previously windows wanted to update to build 1803 but every time it tried to go through the update procedure, it would just restart the PC mid update and corrupt my windows directory. There is no malware, there is no faulty hardware and I have tried running the update without any drivers but nothing works, it always corrupts my windows copy no matter what.

I'm still on build 1709 but i get the same exact issue everyone else is getting. Which is really strange. Also windows update managed to re-enable itself but without prompting an install for the 1803 build which was REALLY strange to me. It updated many other things except windows. Even after those driver updates, (and ones I performed second hand) I still get the same issue. This issue doesn't just happen on osu either, it happens systemwide at random times.

As ram increases to build up usage, the stutters get worse. So I thought it could be a page file issue but even then it didnt fix it. What minimized the amount of stutter I got was moving osu to my HDD (I have windows on a 120gig SSD) the stutters till happen randomly but the frame times are more consistent. I suspect this is due to the fact that windows processes are not interfering with your game, giving it more consistency.

i7-2600
GTX-1050ti
8GB RAM
120gig SSD
1TB Western Digital Blue

(social security number if requested Kappa)
posted

Dntm8kmeeatu wrote:

Mr_Shiro_ wrote:

well, I noticed that whenever i start playing a map, osu forced the settings to turn on Vsync, so i just turned on Vsync and it seems like that fixed the problem for me. Getting around 0.5 ms and no stuttering.
That's impossible.

Vsync forces your framerate to be that of your refresh rate, so 0.5ms is literally impossible. You are mistaken.
0.9ms, my bad.
https://www.youtube.com/watch?v=1tMF0QTmAwE
The video shows 1.2 ms, but that's because i was recording. The stutters in this were only in the recording, i didn't see it when i was recording.
posted

Mr_Shiro_ wrote:

Dntm8kmeeatu wrote:

Mr_Shiro_ wrote:

well, I noticed that whenever i start playing a map, osu forced the settings to turn on Vsync, so i just turned on Vsync and it seems like that fixed the problem for me. Getting around 0.5 ms and no stuttering.
That's impossible.

Vsync forces your framerate to be that of your refresh rate, so 0.5ms is literally impossible. You are mistaken.
0.9ms, my bad.
https://www.youtube.com/watch?v=1tMF0QTmAwE
The video shows 1.2 ms, but that's because i was recording. The stutters in this were only in the recording, i didn't see it when i was recording.
Vsync is not working, otherwise you would be at 16ms. It's possible it's being overridden by your GPU Driver settings, please check those. You shouldn't be using Vsync anyways though however.
posted

Dntm8kmeeatu wrote:

Mr_Shiro_ wrote:

Dntm8kmeeatu wrote:

Mr_Shiro_ wrote:

well, I noticed that whenever i start playing a map, osu forced the settings to turn on Vsync, so i just turned on Vsync and it seems like that fixed the problem for me. Getting around 0.5 ms and no stuttering.
That's impossible.

Vsync forces your framerate to be that of your refresh rate, so 0.5ms is literally impossible. You are mistaken.
0.9ms, my bad.
https://www.youtube.com/watch?v=1tMF0QTmAwE
The video shows 1.2 ms, but that's because i was recording. The stutters in this were only in the recording, i didn't see it when i was recording.
Vsync is not working, otherwise you would be at 16ms. It's possible it's being overridden by your GPU Driver settings, please check those. You shouldn't be using Vsync anyways though however.
These are my NVIDIA control panel settings:
Ambient Occlusion: Off
Anisotropic filtering: Off
Antialiasing - FXAA: Off
Antialiasing - Gamma correction: On
Antialiasing - Mode: Off
Antialiasing - Setting: None
Antialiasing - Transparency: Off
CUDA - GPUs: All
DSR - Factors: 4.00x (native resolution)
DSR - Smoothness: 33%
Maximum pre-rendered frames: Use the 3D application setting
Multi-Frame Sampled AA (MFAA): Off
OpenGL rendering GPU: Auto-select
Power management mode: Optimal power
Shader Cache: Off
Texture filtering - Anisotropic sample opti...: On
Texture filtering - Negative LOD bias: Allow
Texture filtering - Quality: Quality
Texture filtering - Trilinear optimisation: On
Threaded optimisation: Auto
Triple buffering: Off
Vertical sync: Off
Virtual Reality pre-rendered frames: 1
------------------------------------------
Can someone try to copy these settings and see if it fixes the problem?
EDIT: The problem is fixed for me, btw. Just don't know what fixed it. Sorry
EDIT2: The problem is not fixed, just randomly started stutturing again.
posted
Change Power Management settings to Performance, or something similar (I have AMD so I don't know what NVidia has exactly)
posted
I have constant micro stutters
Compatibility mode and "Reduce dropped frames" reduce the stutters a bit but they're still here, they're not that big but very annoying when playing mania and ctb
I have everything at default in the nvidia control panel
Superfetch doesnt change anything

i5 2500K
8GB ram
GTX 1080

I had the same problem with my old HD 5870
posted
for me, the game is forcing vsync on, because I get 17ms response time. I'm not sure if this problem is related though. (absolutely unplayable. It feels like playing with a mouse underwater lmao) It only ever happens when I start the song. In the menu, the frames aren't limited. The stuttering interval is between like .5 - 5 seconds.
posted
I can confirm that disabling the superfetch service resolved the seemingly random but very heavy stuttering issue on my end :D
posted
I started getting the random stuttering issue around a couple months ago - thought it was strange since I'd never seen it before. It would stutter about every 5 seconds or so, which made it pretty unplayable at that point. One thing I noticed, though, was that even while sitting at any of the menu or song select screens the track that plays in the background would skip the exact same way.

I checked drivers to make sure they were good. I also used Sandra to run some diagnostics and make sure my hardware was consistent. Everything checked out, so I tried closing out other programs and browser tabs (I always have a lot of tabs open for pages or videos to check out later) and that cleared up the stuttering issue for me - mostly. I still get a single stutter here and there while playing, but it's rare - maybe once or twice over a few hours.

It seems strange since I've got pretty good hardware. I may have to try the Superfetch tip if it happens to get really bad again.

i7-4960X 3.6GHz
32 Gb Ram
GTX 1080 Ti
Windows 10 Pro
posted
Pls Help me Osu lag in the menu https://www.youtube.com/watch?v=yxCyHud7_4I


FIX: I Disable Anti-Virus SONAR-Protection
posted
Yo, I've been getting this horrible stuttering in osu that's been making the game unplayable. Here is a video I recorded of my problem: https://www.youtube.com/watch?v=rvWYzUPOlaQ

I have a Radeon RX 480 GPU, Ryzen 1700x CPU and 16bs of DDR4 RAM.
My OS is Windows 10

These stutters have just now been happening to me recently and I don't know what to do to fix them. They seem to happen at random during play. I know it's not a CPU usage thing because even with google chrome or other programs open while playing osu I wouldn't ever stutter like this before, my PC is pretty good so maybe my MS would go from 0.40 ms to 1.7 ms but I'd never lag like this with other programs open. Restarting my computer seems to fix the problem but only for a little bit, about two hours later the stuttering would come back. I've tried reduce frame drops, compatibility mode, vsync and limiting my frame rates and nothing works the only thing that seems to help is restarting my computer and even then the problem only fixes itself for maybe an hour or two. This stuttering problem only happens in osu too, which is really weird if it's an issue with my PC.

If anyone knows how I can fix this please let me know because I just wanna play osu. ;;
posted
Yeah, i just checked again. For me, being connected to the Wi-Fi causes the stutter. I haven't stuttered once when i'm not connected to wi-fi. As soon as i reconnect, i start stuttering again. I don't think it's osu doing this, but more like Windows 10 starts doing something with the internet and just causes the whole computer to stutter, but osu is affected by it the most.
I did a bit of research on this stuttering thing and people get it on other games as well, since the April 2017 update for Windows 10 or something.
posted
Occured stutter after osu! update, anyone knows how can i fix it? or am i stuck with it?
posted
Hi!
I have upgraded my graphic card from 750ti to 1060. After that I have installed the newest nvidia drivers (from 08.01.2018). After all of that I had opened osu and I have noticed that stuttering started to show. I have searched for answer on osu forums and other forums too (antivirus, firewall etc.) Nothing changed.
Here is video that is showing what is exactly going on.
https://www.youtube.com/watch?v=rQMVoqz_i1o&
The thing is I'm looking for some sort of stable frame limiter. That there won't be missing frames like on the video.
Please sign in to reply.