1. osu! forums
  2. osu!
  3. Help
show more
posted
I was experiencing this for a week until someone told me to turn SuperFetch off, the stuttering was very often. This seemed to have fixed it until today, Superfetch is still off yet the stutters have returned. Superfetch seems like a temporary fix atleast?
posted

Exty wrote:

I was experiencing this for a week until someone told me to turn SuperFetch off, the stuttering was very often. This seemed to have fixed it until today, Superfetch is still off yet the stutters have returned. Superfetch seems like a temporary fix atleast?
Try playing with your wifi off.
posted
ive tried everything people have said to do. this has never happened to me only today it started happening.
posted
whats superfetch?
also did you stutter for like a secons when you start a map? (just making sure were talking aboutt the same thing)
posted
If you're stuttering only at the beginning of maps, check your universal offset settings in osu!, when too high/low it can cause that stutter. The issue i believe this thread is about is an issue where the game will constantly stutter throughout playing, and it's like the map/song get rewinded for a second when it does it.

For an update on my previous comment; My driver needed updating which has fixed the issue for me, so I think turning off SuperFetch (and disabling it to stop it from automatically starting again next time you turn the PC on) seems to be a fix, it pre-loads apps that you use often, so if you play osu! everyday it will set it on preload to "load faster", along with any other apps you use alot. Wondering if it can be having a conflict somewhere with the game?
posted

Mr_Shiro_ wrote:

Superfetch randomly downloads/uploads data because windows wants to "Maintain" and "Improve" without you knowing so.
Superfetch preloads files from disk into memory, because it thinks you will soon use them (it can detect for example that you open your mail app every morning, and many other patterns, simple or complex).
So Superfetch only affects disk performance. However it's usually a bad idea to disable it, because you will have to load these files anyway, resulting in delays and disk and memory usage bursts rather than loading things progressively.
Some cases may train it in a wrong way, making it load lots of useless stuff. It may be the case here, considering the enormous amounts of files osu! uses, and the fact they almost change on every use (except if you're always playing the same beatmaps and not scrolling through the list, making it not load other background previews).
I hope that also answer your question, zharga_Lolz.

The services mainly involved in downloading for "improvement" are BITS (Background Intelligent Transfer Service) and Delivery Optimization.

By the way CPU interrupts often have close to no effects (but sometime do) on CPU performance. Rather than using a network sniffer (there is too much noise, a newcomer can't find anything with that), look in "Processes" tab of your Task Manager for the line "System Interrupts". If it's under about 5%, it's certainly not the cause of lags.
posted

zharga_Lolz wrote:

whats superfetch?
also did you stutter for like a secons when you start a map? (just making sure were talking aboutt the same thing)
For me this issue starting occurring when I launched osu! today, the first song I played I noticed the map stuttered. (I did not change any settings from when I played the night before, when it was running fine)

Secondly I noticed the rest of the song is noticeably out of beat, and remains that way. Even when watching a replay, the song stays out of beat with the map. (tested many ranked maps, the issue occurs consistently)
posted

Zoochie wrote:

zharga_Lolz wrote:

whats superfetch?
also did you stutter for like a secons when you start a map? (just making sure were talking aboutt the same thing)
For me this issue starting occurring when I launched osu! today, the first song I played I noticed the map stuttered. (I did not change any settings from when I played the night before, when it was running fine)

Secondly I noticed the rest of the song is noticeably out of beat, and remains that way. Even when watching a replay, the song stays out of beat with the map. (tested many ranked maps, the issue occurs consistently)
Your universal offset is wrong, Set it to 0 in the options menu. This is not the same issue.
posted
I have tried several fixes. Disabling superfetch reduced the amount of stutters but the I still had the game stutter once or twice in a map. Repairing the game did nothing. Turning off shader cache did nothing and removing osu!.db from the osu folder and restarting the game did hardly anything (some times making it worse)
posted
I'm having heavy performance issues on my PC after Windows update (from Fall Creator's to April Update) which is not present from the previous build. And I can't help it bear the lag when I click outside from my fullscreen osu! monitor to my second monitor which it takes 2-3 seconds according to the FPS counter. It also stutter when I was playing yesterday 2 times in a row with the 2-3 second lag. And, doing some software changes like SuperFetch didn't do anything because my PC is fast.

Specs:
i5-6400
GTX 1060 6GB
8GB DDR4 RAM

posted
well, I noticed that whenever i start playing a map, osu forced the settings to turn on Vsync, so i just turned on Vsync and it seems like that fixed the problem for me. Getting around 0.5 ms and no stuttering.
posted

Mr_Shiro_ wrote:

well, I noticed that whenever i start playing a map, osu forced the settings to turn on Vsync, so i just turned on Vsync and it seems like that fixed the problem for me. Getting around 0.5 ms and no stuttering.
That's impossible.

Vsync forces your framerate to be that of your refresh rate, so 0.5ms is literally impossible. You are mistaken.
posted
Started these lag spikes about 13 days ago after turning my PC on. Previously windows wanted to update to build 1803 but every time it tried to go through the update procedure, it would just restart the PC mid update and corrupt my windows directory. There is no malware, there is no faulty hardware and I have tried running the update without any drivers but nothing works, it always corrupts my windows copy no matter what.

I'm still on build 1709 but i get the same exact issue everyone else is getting. Which is really strange. Also windows update managed to re-enable itself but without prompting an install for the 1803 build which was REALLY strange to me. It updated many other things except windows. Even after those driver updates, (and ones I performed second hand) I still get the same issue. This issue doesn't just happen on osu either, it happens systemwide at random times.

As ram increases to build up usage, the stutters get worse. So I thought it could be a page file issue but even then it didnt fix it. What minimized the amount of stutter I got was moving osu to my HDD (I have windows on a 120gig SSD) the stutters till happen randomly but the frame times are more consistent. I suspect this is due to the fact that windows processes are not interfering with your game, giving it more consistency.

i7-2600
GTX-1050ti
8GB RAM
120gig SSD
1TB Western Digital Blue

(social security number if requested Kappa)
posted

Dntm8kmeeatu wrote:

Mr_Shiro_ wrote:

well, I noticed that whenever i start playing a map, osu forced the settings to turn on Vsync, so i just turned on Vsync and it seems like that fixed the problem for me. Getting around 0.5 ms and no stuttering.
That's impossible.

Vsync forces your framerate to be that of your refresh rate, so 0.5ms is literally impossible. You are mistaken.
0.9ms, my bad.
https://www.youtube.com/watch?v=1tMF0QTmAwE
The video shows 1.2 ms, but that's because i was recording. The stutters in this were only in the recording, i didn't see it when i was recording.
posted

Mr_Shiro_ wrote:

Dntm8kmeeatu wrote:

Mr_Shiro_ wrote:

well, I noticed that whenever i start playing a map, osu forced the settings to turn on Vsync, so i just turned on Vsync and it seems like that fixed the problem for me. Getting around 0.5 ms and no stuttering.
That's impossible.

Vsync forces your framerate to be that of your refresh rate, so 0.5ms is literally impossible. You are mistaken.
0.9ms, my bad.
https://www.youtube.com/watch?v=1tMF0QTmAwE
The video shows 1.2 ms, but that's because i was recording. The stutters in this were only in the recording, i didn't see it when i was recording.
Vsync is not working, otherwise you would be at 16ms. It's possible it's being overridden by your GPU Driver settings, please check those. You shouldn't be using Vsync anyways though however.
posted

Dntm8kmeeatu wrote:

Mr_Shiro_ wrote:

Dntm8kmeeatu wrote:

Mr_Shiro_ wrote:

well, I noticed that whenever i start playing a map, osu forced the settings to turn on Vsync, so i just turned on Vsync and it seems like that fixed the problem for me. Getting around 0.5 ms and no stuttering.
That's impossible.

Vsync forces your framerate to be that of your refresh rate, so 0.5ms is literally impossible. You are mistaken.
0.9ms, my bad.
https://www.youtube.com/watch?v=1tMF0QTmAwE
The video shows 1.2 ms, but that's because i was recording. The stutters in this were only in the recording, i didn't see it when i was recording.
Vsync is not working, otherwise you would be at 16ms. It's possible it's being overridden by your GPU Driver settings, please check those. You shouldn't be using Vsync anyways though however.
These are my NVIDIA control panel settings:
Ambient Occlusion: Off
Anisotropic filtering: Off
Antialiasing - FXAA: Off
Antialiasing - Gamma correction: On
Antialiasing - Mode: Off
Antialiasing - Setting: None
Antialiasing - Transparency: Off
CUDA - GPUs: All
DSR - Factors: 4.00x (native resolution)
DSR - Smoothness: 33%
Maximum pre-rendered frames: Use the 3D application setting
Multi-Frame Sampled AA (MFAA): Off
OpenGL rendering GPU: Auto-select
Power management mode: Optimal power
Shader Cache: Off
Texture filtering - Anisotropic sample opti...: On
Texture filtering - Negative LOD bias: Allow
Texture filtering - Quality: Quality
Texture filtering - Trilinear optimisation: On
Threaded optimisation: Auto
Triple buffering: Off
Vertical sync: Off
Virtual Reality pre-rendered frames: 1
------------------------------------------
Can someone try to copy these settings and see if it fixes the problem?
EDIT: The problem is fixed for me, btw. Just don't know what fixed it. Sorry
EDIT2: The problem is not fixed, just randomly started stutturing again.
posted
Change Power Management settings to Performance, or something similar (I have AMD so I don't know what NVidia has exactly)
posted
I have constant micro stutters
Compatibility mode and "Reduce dropped frames" reduce the stutters a bit but they're still here, they're not that big but very annoying when playing mania and ctb
I have everything at default in the nvidia control panel
Superfetch doesnt change anything

i5 2500K
8GB ram
GTX 1080

I had the same problem with my old HD 5870
posted
for me, the game is forcing vsync on, because I get 17ms response time. I'm not sure if this problem is related though. (absolutely unplayable. It feels like playing with a mouse underwater lmao) It only ever happens when I start the song. In the menu, the frames aren't limited. The stuttering interval is between like .5 - 5 seconds.
posted
I can confirm that disabling the superfetch service resolved the seemingly random but very heavy stuttering issue on my end :D
show more
Please sign in to reply.