1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
I've recently came back from a trip and after that my OSU doesn't seem to be able to connect to the bancho nor is my browser able to connect to the OSU website. However my phone seems to be able to connect fine with the WiFi my computer uses. I've used the technique in the forum here (https://osu.ppy.sh/community/forums/topics/647666) and tried turning my firewall off and even using my mobile hotspot but still it's unable to load on my computer. By loading it on browser it would simply come up as (OSU.ppy.sh closed connection or took too long to respond) while the game won't connect me to bancho and OSU!repair asks to check connection. OSU has worked fine before my trip and the problem has only recently occured now, noted was after a Windows update. Is there any way to fix this problem?
posted
then how did you make this post?
posted
Make sure your computer's time is set correctly.

Flush DNS, release/renew IPConfig, and restart your modem/router.
Please sign in to reply.