1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
just reinstalled windows 10 on my pc, and somehow osu! refuses to start. after installing, the osu! logo shows up followed by a windows error message right away. no matter what I do, compatability mode, run as admin didnt work. I even reinstalled windows 10 again but the issue persists.

I also noticed the game didnt get downloaded completely, my osu! folder looks like this: https://puu.sh/zGVZf/ff51ece5e3.png

I thought it might only be an issue with installing the game, but even when copying my friends' osu! folder, I couldnt run osu!.exe, the same error message appeared.

osu!repair doesnt run either.

I'm kinda out of ideas, the only thing that could be an issue is .NET framework but I cannot reinstall that since it comes preinstalled with win10...

does anyone have any clues to what I could be missing? other games seem to run just fine

EDIT forgot to mention, I did manage to run the game through the "old installer", howerever it installs the 2015 version of osu! and I couldnt find a way to update it

EDIT2 reinstalling windows for the third time somehow fixed it. still no idea what the issue was.
posted
What is the error message you are seeing?
posted
https://puu.sh/zGWJg/f7c01c56c3.png

tells me nothing...

EDIT forgot to mention, I did manage to run the game through the "old installer", howerever it installs the 2015 version of osu! and I couldnt find a way to update it
posted
Please follow this guide to get the crash log from your event viewer.
posted
I get 3 messages:
the first one is not labeled as error, but instead as "information" but it looks like it may be useful too:

2185731276776098621
5
BEX
Not available
0
osu!.exe
1.3.3.7
5a43163b
StackHash_c1b6
0.0.0.0
00000000
PCH_D9_FROM_ntdll+0x0007718C
c0000005
00000008

C:\Users\Fayhe\AppData\Local\Temp\WER47C9.tmp.WERInternalMetadata.xml
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_osu!.exe_4adbe642daffdcb12a84113b7edfefa94b5afc0_4a8a2702_1ce75815

0
d5678868-cd47-4ac8-b6a9-4f1cc1cbebbc
0
062fe9573a2e1aeefe55470406b34b3d


then I got one error saying:

osu!.exe
1.3.3.7
5a43163b
unknown
0.0.0.0
00000000
c0000005
00000000
bb4
01d3bb121fdd0733
C:\Users\Fayhe\AppData\Local\osu!\osu!.exe
unknown
d5678868-cd47-4ac8-b6a9-4f1cc1cbebbc


and lastly, this one:

Application: osu!.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.AccessViolationException at OpenTK.Platform.Windows.Functions.DescribePixelFormat(IntPtr, Int32, Int32, OpenTK.Platform.Windows.PixelFormatDescriptor ByRef) at OpenTK.Platform.Windows.WinGraphicsMode.ChoosePixelFormatPFD(IntPtr, OpenTK.Graphics.GraphicsMode, AccelerationType) at OpenTK.Platform.Windows.WinGraphicsMode.SelectGraphicsMode(OpenTK.Graphics.ColorFormat, Int32, Int32, Int32, OpenTK.Graphics.ColorFormat, Int32, Boolean) at OpenTK.Platform.Windows.WinGLContext.SetGraphicsModePFD(OpenTK.Platform.Windows.WinGraphicsMode, OpenTK.Graphics.GraphicsMode, OpenTK.Platform.Windows.WinWindowInfo) at OpenTK.Platform.Windows.WinGLContext+TemporaryContext..ctor(OpenTK.INativeWindow) at OpenTK.Platform.Windows.WinGLContext..ctor(OpenTK.Graphics.GraphicsMode, OpenTK.Platform.Windows.WinWindowInfo, OpenTK.Graphics.IGraphicsContext, Int32, Int32, OpenTK.Graphics.GraphicsContextFlags) at OpenTK.Platform.Windows.WinFactory.CreateGLContext(OpenTK.Graphics.GraphicsMode, OpenTK.Platform.IWindowInfo, OpenTK.Graphics.IGraphicsContext, Boolean, Int32, Int32, OpenTK.Graphics.GraphicsContextFlags) at OpenTK.Graphics.GraphicsContext..ctor(OpenTK.Graphics.GraphicsMode, OpenTK.Platform.IWindowInfo, OpenTK.Graphics.IGraphicsContext, Int32, Int32, OpenTK.Graphics.GraphicsContextFlags) at #=z9RJ9kJoQhEik5dnUI3$mmPgrkLhQ.#=zHIt581s=(Int32, Int32, OpenTK.Graphics.GraphicsContextFlags) at #=zGakJG9Q3v6laKark7tuRqtg=.#=zxvTukgiTxaQp(OpenTK.Graphics.GraphicsContextFlags) at #=zGakJG9Q3v6laKark7tuRqtg=.OnHandleCreated(System.EventArgs) at #=zb5JitTNJn9rcBO1zgYVkhC2TlnxB.OnHandleCreated(System.EventArgs) at System.Windows.Forms.Control.WmCreate(System.Windows.Forms.Message ByRef) at System.Windows.Forms.Control.WndProc(System.Windows.Forms.Message ByRef) at System.Windows.Forms.ScrollableControl.WndProc(System.Windows.Forms.Message ByRef) at System.Windows.Forms.ContainerControl.WndProc(System.Windows.Forms.Message ByRef) at System.Windows.Forms.Form.WmCreate(System.Windows.Forms.Message ByRef) at System.Windows.Forms.Form.WndProc(System.Windows.Forms.Message ByRef) at #=zmO8KZUH1_$9DqdBLs8Ywubo=.WndProc(System.Windows.Forms.Message ByRef) at System.Windows.Forms.Control+ControlNativeWindow.OnMessage(System.Windows.Forms.Message ByRef) at System.Windows.Forms.Control+ControlNativeWindow.WndProc(System.Windows.Forms.Message ByRef) at System.Windows.Forms.NativeWindow.Callback(IntPtr, Int32, IntPtr, IntPtr)

hope that helps
posted
Update your graphics drivers mate.

Fresh install of Win will need it.
posted
You aren't serious right? Updating my drivers is literally the first thing I did after reinstalling. I actually even rolled them back on an older version just in case
Please sign in to reply.