1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
posted
Suddenly Out of nowhere my osu decided to not launch anymore, i check task manager and it's there for about 2 seconds then it goes away and doesn't launch my game i didn't do anything in particular with my pc such as installing new programs or deleting programs.

1.i tried reinstalling

2.i tried compatibility mode

3.i tried running as an admin (w/ and w/o compatibility mode)

I'm On windows 10 btw.
posted
Check if theres anything in event viewer related to this launch failure. If you don't know how to heres a guide: https://osu.ppy.sh/community/forums/posts/6231904
posted

Flanster wrote:

Check if theres anything in event viewer related to this launch failure. If you don't know how to heres a guide: https://osu.ppy.sh/community/forums/posts/6231904


osu!.exe
1.3.3.7
5a43163b
KERNELBASE.dll
10.0.16299.248
13ae3814
c06d007e
001008c2
cc0
01d3b700f57732bf
D:\Osu\osu!.exe
C:\WINDOWS\System32\KERNELBASE.dll
5ae740a1-645c-4419-923c-e8693c3a05fb

and in the general this is what is says
Faulting application name: osu!.exe, version: 1.3.3.7, time stamp: 0x5a43163b
Faulting module name: KERNELBASE.dll, version: 10.0.16299.248, time stamp: 0x13ae3814
Exception code: 0xc06d007e
Fault offset: 0x001008c2
Faulting process id: 0xcc0
Faulting application start time: 0x01d3b700f57732bf
Faulting application path: D:\Osu\osu!.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 5ae740a1-645c-4419-923c-e8693c3a05fb
Faulting package full name:
Faulting package-relative application ID:
posted
I suggest reinstalling .NET Framework, if that doesnt help consider verifying system files via command prompt (Win+R, type cmd and hit Enter) and type sfc /scannow. It might take a while.
posted

Flanster wrote:

I suggest reinstalling .NET Framework, if that doesnt help consider verifying system files via command prompt (Win+R, type cmd and hit Enter) and type sfc /scannow. It might take a while.
Can't seem to reinstall net framework i did the sfc scannow though and it didnt help, at best i used a net framework repair tool from microsoft.
posted
Although a bit unlikely, it is possible Data Execution Prevention is causing this issue.

Right click on "My Computer" select Properties > Advanced System Settings. In a new window that pop ups select the Advanced tab and under Performance hit Settings. Again, another window will pop up and it should have a "Data Execution Prevention" tab. Try selection the second option and adding osu! to it.

Or if you have changed any group policy settings recently, that could also be the cause.
posted

Death wrote:

Although a bit unlikely, it is possible Data Execution Prevention is causing this issue.

Right click on "My Computer" select Properties > Advanced System Settings. In a new window that pop ups select the Advanced tab and under Performance hit Settings. Again, another window will pop up and it should have a "Data Execution Prevention" tab. Try selection the second option and adding osu! to it.

Or if you have changed any group policy settings recently, that could also be the cause.
It says This program must run with data execution program (DEP) enabled. you cannot turn off DEP for this program.

EDIT: i found the reason for crashing it was because of my tablet? whenever i unplug it my game starts
Please sign in to reply.