1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
show more
posted
lmao you just posted right before me

do you use unlimited fps as your fps limiter? or is it 240fps?
posted

Kondou-Shinichi wrote:

lmao you just posted right before me

do you use unlimited fps as your fps limiter? or is it 240fps?
LOL I DIDN'T NOTICE

I set it to the "Unlimited" FPS option, but it shows FPS/240FPS on the FPS counter, at the bottom right of the screen.

Also, I was experimenting with my integrated Intel graphics... I get overall less FPS (ranging from 150 to 180FPS, not usually going over 200), but also less input lag, at 2.0ms to even less than 1.0ms.

Regarding my previous post, both of those "fixes" result in a greater total of FPS (for me, the aforementioned 240FPS) but around 3.0ms of input lag. This is probably due to the fact of "Compatibility Mode" or "fullscreen windowed borderless," depending on what "solution" you are utilizing.

~150FPS and less than 2.0ms (integrated) ... vs 240FPS and around 3.0ms (NVIDIA) ...

I'm curious if this makes a significant difference! Please provide feedback on what is to be prioritized, if anything :D
posted
Where are you getting these numbers for "input lag"?

If you are using the ms values at the bottom right of your screen while playing, this is not input lag. These are your frame times, which is just the inverse of FPS. You can calculate your FPS using these values by doing 1000/ms = fps. 3ms would be 333.333fps and 2ms would be 500fps.

The difference should not be too significant unless you are getting spikes. But, you are able to play on both, you should try to see if you feel a difference yourself.
posted

Death wrote:

Where are you getting these numbers for "input lag"?



If you are using the ms values at the bottom right of your screen while playing, this is not input lag. These are your frame times, which is just the inverse of FPS. You can calculate your FPS using these values by doing 1000/ms = fps. 3ms would be 333.333fps and 2ms would be 500fps.



The difference should not be too significant unless you are getting spikes. But, you are able to play on both, you should try to see if you feel a difference yourself.
Oh, jeez. I had no idea...

I've always assumed that was an indication of input lag. The reason for this was due to the fact that the 60 FPS lock also included "17ms," and cursor movement was severely slowed down, "lagging" behind when compared to 240 FPS and a lower "ms" value (ranging from "4.0ms" and below).

I feel so foolish right now :?

As you have uncovered an incorrect interpretation of mine, is there any valid way (instead of relatively "feeling" it) to observe "input lag" within osu!...?

Such things aside, my FPS continues to be locked at 60 with my NVIDIA GPU and fullscreen, while including a constant "frame time" of 17ms.

This 60 FPS cap and the frame time of 17ms results in a sluggish, delayed cursor movement, which makes osu! basically unplayable from what I am used to. I avoid this issue by running osu! using the aforementioned settings, spoken throughout this post.

I shall perform further testing on both settings when I have time.

Please forgive my error! If need be, I can clarify on anything else... Additionally, whatever help is appreciated.
posted
My fault for not addressing it in my earlier posts. While it's not input latency itself, having a high frame time/low FPS can cause input lag.

Have you tried clean installing older graphics drivers instead of the most recent version yet?
https://www.geforce.com/drivers - This should give you a list of quite a few older versions to try.
posted

Death wrote:

My fault for not addressing it in my earlier posts. While it's not input latency itself, having a high frame time/low FPS can cause input lag.



Have you tried clean installing older graphics drivers instead of the most recent version yet?

https://www.geforce.com/drivers - This should give you a list of quite a few older versions to try.
~ Merging my posts into one ~

Yes, around one week ago, I tried performing a clean installation and downloading/installing the oldest driver in the list... Version 385.41 (August 4, 2017) was what popped up.

Didn't work out, however; I continue to receive the 60 FPS lock and the frame time of 17ms.

Should I attempt with another driver? If so, which do you suggest?

Also, re-reading your explanation on frame time had brought another question to my mind.

As I stated before, I observed ~150 (130-180) FPS and a frame time of less than 2.0ms while running on integrated graphics, while finding myself with 240+ FPS and an average frame time of 3.0ms when utilizing my NVIDIA GPU.

According to your definition, would not a frame time of 6.67ms accompany my 150 FPS on integrated, while 4.17ms would join my 240 FPS on NVIDIA? Could there be another factor that takes part in this determination...?

Perhaps you could correct me in my interpretation :lol:

Thanks again. :D
posted
Whatever you are using to actually determing the FPS you were getting in-game could be at fault.

And in fact, whatever that is, why don't you completely disable it?
posted

Death wrote:

Whatever you are using to actually determing the FPS you were getting in-game could be at fault.

And in fact, whatever that is, why don't you completely disable it?
Well, I simply use the in-game osu! FPS counter...



I'm not quite sure what to say. Disabling does not make a difference; I am still affected by the delay nonetheless. I only enable it to observe the issue at hand.

Other than that, I thank you for your continuous support. All help is appreciated greatly :D
posted
The in-game FPS counter should be a nearly perfect inverse except for slight rounding issues. Perhaps you just saw the values incorrectly at the time?
posted

Death wrote:

The in-game FPS counter should be a nearly perfect inverse except for slight rounding issues. Perhaps you just saw the values incorrectly at the time?
As I posted before, I run osu! at ~150 FPS, and this is the given frame time ingame:



On the NVIDIA GPU w/ fullscreen borderless, I receive maximum FPS (240/240 FPS on the Unlimited FPS option), and the following frame time when ingame:



Any thoughts?
posted
Where are you getting these FPS values from?

The unlimited FPS setting is only unlimited when you are in game, hence the name "Unlimited (gameplay)" Any other time your FPS will be the same as the next highest FPS limit.

In your second example, when playing a map your FPS is not limited at 240FPS anymore like it was in the menu, so you are getting ~370FPS instead.
posted

Death wrote:

Where are you getting these FPS values from?

The unlimited FPS setting is only unlimited when you are in game, hence the name "Unlimited (gameplay)" Any other time your FPS will be the same as the next highest FPS limit.

In your second example, when playing a map your FPS is not limited at 240FPS anymore like it was in the menu, so you are getting ~370FPS instead.
I see what you mean. I had believed the FPS values within the menus - including during the brief moments before gameplay occurs - remain constant throughout the entire game.

This information considered, where my FPS is no longer capped at the given 240 FPS, am I not ultimately achieving higher FPS values with my integrated graphics vs my NVIDIA GPU?

As I have said before, I achieve less frame time within game w/ integrated, with it being around 1ms; I find myself with an average of 3ms while running osu! w/ NVIDIA GPU and fullscreen borderless. With 1ms, that would equate to around 900-1000FPS (1000/1000 = 1); with 3ms, that would be over 300 FPS (1000/300 = 3.33).

Please confirm on my interpretation of the mentioned information.

Is it normal for my integrated graphics to average ~150 FPS on the menus, while hitting 1000 FPS in-game? Similarly, is it right for my NVIDIA GPU (at fullscreen borderless) to be achieving 240/240 FPS on menus, but only ~300 FPS compared to my integrated's apparent 900-1000 FPS?

Again, these in-game FPS values are based on my given frame times. Please correct me as necessary.

I can provide any additional information that is required. I shall report to any requests as soon as I am available :)
posted
Your interpretation is correct.

I'm not certain why you would only achieve 150FPS in song selection (assuming that is not what your frame limiter is set to) while getting 1000FPS in game, it could be your skin, but that is a very large drop off. As long as you aren't getting spikes this should not be too big of an issue.

Your NVIDIA GPU should probably be outperforming your integrated GPU, which leads me to believe there is still some setting that was missed.
posted
The only time that has happened to me is when the PC was bad, where the song selection and menu screen had a complete black background, but as soon as I play, it becomes smooth again.
posted

Death wrote:

Your interpretation is correct.



I'm not certain why you would only achieve 150FPS in song selection (assuming that is not what your frame limiter is set to) while getting 1000FPS in game, it could be your skin, but that is a very large drop off. As long as you aren't getting spikes this should not be too big of an issue.



Your NVIDIA GPU should probably be outperforming your integrated GPU, which leads me to believe there is still some setting that was missed.
Well, I've managed to gather some screenshots exemplifying this weird occurrence. I have set the game to the Default osu! skin, to determine if your guess had any effects.

Here's my integrated graphics, Intel(R) HD Graphics 5500, running osu! on native fullscreen, on the beatmap selection vs when in-game:

Beatmap selection -


In-game -


This is my NVIDIA GPU, NVIDIA GeForce 820M, running osu! on fullscreen borderless, also on the beatmap selection vs when in-game:

Beatmap selection -


In-game -


As it can be viewed, my integrated graphics do not reach the maximum 240/240 FPS on the beatmap selection, but it does reach nearly 1000 FPS when playing a beatmap. With my NVIDIA GPU, I am able to satisfy the 240/240 FPS menu cap, yet I do not get anywhere near to 1000 FPS in-game (as indicated by my higher frame time of 2.7ms, which amounts to approximately 370 FPS).

These measurements were recorded utilizing the same beatmap, including when viewing it on the beatmap selection. osu! was the only open program during both of these tests; the Default skin, in addition to all graphical settings to be disabled (except "snaking sliders") were used.

But yes, it should not affect me significantly, as the in-game experience is prioritized - not so much the beatmap selection. I shall be on the lookout for any possible lag spikes and freezes. Thanks again :)

Kao wrote:

The only time that has happened to me is when the PC was bad, where the song selection and menu screen had a complete black background, but as soon as I play, it becomes smooth again.
A complete black background, huh? Though I do not get this "black background" you speak of, I stutter constantly in the beatmap selection when running osu! on my flash drive, on other outside computers. It loops a second of a song a couple of times, where it can take up to 10 seconds to calm down. However, once you are able to select a beatmap, you no longer find yourself with such problems - smooth gameplay!

Of course, this could be due to the fact that the flash drive has to process all of the beatmaps on the beatmap selection :P

Thank you for your contribution to this page :D
posted
Heyo, everyone. Just a little bump for the thread, to see if any new potential viewers may have suggestions. Again, all feedback is appreciated.

If I cause any inconvenience in doing this, please notify me as necessary. I apologize in advance, and I shall not do so another time.

Else, thank you for all of your contributions to this page :)

~ TR4NQU1L1TY ~
posted
I have the same issue, and when I say the same, I mean it's identical. While in fullscreen, the game is stuck at 60fps and exactly 17ms "frame times," which somehow slows down my cursor (which also made me think this was input lag). Runs fine with intel graphics, but it gets fps drops on cool storyboarded maps, and also sometimes I get some random lag no matter if I have video/sb disabled (game randomly freezes for 1 second while playing and it's annoying af when I'm fcing a map), which doesn't happen when running on nvidia. So what I look for is a way to use nvidia graphics without issues.

The reason why I'm not creating another thread is because I see that the issue is identical to mine, so I bet there's a universal solution that would work for both of us despite our computers not being identical, and continuing the discussion here is the best option.

My pc is a laptop and the specs are the following:
Windows 10
CPU: Intel Core i7-7700HQ
GPU: Nvidia GTX 1050 (4GB)
RAM: 16GB DDR4 @2400Mhz

As you can see, there's no doubt that my computer shouldn't have any issues in running Osu! at 240fps on nvidia. I already tried everything TR4NQU1L1TY did with no successful effects.
Checked nvidia control panel, set VSync off and moved around other options (both in osu and nvidia control panel), frame rate is set to unlimited, power options in both nvidia and windows are set to high performance, completely disabled windows' game dvr, checked nvidia's battery boost was disabled (GeForce experience), got the latest drivers, and I even ended up uninstalling GeForce experience... all of this with no result.

Just as with KrisyYy (at the bottom of the first page), the issue goes away if I restart my laptop (not turning it off and on, it has to be a restart). And as he/she mentioned, doing this is very annoying. Also, the issue comes back if I put my laptop to sleep and wake it up, so then I'd have to restart it again. This is the only way I've made my nvidia graphics to work like they should (I think). But yeah, it's extremely annoying doing this every single time I wanna play Osu!, so this is not a solution.

Again, just as KrisyYy, disabling fullscreen optimizations on the osu.exe properties + Compability mode in osu settings gets rid of the cap; however, besides the frame times / input lag / whatever being slightly higher, I also noticed the graphics won't go to their full potential, since I get some fps drops on heavy storyboards, which doesn't happen when graphics are working properly (the extremely annoying restart method).

On a side note, I saw someone said that running the game as administrator fixes fps drops, but that didn't work for me either. p/6483509

Can't we just have peppy look at this issue? Seems just talking about settings and drivers is not fixing anything here :c
posted

ezek wrote:

I have the same issue, and when I say the same, I mean it's identical. While in fullscreen, the game is stuck at 60fps and exactly 17ms "frame times," which somehow slows down my cursor (which also made me think this was input lag). Runs fine with intel graphics, but it gets fps drops on cool storyboarded maps, and also sometimes I get some random lag no matter if I have video/sb disabled (game randomly freezes for 1 second while playing and it's annoying af when I'm fcing a map), which doesn't happen when running on nvidia. So what I look for is a way to use nvidia graphics without issues.

The reason why I'm not creating another thread is because I see that the issue is identical to mine, so I bet there's a universal solution that would work for both of us despite our computers not being identical, and continuing the discussion here is the best option.

My pc is a laptop and the specs are the following:
Windows 10
CPU: Intel Core i7-7700HQ
GPU: Nvidia GTX 1050 (4GB)
RAM: 16GB DDR4 @2400Mhz

As you can see, there's no doubt that my computer shouldn't have any issues in running Osu! at 240fps on nvidia. I already tried everything TR4NQU1L1TY did with no successful effects.
Checked nvidia control panel, set VSync off and moved around other options (both in osu and nvidia control panel), frame rate is set to unlimited, power options in both nvidia and windows are set to high performance, completely disabled windows' game dvr, checked nvidia's battery boost was disabled (GeForce experience), got the latest drivers, and I even ended up uninstalling GeForce experience... all of this with no result.

Just as with KrisyYy (at the bottom of the first page), the issue goes away if I restart my laptop (not turning it off and on, it has to be a restart). And as he/she mentioned, doing this is very annoying. Also, the issue comes back if I put my laptop to sleep and wake it up, so then I'd have to restart it again. This is the only way I've made my nvidia graphics to work like they should (I think). But yeah, it's extremely annoying doing this every single time I wanna play Osu!, so this is not a solution.

Again, just as KrisyYy, disabling fullscreen optimizations on the osu.exe properties + Compability mode in osu settings gets rid of the cap; however, besides the frame times / input lag / whatever being slightly higher, I also noticed the graphics won't go to their full potential, since I get some fps drops on heavy storyboards, which doesn't happen when graphics are working properly (the extremely annoying restart method).

On a side note, I saw someone said that running the game as administrator fixes fps drops, but that didn't work for me either. p/6483509

Can't we just have peppy look at this issue? Seems just talking about settings and drivers is not fixing anything here :c
Thanks for taking your time to write such a detailed post! Practically a recap of our grievous situation, emphasizing the problem at hand.

We can reasonably confirm that this is a persistent issue between osu! and NVIDIA GPUs (perhaps specific to laptop models, from what I have observed). I wonder what could be causing it...

While reading through your statements, I came up with an inquiry. Have you attempted to run osu! on fullscreen borderless windowed, using your GTX 1050? My younger brother's HP OMEN laptop is nearly identical to your specs, with the exception of having a less amount of RAM (8GB). He had also been experiencing the aforementioned problem of the 60FPS cap/17ms frame time, so I asked him to run osu! windowed, on the fullscreen borderless option. He did so, and it freed him of the FPS/ms lock. From what we have observed, he achieves 1 ms or less in-game, meaning he gets 1000+ FPS... He also says he doesn't get any freezes, unlike your situation when utilizing your integrated graphics.

I suggest you try this as well, if you haven't already (I apologize in advance if it doesn't work ;-;). Operating in fullscreen borderless windowed also worked for me, granting me ~300 - 400 FPS (2.5 - 3ms) but I seemed to get more constant in-game FPS when running osu! fullscreen with my integrated graphics, resulting in 800 - 1000FPS (< 1.2ms). Feel free to report back if it works/doesn't work; the more information, the better.

On the last note, where you prompt developers to take a close look at this odd problem, I believe we should leave them be for the moment, as they may be busy working with other curious items, for our beloved game of osu!. Nevertheless, if more and more posts of this issue become apparent, they'll probably notice. We just have to wait and see :D

Again, thanks for your contribution to this page :)
posted
Yeah, I tried my native resolution on borderless with my GTX 1050. It does remove the cap, graphics seem to run normally, I get 1.6ms "frame times" when a map doesn't have any video or sb, and around 5ms when on heavy sb. However, I feel a delay in my cursor movement; it seems I got some notable input lag while running the game on borderless. So again, this is not a solution :c

Moving that aside, I probably have the same laptop as your bro. Mine is also an Omen and originally came with 8GB of RAM, but I upgraded to 16 :p

I guess we'll have to wait till someone who can fix this notices us, or wait till lazer is done xp
posted

ezek wrote:

Yeah, I tried my native resolution on borderless with my GTX 1050. It does remove the cap, graphics seem to run normally, I get 1.6ms "frame times" when a map doesn't have any video or sb, and around 5ms when on heavy sb. However, I feel a delay in my cursor movement; it seems I got some notable input lag while running the game on borderless. So again, this is not a solution :c

Moving that aside, I probably have the same laptop as your bro. Mine is also an Omen and originally came with 8GB of RAM, but I upgraded to 16 :p

I guess we'll have to wait till someone who can fix this notices us, or wait till lazer is done xp
Ah, sucks that it doesn't really help. I guess my brother (lul same laptops) is just used to the delay; maybe the fact that we play w/o detail settings (except snaking sliders) prevents us from hitting frame drops and lagging all over the place.

Yep, we shall wait until that day. Thanks again :D
show more
Please sign in to reply.