Unoffical Updated OSX osu! Wineskin Package

posted
Total Posts
291
show more
Paydru

bBob_21 wrote:

Rigtu wrote:

slc wrote:

bBob_21 wrote:

For the command part you should instead type this:

sudo xattr -rd com.apple.quarantine "~/path/to/my/osu\!.app"

Because without the "\" behind the "!" it will say "-bash: !.app: event not found" and the command will not work
thanks for the tip, edited original post
every time i enter the command in terminal, it says xattr: No such file. I have no idea what i am doing wrong
Did you use the correct slash after "osu" and before "!"? It's this one \. If that doesn't fix it then you may be putting in the wrong path. It should look something like this:

sudo xattr -rd com.apple.quarantine "/Users/YOURMACNAME/Desktop/osu\!.app"

If you want to get the path to your file(in this case your osu) then just select your file and click Option+Command+C and the path should be copied to your clipboard
https://puu.sh/CuCn5/4aecdbb224.png this is what keeps on happening. i tried it a bunch of time and its all the same.i tried changing the paths several times and it keeps saying the same thing and idk what to do :/
bBob_21

Rigtu wrote:

bBob_21 wrote:

Rigtu wrote:

slc wrote:

bBob_21 wrote:

For the command part you should instead type this:

sudo xattr -rd com.apple.quarantine "~/path/to/my/osu\!.app"


Because without the "\" behind the "!" it will say "-bash: !.app: event not found" and the command will not work
thanks for the tip, edited original post
every time i enter the command in terminal, it says xattr: No such file. I have no idea what i am doing wrong
Did you use the correct slash after "osu" and before "!"? It's this one \. If that doesn't fix it then you may be putting in the wrong path. It should look something like this:

sudo xattr -rd com.apple.quarantine "/Users/YOURMACNAME/Desktop/osu\!.app"


If you want to get the path to your file(in this case your osu) then just select your file and click Option+Command+C and the path should be copied to your clipboard
https://puu.sh/CuCn5/4aecdbb224.png this is what keeps on happening. i tried it a bunch of time and its all the same.i tried changing the paths several times and it keeps saying the same thing and idk what to do :/
I'm unsure but can you try to remove the " " in the path?
Paydru

bBob_21 wrote:

Rigtu wrote:

bBob_21 wrote:

Rigtu wrote:

slc wrote:

bBob_21 wrote:

For the command part you should instead type this:

sudo xattr -rd com.apple.quarantine "~/path/to/my/osu\!.app"

Because without the "\" behind the "!" it will say "-bash: !.app: event not found" and the command will not work
thanks for the tip, edited original post
every time i enter the command in terminal, it says xattr: No such file. I have no idea what i am doing wrong
Did you use the correct slash after "osu" and before "!"? It's this one \. If that doesn't fix it then you may be putting in the wrong path. It should look something like this:

sudo xattr -rd com.apple.quarantine "/Users/YOURMACNAME/Desktop/osu\!.app"

If you want to get the path to your file(in this case your osu) then just select your file and click Option+Command+C and the path should be copied to your clipboard
https://puu.sh/CuCn5/4aecdbb224.png this is what keeps on happening. i tried it a bunch of time and its all the same.i tried changing the paths several times and it keeps saying the same thing and idk what to do :/
I'm unsure but can you try to remove the " " in the path?
some stuff showed saying operation not permitted but it ended up working fine. thanks a lot for your help :)
https://puu.sh/Cv6Xv/2c3d169afb.png
Kirito6554
When I try to change the difficulty of beatmaps that is shown, through options -> song select, it does not work. For example if I increase the minimum from 0 to 4.16 and keep the max at 10+, it still displays it.

Edit: I found out that it works for only some maps but not for others.

Last edit: restarting the app multiple times seems to have made it work. Apparently restarting once wasn't enough.
Sw33tS0urC4ndy
When I enter to Edit mode the Song Setup window (or any other window) does not appear, just the Song Setup thing above. Sorry for my bad English
Himajin1
When I open the game, the texts seems to be just squares and I can't see/read the texts on places like the options, how do I fix this?
zodiacstyx
I just download and unzip the file.
I drag the icon to the desktop and right click the icon waiting for "welcome to OSU"
but when the updated from 10% to 80% it's ok,in the next the update loop from the 1% to 70% then stop and always loop again and again.

It's so crazy...

I was delete all the file and re-download but still the case.
I'm so helpless,please help me with my macbook pro 2018 and OSU...thanks in advance.
Topic Starter
Technocoder

zodiacstyx wrote:

I just download and unzip the file.
I drag the icon to the desktop and right click the icon waiting for "welcome to OSU"
but when the updated from 10% to 80% it's ok,in the next the update loop from the 1% to 70% then stop and always loop again and again.

It's so crazy...

I was delete all the file and re-download but still the case.
I'm so helpless,please help me with my macbook pro 2018 and OSU...thanks in advance.

Please post the contents of the update log in a Pastebin (osu! > Show Package Contents > drive_c > osu! > Logs)
darsparx
I think I'm having issues too, I redownloaded(because I screwed up and didn't realize I hit compatibility mode somehow)and it's now having input lag issues. I'm not even sure how but yeah, since I typically make it much further in a map I'm having trouble playing now....it's like it's not recognizing my Z and X inputs everytime I press them

Apparently "turn off mouse buttons during gameplay" got flipped to off somehow....idk how but yeah it did. (do people even play with that on in the first place? because I've never seen it in any vid I've ever watched)
hi_nepnep
So my osu got locked up...how do I unlock it? Anyone knows? For MacOs
darsparx

hi_nepnep wrote:

So my osu got locked up...how do I unlock it? Anyone knows? For MacOs
Same here, I think it might be a mojave bug if you've upgraded to that from what I can tell. Not even sure, it worked fine for me for a week and a half and now nothing. Trying to see if maybe I can find a more updated version of wineskin I guess? From what I can tell the latest version listed on what I think is the "official" site is what came before mojave. Not sure why but yeah...

Edit: not sure how, but got it open by pressing alt and clicking on it....guess it works now somehow...

Edit 2: and now was somehow able to get wineskin to open(the little app inside of osu on mac since that's what osu is here) and updated the wrapper. Highly recommend and hope someone manages to do it officially as a tie over until lazer comes out. The wrapper used is apparently ancient by mac standards since being Apple it seems like wine breaks every update to the point I've given up personally doing it myself because it seems so pointless at this point...(and I've never had luck getting apps up and running without the help of crossover or in this case the person who wrapped this originally)
Ramza-San
Not here to express problems or concerns, i've been running just fine on a modded late 2011 iMac Desktop.
I wanted to say thank you for continuing to support mac users and for helping all these people with their problems. I haven't played in over 5 years because of the old version that broke and went unfixed for a while, and I'm glad to see that after all these years that people are still helping Mac users for Osu!. You have my sincerest gratitude.
ItsTee
in the video tutorial, you said that you needed to rightclick and click "Open" when opening osu.

Do you need to do this every time you open or just the first time?
Topic Starter
Technocoder

OfficialTNT wrote:

in the video tutorial, you said that you needed to rightclick and click "Open" when opening osu.

Do you need to do this every time you open or just the first time?
You should only have to do this once. Generally speaking, once you get it working, it won't break again.
GLR9GT
Okay, I have a new problem. I followed all the steps and when I try to open it the updater doesn't show up. I also didn't double click the icon. Osu used to work after I updated to Mojave but I turned on one of the settings in osu and it made my game crash. I am trying to reinstall but nothing is working.
Kalebloganwer
The game says that it needs an update and it is not optimized. I do not know why it says that and it's not updating from OSU launcher.
Topic Starter
Technocoder

GLR9GT wrote:

Okay, I have a new problem. I followed all the steps and when I try to open it the updater doesn't show up. I also didn't double click the icon. Osu used to work after I updated to Mojave but I turned on one of the settings in osu and it made my game crash. I am trying to reinstall but nothing is working.
It sounds like you may have enabled compatibility mode; If this is the case, Right click osu! > Show Package Contents > drive_c > osu! > Open osu!.(name).cfg and change CompatibilityContext = 1 to CompatibilityContext = 0

Kalebloganwer wrote:

The game says that it needs an update and it is not optimized. I do not know why it says that and it's not updating from OSU launcher.
Ignore the message, macOS is simply saying that 32 bit applications will not run in a future version of macOS. If the updater doesn't launch, right click osu! and click Open again.
Arturo10170
Hi! I've been trying to fix this issue for a while now, but whenever I try to extract the .zip file in the link, it takes a substantial amount of time and usually ends up with saying that the zip file was either:

too long, says that it has downloaded for far too long or says that there were files that were unable to be extracted due to an error.

I used the default apps that were in the link/Google Drive to extract (CloudConverter, Zip Extractor and Zip, Unzip)
https://gyazo.com/505284a3338528a8b92dc35e653475bb
but each one of them says that the files were unable to be extracted due to an error, too long or took too long to download.

^ Is there any way for me to fix this problem? Thanks! (sorry for the long post)
Topic Starter
Technocoder

Arturo10170 wrote:

Hi! I've been trying to fix this issue for a while now, but whenever I try to extract the .zip file in the link, it takes a substantial amount of time and usually ends up with saying that the zip file was either:

too long, says that it has downloaded for far too long or says that there were files that were unable to be extracted due to an error.

I used the default apps that were in the link/Google Drive to extract (CloudConverter, Zip Extractor and Zip, Unzip) but each one of them says that the files were unable to be extracted due to an error, too long or took too long to download.

^ Is there any way for me to fix this problem? Thanks! (sorry for the long post)


Default apps to extract? I've never heard of any of them. Are you using an app inside your browser to extract the zip file? If so, the zip file maybe too large for those apps to handle. You need to download the zip file itself to your Downloads folder and then extract them from there (using for example The Unarchiver [from the Appstore] or with Archive Utility)
Arturo10170
Hi! Using an app in the app store to extract it worked and extracted it in such a fast time! However, when I tried to open the app, it wouldn't open, will just bounce or say that it cannot be opened.
https://gyazo.com/94076ab1a0391e10f807f98fcd5b056b (please look at this image)
Also, when I opened osu!-1(which came from the .zip file), it produced the black screen above. I tried using the .zip file to make a new osu! file (osu!-2) but osu!-2 didn't work as well. Am I doing anything wrong or did I just miss a step? Thanks!
show more
Please sign in to reply.

New reply