forum

[Guide] Fixing Mac issues

posted
Total Posts
144
show more
Z3xs_old
I have a Mac and the problem of the month for osu for me is that when I start it up, the screen is just white. I can still hear the sound but I can't see anything
jonaah
My osu! can't stop download some kind of discord-rpc.dll_patch

Can someone send me a copy?


thanks
Dntm8kmeeatu

jonaahDE wrote:

My osu! can't stop download some kind of discord-rpc.dll_patch

Can someone send me a copy?


thanks
https://drive.google.com/file/d/1x17jM9fnbyfbGM9vY6H54UXWECSILwlY/view?usp=sharing

The link is in the post.
jonaah
i need discord_rpc.dll_patch not the one without patch
kiadeiaz
everything else is fine, except for that whenever i type (searching, playing the game, etc) the game will either freeze or crash.

i can press keys while keybinding, but the keys don't change, they stay default, no matter what key i press.
akinawoo
Every time I try to use update wrapper or change engine used, it would just say your wrapper is running and can't perform the task. Is there a way to stop the wrapper?
Topic Starter
Technocoder

Alledion wrote:

Every time I try to use update wrapper or change engine used, it would just say your wrapper is running and can't perform the task. Is there a way to stop the wrapper?
Open Activity Monitor and type in the search bar "wine", "Wineskin" and "osu" and then force quit any programs with those names.
akinawoo
Thanks for the advice!
Scribbss

Dntm8kmeeatu wrote:

jonaahDE wrote:

My osu! can't stop download some kind of discord-rpc.dll_patch

Can someone send me a copy?


thanks
https://drive.google.com/file/d/1x17jM9 ... sp=sharing

The link is in the post.
Where should I put the file after downloading?
Topic Starter
Technocoder

Scribbss wrote:

Dntm8kmeeatu wrote:

jonaahDE wrote:

My osu! can't stop download some kind of discord-rpc.dll_patch

Can someone send me a copy?


thanks
https://drive.google.com/file/d/1x17jM9 ... sp=sharing

The link is in the post.
Where should I put the file after downloading?

Technocoder wrote:

osu! folder can be found by going to Show package contents > drive_c > osu!
Jared-San
Before I updated to High Sierra (was using El Capitan before, never updated to Sierra) my Osu! with this wrapper worked perfectly smooth, no input lag or anything. Now that I've updated to High Sierra I've had no problem opening it, however, the gameplay is terrible now. I get high input lag and the notes don't even show up on time anymore they are super delayed and very laggy, along with the cursor lag, it's pretty much unplayable. I haven't seen anyone with this problem though, only those having trouble opening it and no gameplay problems. Any thoughts on how I could fix?
Songbirb
Currently my odd problem, is that whenever I am playing and get to low hp, the screen goes entirely black, I am not even using a dual monitor setup or anything, it really hinders gameplay.
Topic Starter
Technocoder

Songbirb wrote:

Currently my odd problem, is that whenever I am playing and get to low hp, the screen goes entirely black, I am not even using a dual monitor setup or anything, it really hinders gameplay.


See my reply on a previous problem extremely to similar to this one.

Technocoder wrote:

[box=catitaa6]

catitaa6 wrote:

thank you! runs 100%, except for one problem. i've installed yesterday and every time i play whenever the HP bar starts dropping to around 10-15% the game blacks out, really annoying cause then i just stop being able to see the game and obviously always lose as i can't keep playing to come back. soon as the song is lost i'm able to see the game just fine once again.

logs: https://drive.google.com/open?id=1jL2CgQX15aKGbC_6F35K3IPPZoUTIKyo

some help would be appreciated on this one, thanks

Only thing I can think of is OpenGL issues but your GL Version is only slightly lower than mine so I doubt it's a huge issue. You can try disabling as many graphical effects in the osu! options and if that doesn't work, enable compatibility mode. If even that doesn't work I'll add a section in my guide later that explains how to revert your Wine version to an older one that may work better.

[quote="catitaa6"]hey! worked for me - i moved some settings around, something was probably causing conflict and the problem is gone. not sure what it was as i changed a lot of stuff, but fortunately it's properly working again. thanks again for this lovely package now i can say it's fully running :)[/box]

RIP formatting
orangeosu
osu! is black when i open it and I only hear audio help what do I do I also tried to reinstall it and i can't get into wine yet because it says busy please wait well how long do i have to wait?!?!

Update: reinstalled osu! it works fine now now i have lag like every 2-3 seconds i try to play a map WHATS WRONG!?!?!? forgot to mention also on the latelst high Sierra update just released a few days ago
Jared-San

orangeosu wrote:

osu! is black when i open it and I only hear audio help what do I do I also tried to reinstall it and i can't get into wine yet because it says busy please wait well how long do i have to wait?!?!

Update: reinstalled osu! it works fine now now i have lag like every 2-3 seconds i try to play a map WHATS WRONG!?!?!?
As I posted before although skipped over, I am also having the lag problem but it is all throughout Osu! since the High Sierra update. Before, however, the wrapper worked perfectly. What causes this lag? It is unbearable. Thanks
IndigoRush

Z3xs wrote:

I have a Mac and the problem of the month for osu for me is that when I start it up, the screen is just white. I can still hear the sound but I can't see anything
Same here except my screen is black i cant see anything but i can hear the game
IkuKazumi
These tips were helpful when I still had Osu, but when I had it running in the background for about 5 mins, it suddenly froze and had to uninstall it. Upon reinstalling the game, I set up all the settings to what I had before uninstalling Osu. But now the game won't even launch. I have tried using all the steps in the post but still hasn't worked. I'm running on High Sierra. In Activity Monitor, I see the Osu app active for about a minute then immediately shuts down. I also didn't see the Osu wine commands active during the process.
IkuKazumi

IndigoRush wrote:

Z3xs wrote:

I have a Mac and the problem of the month for osu for me is that when I start it up, the screen is just white. I can still hear the sound but I can't see anything
Same here except my screen is black i cant see anything but i can hear the game
Have you put shaders on?
mbruhyo
I've looked through here and can't seem to find a solution for my issue. I'm using a Wacom Intuos P S (newest intuos tablet, also known as intuos draw) when I play osu! and when I'm playing, the cursor will freeze for a few seconds - every 10-20 seconds and make me fail. I have Wacom drivers installed, so I checked to see if it was my tablet by playing with my mouse and I get the same problem. The mouse & tablet works perfectly fine outside of osu! so I'm not sure what the problem is.
CogentLagger
For some reason, osu will work fine but then will give an error message that reads,"Unable to find a version of the runtime to run this application". I backed up my osu folder and reinstalled osu, but after I restored my backup, the updater opened and installed some files, and I got the error message after it closed. I'm unsure as to how to fix this, and I don't want to reinstall osu again in case the same thing happens.
Flifflareon
I'm unable to open wineskin. Its constantly stuck on this small window that says its busy. Anyone able to help?
Kpham9906
Thank you soo much!!
PewPewFox
When it is on desktop it launches but won't launch when moved to applications. Also, when updating, replacing the dll file won't work and would still be downloading 17 files.
IkuKazumi
Is anyone having a problem where when you open up osu! it says unable to find version? I had pressed the "Click to Restart osu!" and it just told me it couldn't find a version?
Renzu
My osu! opens up at black screen, I can hear the music and I can still navigate throughout the menu but only displays black screen!
ANDavid1611
When I try to update Osu, an error appears: you can not find a version of the runtime to run this application. Can anybody help me?
Whamo
i did everything you said here but it still wont run
JasmineMA
I have just found out that if you are in an update loop, you can delete the file "Wineskinx11" (Contents>MacOS) and it should stop the update loop.

This is only if you have updated all of the wineskin stuff beforehand - including the engine and completed the steps under "Help!My game wont start after updating to High Sierra"

This has just worked for me and I cant speak for anyone else but I hope it helps.
SnowSiren
My Wine package worked fine until a couple days ago when osu! updated. I've updated the settings, but I get an error message saying, "Unable to find a version of the runtime to run this application." I'm not sure why it's happening, but the log I checked from a Wine test run said that fonts wouldn't initialize (with the X11 from the computer). Future runs said, "No X11 Log info when using XQuartz!" How do I fix this?

The XQuartz file now just mentions hardware, graphics, and Wine engine used, but now Wine says something that I don't know how to fix. Here's what I got:
winedevice.exe(17014,0x407e9000) malloc: *** error for object 0x2c883d0: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
DESUxDESU
Hey guys, I got xQuartz and Wine installed, however I have to cd to the osu.exe file to launch. And once I do this I'm stuck at can't download .NET.

Heres the logs:

fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform
fixme:exec:SHELL_execute flags ignored: 0x00004100
fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:process:SetProcessDEPPolicy (3): stub
fixme:clusapi:OpenCluster ((null)) stub!
fixme:clusapi:ClusterOpenEnum (0xdeadbeef, 4) stub!
fixme:clusapi:ClusterEnum (0xdeadbeef, 0, 0x33f8b0, 0x159618, 261) stub!
fixme:clusapi:ClusterCloseEnum (0xdeadbeef) stub!
fixme:clusapi:CloseCluster (0xdeadbeef) stub!
fixme:advapi:DecryptFileW (L"C:\\dbb6d7d5edfb749e42fdbf14\\", 00000000): stub
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:ntdll:EtwRegisterTraceGuidsW (0x6cd15f38, 0x6cd20180, {e2821408-c59d-418f-ad3f-aa4e792aeb79}, 1, 0x33fda0, (null), (null), 0x6cd20188): stub
fixme:ntdll:EtwRegisterTraceGuidsW register trace class {e2821408-c59d-418f-ad3f-aa4e792aeb79}
fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:process:SetProcessDEPPolicy (1): stub
fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:thread:SetThreadStackGuarantee (0x33fbb8): stub
fixme:advapi:LsaOpenPolicy ((null),0x33f4b0,0x00000001,0x33f4a0) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:msxml:domdoc_putref_schemas (0x16c708)->(0x33f408 {VT_DISPATCH: 0x16c5e4}): semi-stub
fixme:msxml:domdoc_get_readyState stub! (0x16c708)->(0x33f3e8)
fixme:advapi:LsaOpenPolicy ((null),0x33f300,0x00000001,0x33f2f0) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:UnregisterTraceGuids deadbeef: stub
RGxBlaze
Hey the application works perfectly fine but there is a noticeable cursor lag or just some slight FPS issues.

MacBook Pro (Retina, 13-inch, Late 2012) is what I'm running it on if that helps
diddy_dante
It crashes When I turn on compatability mode and won't start up (had to reinstall). Is that a graphics problem or is there a fix to that?

don't have the logs anymore sorry
Death

diddy_dante wrote:

It crashes When I turn on compatability mode and won't start up (had to reinstall). Is that a graphics problem or is there a fix to that?

don't have the logs anymore sorry
Probably some graphics issue.

If you accidentally turn it on in the future, right click on your osu! icon and hit "Show package contents" then go to "Contents > Resources > drive_c > osu!". Edit the file "osu!.pcname.cfg" in any text editor (TextEdit will do) and set the line CompatibilityContext equal to 0. Save the file and close the document and you should be able to start the game again.
fongtastic
help, i have a mac 12 inch (2012 version) running osx 13.6. i have followed all your instruction but my game wont load. in activity monitor it appers but after 1 min it disseapear and the game does not show
DJ_Setty
Thank you so much for posting this guide! I love osu! and recently switched from Windows to Mac and this guide helped me get osu! to finally run after installation!
-Michael
Thank you. Helped a lot
Konomatari
Do you know how to fix the Japanese characters showing as boxes?
Lv99Pikachu
Whenever I play this beatmap: https://osu.ppy.sh/beatmapsets/219380/#osu/724015
my game crashes.

After I played any other map, throughout the song everything was just fine until the very end as I was getting my score, the game crashes.

When I say "the game crashes" I mean the application doesn't close. It's just frozen for eternity, so I have to Force Quit OSU.

Has anyone else encountered this? Is there any fix for this?
Death

Lv99Pikachu wrote:

Whenever I play this beatmap: https://osu.ppy.sh/beatmapsets/219380/#osu/724015
my game crashes.

After I played any other map, throughout the song everything was just fine until the very end as I was getting my score, the game crashes.

When I say "the game crashes" I mean the application doesn't close. It's just frozen for eternity, so I have to Force Quit OSU.

Has anyone else encountered this? Is there any fix for this?
Try deleting and redownloading the map.
Lv99Pikachu

Death wrote:

Lv99Pikachu wrote:

Whenever I play this beatmap: https://osu.ppy.sh/beatmapsets/219380/#osu/724015
my game crashes.

After I played any other map, throughout the song everything was just fine until the very end as I was getting my score, the game crashes.

When I say "the game crashes" I mean the application doesn't close. It's just frozen for eternity, so I have to Force Quit OSU.

Has anyone else encountered this? Is there any fix for this?
Try deleting and redownloading the map.
It didn't help. It's happening whenever I play any beatmap.

EDITED: Nvm.. I found out that the skin I was using was crashing my game. (I was using BeastTrollMC's skin)
show more
Please sign in to reply.

New reply