1. osu!community
  2. osu!
  3. Help
posted

Dntm8kmeeatu wrote:

jonaahDE wrote:

My osu! can't stop download some kind of discord-rpc.dll_patch

Can someone send me a copy?


thanks
https://drive.google.com/file/d/1x17jM9 ... sp=sharing

The link is in the post.
Where should I put the file after downloading?
posted
Scribbss

Scribbss wrote:

Dntm8kmeeatu wrote:

jonaahDE wrote:

My osu! can't stop download some kind of discord-rpc.dll_patch

Can someone send me a copy?


thanks
https://drive.google.com/file/d/1x17jM9 ... sp=sharing

The link is in the post.
Where should I put the file after downloading?

Technocoder wrote:

osu! folder can be found by going to Show package contents > drive_c > osu!
posted
Before I updated to High Sierra (was using El Capitan before, never updated to Sierra) my Osu! with this wrapper worked perfectly smooth, no input lag or anything. Now that I've updated to High Sierra I've had no problem opening it, however, the gameplay is terrible now. I get high input lag and the notes don't even show up on time anymore they are super delayed and very laggy, along with the cursor lag, it's pretty much unplayable. I haven't seen anyone with this problem though, only those having trouble opening it and no gameplay problems. Any thoughts on how I could fix?
posted
Currently my odd problem, is that whenever I am playing and get to low hp, the screen goes entirely black, I am not even using a dual monitor setup or anything, it really hinders gameplay.
posted
Songbirb

Songbirb wrote:

Currently my odd problem, is that whenever I am playing and get to low hp, the screen goes entirely black, I am not even using a dual monitor setup or anything, it really hinders gameplay.


See my reply on a previous problem extremely to similar to this one.

Previous response

Technocoder wrote:

[box=catitaa6]

catitaa6 wrote:

thank you! runs 100%, except for one problem. i've installed yesterday and every time i play whenever the HP bar starts dropping to around 10-15% the game blacks out, really annoying cause then i just stop being able to see the game and obviously always lose as i can't keep playing to come back. soon as the song is lost i'm able to see the game just fine once again.

logs: https://drive.google.com/open?id=1jL2CgQX15aKGbC_6F35K3IPPZoUTIKyo

some help would be appreciated on this one, thanks

Only thing I can think of is OpenGL issues but your GL Version is only slightly lower than mine so I doubt it's a huge issue. You can try disabling as many graphical effects in the osu! options and if that doesn't work, enable compatibility mode. If even that doesn't work I'll add a section in my guide later that explains how to revert your Wine version to an older one that may work better.

[quote="catitaa6"]hey! worked for me - i moved some settings around, something was probably causing conflict and the problem is gone. not sure what it was as i changed a lot of stuff, but fortunately it's properly working again. thanks again for this lovely package now i can say it's fully running :)[/box]

RIP formatting
posted
osu! is black when i open it and I only hear audio help what do I do I also tried to reinstall it and i can't get into wine yet because it says busy please wait well how long do i have to wait?!?!

Update: reinstalled osu! it works fine now now i have lag like every 2-3 seconds i try to play a map WHATS WRONG!?!?!? forgot to mention also on the latelst high Sierra update just released a few days ago
posted

orangeosu wrote:

osu! is black when i open it and I only hear audio help what do I do I also tried to reinstall it and i can't get into wine yet because it says busy please wait well how long do i have to wait?!?!

Update: reinstalled osu! it works fine now now i have lag like every 2-3 seconds i try to play a map WHATS WRONG!?!?!?
As I posted before although skipped over, I am also having the lag problem but it is all throughout Osu! since the High Sierra update. Before, however, the wrapper worked perfectly. What causes this lag? It is unbearable. Thanks
posted

Z3xs wrote:

I have a Mac and the problem of the month for osu for me is that when I start it up, the screen is just white. I can still hear the sound but I can't see anything
Same here except my screen is black i cant see anything but i can hear the game
posted
These tips were helpful when I still had Osu, but when I had it running in the background for about 5 mins, it suddenly froze and had to uninstall it. Upon reinstalling the game, I set up all the settings to what I had before uninstalling Osu. But now the game won't even launch. I have tried using all the steps in the post but still hasn't worked. I'm running on High Sierra. In Activity Monitor, I see the Osu app active for about a minute then immediately shuts down. I also didn't see the Osu wine commands active during the process.
posted

IndigoRush wrote:

Z3xs wrote:

I have a Mac and the problem of the month for osu for me is that when I start it up, the screen is just white. I can still hear the sound but I can't see anything
Same here except my screen is black i cant see anything but i can hear the game
Have you put shaders on?
posted
I've looked through here and can't seem to find a solution for my issue. I'm using a Wacom Intuos P S (newest intuos tablet, also known as intuos draw) when I play osu! and when I'm playing, the cursor will freeze for a few seconds - every 10-20 seconds and make me fail. I have Wacom drivers installed, so I checked to see if it was my tablet by playing with my mouse and I get the same problem. The mouse & tablet works perfectly fine outside of osu! so I'm not sure what the problem is.
posted
For some reason, osu will work fine but then will give an error message that reads,"Unable to find a version of the runtime to run this application". I backed up my osu folder and reinstalled osu, but after I restored my backup, the updater opened and installed some files, and I got the error message after it closed. I'm unsure as to how to fix this, and I don't want to reinstall osu again in case the same thing happens.
posted
I'm unable to open wineskin. Its constantly stuck on this small window that says its busy. Anyone able to help?
posted
Thank you soo much!!
posted
When it is on desktop it launches but won't launch when moved to applications. Also, when updating, replacing the dll file won't work and would still be downloading 17 files.
posted
Is anyone having a problem where when you open up osu! it says unable to find version? I had pressed the "Click to Restart osu!" and it just told me it couldn't find a version?
posted
My osu! opens up at black screen, I can hear the music and I can still navigate throughout the menu but only displays black screen!
posted
When I try to update Osu, an error appears: you can not find a version of the runtime to run this application. Can anybody help me?
posted
i did everything you said here but it still wont run
posted
I have just found out that if you are in an update loop, you can delete the file "Wineskinx11" (Contents>MacOS) and it should stop the update loop.

This is only if you have updated all of the wineskin stuff beforehand - including the engine and completed the steps under "Help!My game wont start after updating to High Sierra"

This has just worked for me and I cant speak for anyone else but I hope it helps.
Please sign in to reply.