1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Hi there. I have a small problem. While creating my beatmap, I inserted new skins for the following files.(First I made a copy of a funktional beatmap)

hit50.png
hit100.png
hit100k.png
hit300.png.
hit300g.png
hit300k.png
cursor.png
cursortrail.png
hitcircleoverlay.png
hitcircle.png
hitcircleselect.png
lightning.png

and several others. Now, when testing the beatmap, the cursor, the hitcircles and the hits are still shown with the standard skin, instead of the files, I inserted.

How can I make them run?
posted
If they are in the beatmap folder they should work correctly, try going out of the map and pressing F5 and then testing it again.
posted
So the hit50 and so on are working but the cursor and the hitcircles still screw up.
posted
Make sure it doesn't say "copy of (filename here)" per file otherwise it won't work.

Also, make sure the filename is exactly how it should be set up with no extra spaces or symbols. Just the same as you would see in the other skin folders.

Did you also put in...

approachcircle.png
cursor.png
cursortrail.png

hitcircleselect.png is for editor, but you can still change it if you want.

And for lighting.png, try to avoid making it too large, bright, dense (poor transparancy settings) or else it may cause cluttering with stacks or notes close together along with visibility issues
posted
I am confused right now.

I did a check on the file names, but I can't find any mistakes and I also added the Approachcircle.png but the Beatmap Test still shows me the cursor of the standard skin. Do I have to choose another option in the editor itself?

Here is the complete Songfolder. Maybe someone finds the mistake.



Edit: All files also contain .png but Windows 7 doesn't show the file endings.
posted

YGSFox wrote:

All files also contain .png but Windows 7 doesn't show the file endings.
Press [Alt] key once, and then select "Tools" > "Folder Options...". On the Folder Options window, select "View" tab and uncheck "Hide file extensions for known file types" and click OK.
posted
There is no Change at all. The Hitcircles and the cursor still don't show up.
posted
Probably something obvious I am not seeing here which is causing the problem...:P

For the cursor make sure the "always use skin cursor" option is turned off on the skinning options menu http://puu.sh/9wmN

As for the hitcircles, they look pretty similar to the default type, type switching them to something else quickly just to make sure you aren't missing the change?
posted
I'm stupid^^ Now the cursor works.

As for the Hitcircles, the numbers are not showing up on them. At least, not the ones I made.
posted
I dont see any combo numbers on your skin? i only see score numbers
posted
So the numbers are just for the scoreboard? Which name do the numbers for the hitcircles need?
posted
default-0 > default-9
posted
default-0.png
default-1.png
default-2.png
default-3.png
default-4.png
default-5.png
default-6.png
default-7.png

You get the idea, default-n.png <-- where n = 0 to 9 for each file.

EDIT: Ninja'd :(
posted
T.T I'm gonna become mad here. Now I inserted the defaults for all numbers but they will not work again T.T
posted
So, now everything is working smoothly. Many thanks to everyone who helped!!
Please sign in to reply.