1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
Looked around for quite a bit now, but haven't found anything substantial.

I'm trying to run osu!lazer on macOS natively, as it is supported, but can't find a correct way for it to work. I've tried using Wine and Mono, but can't run the installer.

I also found that peppy said osu!lazer is able to run if you compile it using VS or VS Code, but being new to how VS works, I can't find a way to compile it. Any help from those with knowledge on the topic would be appreciated.

Wine Error
The error message reads

No new executables found!
Maybe the installer failed...?
If you tried to install somewhere other than C: drive (drive_c in the wrapper) then you will get this message too. All software must be installed in C: drive."

after running the Install Software option and selecting install.exe as the installer.

Mono Error
The error message reads

"Cannot open assembly 'path/install.exe': File does not contain a valid CIL image."

after running 'mono path/install.exe'
Please sign in to reply.