1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Problem Details:
I tried to reinstall and it keeps giving me these error and I already checked my DirectX system.
OpenTK.Graphics.GraphicsContextException: [EGL] Failed to create window surface, error BAD_NATIVE_WINDOW.
at OpenTK.Platform.Egl.EglWindowInfo.CreateWindowSurface(IntPtr config)
at OpenTK.Platform.Egl.EglContext..ctor(GraphicsMode mode, EglWindowInfo window, IGraphicsContext sharedContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
at OpenTK.Platform.Egl.EglAnglePlatformFactory.CreateGLContext(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Boolean directRendering, Int32 major, Int32 minor, GraphicsContextFlags flags)
at OpenTK.Graphics.GraphicsContext..ctor(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
at #=zZjYKHpuRzWjvEgHNFxLVfZJfC2u5.#=zqtqcJFA=(Int32 #=zblFwaHQ=, Int32 #=zncvlaVU=, GraphicsContextFlags #=zQzjV$Ck=)
at #=zjtbDwLqK14NGAiLA3Y3SGUc=.OnHandleCreated(EventArgs #=zOR6kMCg=)
at #=zze2uL$ZDyfLAxFO$Y0dErTYWdkWS.OnHandleCreated(EventArgs #=zOR6kMCg=)
at System.Windows.Forms.Control.WmCreate(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmCreate(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at #=zyWC7LzuxR7OP7HtMRbUMiSw=.WndProc(Message& #=zkM3WRN4=)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
Video or screenshot showing the problem:



osu! version: 20170731.2
posted
Is this issue also prompted with a "Intel ICD OpenGL" error? If so, please make sure your Intel Drivers are properly updated and installed for your Integrated Graphics.
posted
Yes, it "Intel ICD OpenGL" error..I checked everything and it's all up to date.
posted
Nvm I didn't run Osu! with graphics processor...Btw thanks!
posted
So you fixed your issue?

For future reference and maybe future people reading, try uninstalling your intel drivers completely, and downloading the latest version manually from intel's site. This might work better.
Please sign in to reply.