1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
posted
Problem Details:
First things first, yes I have a good enough CPU and GPU to stream. This is (I'm pretty sure) not a hardware issue.

So as of the last two weeks I have encountered a problem the regards both obs and osu. When both programs are running, osu suddenly gets hit by a large sum of lag. This causes the frame rate to drop tremendously and also cause huge input lag. I have been able to stream just fine in the past with the "input lag" number sticking around 0.8-1.2 when streaming. I run windows 10 btw.

Things I have already done in an attempt to fix this:
-When I looked at task manager I saw that windows defender had suddenly jumped in cpu usage. Turning windows defender off actually helped the frame rate and stabilized it to a playable state, however there is still a significant amount of lag and sometimes I still can't hit 60hz.
-Something that may have caused the problem is installing a set of programs by rustbell labeled as "pen lag reduction". The problems occurred shortly after installing this so I'm wondering if this is the reason behind it. I have reversed all the affects the pen programs were doing however nothing has changed.
-This issue only affects osu and obs. All other programs run just fine with eachother (Tested programs include Elsword, Overwatch, and Minecraft)
-I've reinstalled both programs however the issue still stands

I'm not quite sure what the issue is. Task manager doesn't point to anything suspicious other than windows defender, however turning that off only solved half the problem. If anyone could help me think of a solution to this, I would deeply appreciate it!

Computer specs if people think it's a hardware issue:
-CPU: FX-8350
-GPU: GTX 950


Video or screenshot showing the problem:

Task Manager when both programs are running



These images are from the menu. I can't get to the song selection due to lag
Osu framerate (In window)


Osu framerate (Out of window)


What this should look like...



osu! version: 20171101cuttingedge
posted
Updates on problem:

Note 1: I did some testing and the lag does not occur when I am in compatibility mode. HOWEVER the lag is due to windows defender not freaking out. This means that normal osu has something causing a chain reaction to trigger windows defender. Compatibility mode does dodge this issue, however it doesn't eliminate the second lag factor that I am not sure what it is.
Edit: Same was found with fallback version.

Note 2: when lagging the game seems to want to hit 30fps and 33ms. This is the same framerate and ms I get when clicked off the window when obs isn't open. A possible reason is that osu isn't able to detect that I'm clicked onto the windows? Thats when the framerate is supposed to jump back up right?
That doesn't explain the major lag spikes though.
posted
Bump
posted
You do not need to bump your thread after 4 hours.

Do you get this lag only while recording or streaming, or does it occur only when you have OBS open? Same question for when you are previewing a recording or stream.
posted
It's once I open obs. The preview alone creates this issue
(Sorry about bump. I'm used to modding forums where stuff goes way too fast lol)
posted
Are you using OBS studio? Try removing your source or disabling to see if the lag still occurs.

If everything is working well on compatibility mode you might be able to try updating/reinstalling your graphics drivers. NVIDIA has also released a few driver updates recently. If you are set to automatically update, you might want to consider rolling back to a previous version of the drivers before this issue started occurring.
posted
Regarding the Nvidia drivers, I've found I was on version 382.53 from 6-8-17. Most recent it 388.12

I do use obs studio. I'll try out what you have suggested.
posted
Previewing something in obs that does not include osu does not cause lag. Moving over to a scene which includes previewing osu however triggers the issue. I also just found that the issue doesn't resolve itself after closing obs. I need to restart osu in order for the frame rate to recover.

I may have just found my answer to fix this problem though. I have been using game capture in order to record osu, however it seems like this issue does not occur with window/display capture. I have not tested this for an extended period of time, so I'll see how this form of recording osu fairs.
If I do run into issues while using display capture I'll come back here.
posted
Attempt your solution using the Stable build. Someone else made a post with the same issue and Stable improved performance.
posted
I have tested this with all available versions (except beta) of osu. The only versions that this issue doesn't affect are Fallback, and any version with compatibility version on.
Both Stable and cutting edge has this issue.
posted
Anything else that could have changed on your PC that may cause an issue such as this?
posted

Venzire wrote:

Anything else that could have changed on your PC that may cause an issue such as this?
I've listed all I know in the first two posts
posted
Well OBS does take up resources so its just normal to lag...
posted
I am currently having the same issue, obs and osu opened together cause osu to lag. I don't know what caused, but I will try out some things and write another post if anything works.
posted
then just write another post and not reply to an old thread!
posted
I recently just reverted back to http://www.geforce.com/drivers/results/114351 and the OBS/Osu! lag issue disappeared. I believe the issue lies with graphics drivers.
posted
Thanks for helping
posted
Not sure if people are still having this problem, but I maybe found a solution, just go to your nVidia Experience and go to Settings and disable Shadowplay. I've tested it out and it fixed it.
Please sign in to reply.