1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
Problem Details: i imported this: https://osu.ppy.sh/s/648563 beatmap and opened it in the editor where osu promptly crashed
so i opened it again in hope it wont again, but much to my dismay the map wasnt in my library anymore. so i downloaded and imported it again but osu wouldnt even load the map even after using F5. figuring osu is just being osu again i checked the songs folder and lo and behold the map was still in there so i deleted it restarted osu and imported the map again just to be disappointed once again

Video or screenshot showing the problem: most recently imported maps according to my songs folder https://i.gyazo.com/bee071a7d58f6f35103 ... 6c4562.png
most recently imported maps according to osu https://osu.ppy.sh/ss/9402841

osu! version: 20170731.2 (latest)
i love how literally noone gives a shit about this
Check the contents of the beatmap and make sure it has all the right components, is what I would do, but could be something totally different.
Pressing F5 and reloading all of your beatmaps should make the new imported map pop up. If it is still not appearing try closing osu! and moving "osu!.db" out of your osu! folder. Restart and it should automatically reprocess all of your maps.

The second issue you posted is probably unrelated to the first. Try running osu! as an administrator.
the second one is the same, i downloaded a map with a difficulty i didnt have before
it didnt import but it was still in the folder, so i opened another diff in the editor switched to the unimported one (which forever reason was listed in the editor but not in the song selection) and tried to save it which didnt work. that diff worked before, if i delete the new diff it shows up again after i re-import the map
the first map is showing up now however
Please sign in to reply.