1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
posted
I've been streaming using OBS for a while now but all of a sudden, whenever I start streaming, it lags a lot. I've been looking through other threads with the same problem as me but people keep suggesting to cap the fps to 120 or 240. The problem is, I could always run it at unlimited until recently. My settings are the same as they were when it worked perfectly fine. I don't know what's causing it but it's very obnoxious.


osu! version: 20160403.6
posted
Is the stream lagging, or is your actual game lagging?

Maybe try closing other programs in the background that are unneeded.
posted

Death wrote:

Is the stream lagging, or is your actual game lagging?

Maybe try closing other programs in the background that are unneeded.
The game is lagging. I have no other program opened when I stream and I have a i7 7700k cpu with a 1060 gtx so I really don't know what is causing the lag. It's like OBS is limiting my fps or something.

BTW are you in a kik group chat called "osu! standard players"? Someone has the same pfp that you have on osu lol
posted
Are you using Game Capture? And are you using OBS studio or OBS Classic?
posted

Death wrote:

Are you using Game Capture? And are you using OBS studio or OBS Classic?
Yeah using game capture and using OBS studio.
posted
You could try to use window capture to see if it makes a difference. There was also an NVIDIA driver update released yesterday, if you downloaded that update try reverting back to the old one, or perhaps if you didn't update, try updating to it?

You can also try using OBS Classic just to test if you still get lag. You might need to look around OBS studio for settings that could be affecting the game.
posted
just turn off this option on NVIDIA Experience and be happy with your stream :) .
https://gyazo.com/f27181d5751caf47163c599cb42be7da
posted
Edit: Fixed:


FrooZeeN wrote:

just turn off this option on NVIDIA Experience and be happy with your stream :) .
https://gyazo.com/f27181d5751caf47163c599cb42be7da
I don't even have GFE installed and all Windows game-related extensions are disabled such as Game Bar/Mode.
Everything's up-to-date and osu is still lagging at 200+ FPS while OBS is capturing it. Audio becomes a static mess and there's timing issues when playing maps so nothing counts. It used to be perfectly fine with the exact same OBS settings, but one of the osu updates last year screwed it all up. It is unplayable.
In-game compatibility mode somewhat fixes the audio static, but the game's FPS is still unplayable and it adds input lag. I've never needed this setting before either. Disabling fullscreen optimizations also does nothing and Nvidia Control Panel settings are essentially irrelevant.
And no I do not care about bumping a 2-month old """"resolved"""" thread when this has been the biggest problem with the game for months and has shown no signs of being fixed.
https://www.twitch.tv/videos/218523204 This is what's happening.
posted
Any osu! update that supposedly broke OBS was most likely coincidence, and it was something else on your computer that changed around the same time.

If compatibility mode slightly helps with the issue, I would recommend clean reinstalling your graphics drivers directly from your manufacturer's website.

If you are still experiencing the same issue, make a new thread with as much detail as possible please.
posted

Death wrote:

If compatibility mode slightly helps with the issue, I would recommend clean reinstalling your graphics drivers directly from your manufacturer's website.
Updated DDU, downloaded latest Nvidia driver, rebooted in safe mode, wiped drivers with DDU, rebooted, installed drivers, rebooted, redid monitors, color management, control panel, rebooted... nothing changed.
posted
OMFG. Okay, so I need to reply, because I found the cause, and it's been negatively affecting more than osu!..
The "Multi-adapter Compatibility" checkbox in OBS Game Capture caused all the lag....

I've had this checked for months, and not because I intentionally checked it, but I'm pretty sure I clicked it on accident while swapping games... Speechless.
Please sign in to reply.