1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
Problem Details:
Okay so, I recently just got back onto my computer from a six month hiatus. Prior to this leave I played osu! frequently, with little to no trouble on the technical end of things. Coming back to my computer, the first thing I go to is osu! to brush up and practice some, except, after installing the update I have run into the "No compatible audio devices detected. (Etc.)" Error. This is my first time encountering this so I try everything I can muster to fix the problem save wiping my hard drive and starting from scratch.

I have updated alll of my drivers, attempted disabling Nvidia GeForce Experience (Which has been known to cause problems with certain games for apparently no reason in the past), restarted my computer several times, made sure the correct audio device was selected (keeping in mind that I tried several different forms of output, and each one works in other applications), searched and searched on the web for anyone else experiencing this problem (Which led me to this forum post: t/535402 trying these suggestions helped none), tried playing with Stable, Stable (Fallback), and Cutting Edge versions, tried detecting audio problems through windows 10 trouble shooter (It mentioned something about Audio enhancers being disabled and asked if I would like to enable them. I did, no change.), tried several different USB ports, and Headphone Jack ports (Even through my monitor) and even installed wretched Windows updates. All to no avail.

Needless to say I am quite frustrated with this as I seem to be at an impasse. I Just really really want to click those circles and the few hours I have free have been spent trying to get this cursed program to recognize it's fallacy. PLEASE Help me! I'll do anything at this point, but I would like to avoid wiping my hard drive and starting over if that were possible.

Specs: Motherboard: Asus z170-A
CPU: Intel i5 - 6600k
GPU 1: Asus Strix GeForce GTX 980 4GB
GPU 2: Msi GeForce GTX 960 2GB
Soundcard: Integrated with MOBO
RAM: G.SKILL Ripjaws V Series 16GB (4x4GB)
HDD: Western Digital 3TB something another
SSD: Samsung 850 EVO 250 GB Internal SSD - 2.5"
OS: Windows 10 Who cares I'm too tired to find out edition
Monitor: BenQ GL2760H
Headset: Razer Kraken Chroma 7.1 (I'm due for an upgrade)

Again thanks in advance and sorry for the wall of text,

osu! version: 20170731.2 (Latest)
This is a shot in the dark, try disabling surround sound in both Windows and whatever Razer program you may have installed for your headset.
Well That's rather odd.. my headset is not showing up on my synapse.. I'll try to trouble shoot that first and see if that resolves it.
Update: Internet suggested I reinstall drivers for the headset. No change, so I'm reinstalling Razer synapse, we will see if that has any effect. :?
Update / bump: reinstalling synapse made it recognize my headset, however no change with osu!
Now that you have reinstalled that, make sure your headphones are still the default output device. You can also try changing the output device in osu!'s settings to one of the other options it provides.

If that doesn't work, hold shift while starting osu! to open the repair dialog and hit "repair osu!"
I double checked that headphones are selected as default output device. However osu! only has one option for device output, that being 'Default'. Repairing osu! also did not work, I have tried that multiple times.
Try to reinstall your audio drivers completely, instead of updating them.
Have you this problem when you are using other headphones/speakers?
Yes: "I made sure the correct audio device was selected (keeping in mind that I tried several different forms of output, and each one works in other applications)"
I did a complete reinstall of my drivers as well, uninstalled and reinstalled them several times, no luck.
Have you tried plugging in a different audio output device?
Yes I have, same response.
bump. problem still not solved :(
After you reinstalled your drivers, did you check one more time for surround sound?
The 'surround sound' on my headphones can't be disabled because it is how they are designed for some reason. It is not enabled in Windows though. Regardless, the surround sound has not caused a problem before.
Bump/Update: It appears the problem with my game was nothing to do with the game and some sort of incompatibility with windows. There was a large Windows update which allowed osu! to work. Yay?
Remember to update and restart your PC kids ;)

It was most likely Windows trickery anyway
Please sign in to reply.