1. osu!community
  2. osu!
  3. Help
posted
Thefiashmaster can you please make a youtube video for us to show how to do it please!!!!
posted
I found why my osu wasnt working (This is the second time this has happened and i believe it was the same reason why it didnt work the first time).
After playing with the wineskin stuff, it said i was missing something about a gecko (gecko from wine hq) after that, i clicked install as it was missing, it downloaded and osu opened up working like normal once the download finished. https://imgur.com/a/a1AkI that is my set screen options (if it will help anyone) and my engine is WS9Wine 2.22.
posted

Exyonite wrote:

Thefiashmaster can you please make a youtube video for us to show how to do it please!!!!
Sorry for the wait. I was a bit busy, but I finally got a video up. I should warn you about a couple of things:
There is one error I had. Once you extract the exe, MAKE SURE YOU DELETE THE MACBOOK REMAINS, AND CLEAR TRASH.

I also learned that try not to put too many songs into the song folder at once. For some reason, it doesn't pick up that songs are in the folder. I suggest about 20-30 at a time.

Otherwise It should work.

https://www.youtube.com/watch?v=hRDRSSJd3fY
posted
Osu works on HIgh Sierra as longest you know what to do about it. It took me almost 3 months now to fix it after the damn update. Just Download and install PortingKit
posted
GUYS I HAVE FOUND A PROPER FIX FOR OSU ON HIGH SIERRA!!! Found by accident once I had already given up trying to get Osu to work on HS but follow the steps on this YouTube video and it works. Apparently High Sierra stops Wineskin from acknowledging your GPU and this tricks it into doing so.

https://www.youtube.com/watch?v=RDjWNWM3Y7w&list=LLYiUjN5b7vj3_B6s44LU2Pw

Thanks god for this Spanish dude

Hope I helped y'all out

BadgerBeats
posted
Somehow, i did something random on porting kit and it worked:

open osu in porting kit library
click on osu! (add it in if its not there[??])
click on more
click debug

idk what happened lol but it opened, im running it on high sierra.
posted
Even with all of the help Osu gets stuck updating and then crashes. :(
posted
3. Once the wrapper is created, open the wrapper, go to Advanced --> Tools --> Winetricks and search for "dotnet40", click the checkmark and hit "run" This installs .NET Framework 4.0. (This will take a while)
When I selected "dotnet40" and hit run I was greeted by the following message:

warning: taskset/cpuset not available on your platform!
------------------------------------------------------
wine cmd.exe /c echo '%ProgramFiles%' returned unexpanded string '%SystemDrive%\Program Files' ... this can be caused by a corrupt wineprefix, by an old wine, or by not owning /Applications/WS9WineStaging2.16.app/Contents/Resources
------------------------------------------------------


Any clue on whats happening and how it can be resolved?
posted

PixelArray wrote:

I've got osu! running on macOS High Sierra (10.13)

Sorry for the not-so-detailed instructions, but here's a basic guide...

If you have an osu!.app that doesn't work, don't delete it just yet.

1. Download and install PortingKit

2. In PortingKit, create a new wrapper called osu (File --> New Custom Port) on the WS9WineStaging2.16 engine and Mac Driver Window System.

3. When prompted to select an installer, click cancel, yes, then cancel again. (You'll get a warning, that's fine)

3. Once the wrapper is created, open the wrapper, go to Advanced --> Tools --> Winetricks and search for "dotnet40", click the checkmark and hit "run" This installs .NET Framework 4.0. (This will take a while)

4. Download the windows osu! installer from here.

5. Go back to the wrapper, and go to Install Software --> Choose Setup Executable and choose the osu!install.exe file.

6. Let osu! install into the default directory.

7. osu! will automatically open after it installs. Exit out of it.

8. For some reason, wineskin doesn't detect the launch exe, so you'll have to go to the wrapper --> Advanced --> Windows EXE and look for the osu!.exe file. (The directory should be /users/Wineskin/Local Settings/Application Data/osu!/osu!.exe)

9. Close out of the wrapper and open the osu.app itself.

10. Login and you should be able to play.

If you have an existing osu!.app and want to transfer your beatmaps and skins

1. Right click --> Show package contents of the old osu.app and go to drive_c and find the osu! folder where your beatmaps and skins folder are.

2. Copy the beatmaps and skins folder and go in drive_c to the osu! folder in your new osu.app then paste (and replace).

3. Delete your old osu.app

Note that osu may be laggier than it was in Sierra. However, it seems that all games seem to be running at lower fps since the update. Thanks Apple...

EDIT: Revised instructions
It used to work fine for me but now I'm randomly getting this message:

Error occured (please report this!):\n\nSystem.ArgumentException: Illegal characters in path.
at System.IO.Path.CheckINvalidPathChars(String Path)
at System.IO.Path.Path.InternalCombine(String path1, String path2
at System.IO.FileSystemEnumerableIterator`1.CreateSearch
localSearchData, WIN32_FIND_DATA findData)
Etc.

Why does osu not want to work anymore?
posted

Keroshibou wrote:

It used to work fine for me but now I'm randomly getting this message:

Error occured (please report this!):\n\nSystem.ArgumentException: Illegal characters in path.
at System.IO.Path.CheckINvalidPathChars(String Path)
at System.IO.Path.Path.InternalCombine(String path1, String path2
at System.IO.FileSystemEnumerableIterator`1.CreateSearch
localSearchData, WIN32_FIND_DATA findData)
Etc.

Why does osu not want to work anymore?
This is an issue that is not specific to macOS.

Death wrote:

Here is a list of the Windows illegal file name characters:
\ / : * ? " < > |

First, make sure none of these characters are in your path to osu!

Open your Songs folder and make sure none of those characters are in any of individual song folders, including the files inside them. Do the same thing for your Skins folder.

If you have a lot of songs and skins, check your newest files first. Specifically, any you can remember importing the last time you were able to run osu! without issues.
posted

Death wrote:

Keroshibou wrote:

It used to work fine for me but now I'm randomly getting this message:

Error occured (please report this!):\n\nSystem.ArgumentException: Illegal characters in path.
at System.IO.Path.CheckINvalidPathChars(String Path)
at System.IO.Path.Path.InternalCombine(String path1, String path2
at System.IO.FileSystemEnumerableIterator`1.CreateSearch
localSearchData, WIN32_FIND_DATA findData)
Etc.

Why does osu not want to work anymore?
This is an issue that is not specific to macOS.

Death wrote:

Here is a list of the Windows illegal file name characters:
\ / : * ? " < > |
First, make sure none of these characters are in your path to osu!

Open your Songs folder and make sure none of those characters are in any of individual song folders, including the files inside them. Do the same thing for your Skins folder.

If you have a lot of songs and skins, check your newest files first. Specifically, any you can remember importing the last time you were able to run osu! without issues.
Thanks a lot man! It worked for me. Aside from that I had another problem I solved because wineskin didn't select mac driver when I did while creating a new wineskin so I had to do it manually.
posted
What Happened is umm My Osu is on El capitan when im using the Porting Kit and my mac is High Sierra :shock:
posted

thefiashmaster wrote:

I found a way to work osu, but before you do this way, try the other techniques. This way is a bit tedious, but it gets the job done. There will be some unesserary steps, but the way I did it, it worked.

1. Download PortingKit (http://www.PortingKit.com)

2. Download both the recent mac and windows versions. (I'm not sure if you need to have the windows, but download it anyway.)

3.Do an show package contents on the mac version, remove the osu.exe, and place both the osuinstaller.exe and osu.exe on the desktop.

4.In PortingKit, create a new wrapper called osu (File --> New Custom Port) on the WS9WineStaging2.16 engine and Mac Driver Window System.

5. During the installation, change the location of the wrapper to the desktop. (Not needed, but will come in handy later)

6. When prompted to place an installer, put the osuinstaller.exe and when prompted to place an exe, put the osu.exe

7.Then with the wrapper, go to Winetricks and download dotnet40.

8.THIS IS VERY IMPORTANT. Create a new folder on the desktop called osu or a name you will remember.

9.When it is downloaded, press place on PortingKit or the wrapper on the desktop.

10. ALSO IMPORTANT. When osu! is installing, at the bottom there should say "osu! is installing at..." Change the location to the folder you made on the desktop.

11. The game will start up, but it will need to install an update. Do this.

12. Wait for the game to download the pre- downloaded songs, then exited out.

13. Repeat steps 10-12. You will ALWAYS need to change the location to the folder you made and it will ALWAYS tell you it needs an update. If you don't get the update, then it will not allow you to see online scores and such.

14. In the folder is the files of osu!, this is the only way to download new songs. For some reason, the game will not allow you to exit full-screen. Put the new songs in there, and when you start up the game after changing the location, the songs should appear.

Now that should be the steps. It is a bit inconvenient, but it will work. Make sure you change the location ALWAYS because if you don't than it will go to its original location, the songs will not be there. Also, in the settings, if you want to fix the frame rate, go to the settings to removed dropped frames, but this is important. DO NOT PUT ON COMPATIBILITY MODE. It will crash the game, and you cannot open it again.

Hope this helps, if you have any questions, feel free to ask.
Yo i cant download Beatmaps for osu on my Porting kit and Also my Osu in my Porting kit says when it opens "Osu! ElCapitan"but im using High Sierra What did i do wrong?
posted
Porting actually works lmao :)
posted

Een Persoon wrote:

a0206021 wrote:

There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
When I do it, it keeps running the osu!updater over and over. I'm using the alpha release from http://osuosx.tumblr.com/. Is there a reason to why this happens?
Same problem for me
posted
posted
Funny that I didn't update my computer so its still 10.12.6 so I was able to download and play Osu!
I was very lucky for this....
jeezus
posted
I have a lot of problems.

I bought mac almost 2 months ago and I wanted to install osu!. I updated my macOS to High Sierra.

I installed osu! from this tutorial: https://www.youtube.com/watch?v=hRDRSSJd3fY and I could play it.

But I couldn't connect to my account. It was my only problem.

2 weeks ago osu! started updating. When I opened osu!, it was an old version and it started updating. When I restarted osu!, it was an old version again.

A few days ago my osu! started lagging. Today I tried to do something with that. I tried to change my settings.

When I clicked on one of these, osu! turned off. When I tried to open it, I saw "Unable to find a version of the runtime to run this application".

So I can't play osu!.

What should I do to fix problems?


Edit: I haven't red it earlier: "DO NOT PUT ON COMPATIBILITY MODE". So I did it...

Can you help me?
posted

Death wrote:

Keroshibou wrote:

It used to work fine for me but now I'm randomly getting this message:

Error occured (please report this!):\n\nSystem.ArgumentException: Illegal characters in path.
at System.IO.Path.CheckINvalidPathChars(String Path)
at System.IO.Path.Path.InternalCombine(String path1, String path2
at System.IO.FileSystemEnumerableIterator`1.CreateSearch
localSearchData, WIN32_FIND_DATA findData)
Etc.

Why does osu not want to work anymore?
This is an issue that is not specific to macOS.

Death wrote:

Here is a list of the Windows illegal file name characters:
\ / : * ? " < > |

First, make sure none of these characters are in your path to osu!

Open your Songs folder and make sure none of those characters are in any of individual song folders, including the files inside them. Do the same thing for your Skins folder.

If you have a lot of songs and skins, check your newest files first. Specifically, any you can remember importing the last time you were able to run osu! without issues.
Hi Death, the problem has occured again as I was stupid enough to accidently remove the Localisation file. The message started to pop up again so I had reinstalled the porting kit, remade the wrapper and reinstalled osu!install.exe.
When I start it up (after selecting choosing setup executable) the same message pops up and a new locatisation file is created while opening osu. I've noticed that the localisation file contains a file called: nl.txt which conatined a full translation of osu! in dutch (my language). The file contained a lot of forbidden symbols, thus I removed them but there was no positive result. The message pops up again while there has not even been an osu! folder been made yet so I do not have my skins, songs folder, replays, screenshots etc.

I was hoping you could inform me about this or/and give me advice on how to solve this problem.
posted
Please make a new thread for your issue.
Please sign in to reply.