1. osu!community
  2. osu!
  3. Help
posted

silverlightcs wrote:

Loucoh wrote:

No new executables found!

Maybe the installer failed...?

If you tried to install somewhere other than C: drive (drive_c in the wrapper) then you will get this message too. All software must be installed in C: drive.


how can i resolve the problem???
I'm getting the same problem here.
Around when in the process does it happen? If it's after osu! installation, then that's normal. Step 8 should fix that issue.
posted
After I select the osu!install.exe file for the Setup Executable (step 5), a few seconds pass and I get that error message.
posted
Found another good way to fix this problem.














Buy a windows computer
posted
Same for me. When I go to Install Software then go to drive_c > users > wineskin > Local settings > Application data > osu! > osu!install.exe I get this error.
posted
Can't work ...
posted
you can install windows through bootcamp utility
posted
I built a stable version a while ago and it's on github
https://github.com/Mic238/osu-for-Mac-Stable-Latest
posted

Mic238 wrote:

I built a stable version a while ago and it's on github
https://github.com/Mic238/osu-for-Mac-Stable-Latest
Thank you! Just one question, when using this version, I can't switch desktops (swiping with 3 fingers to the left/right or clicking the buttons at the top to show the different windows), is there a way to do that?

[Edit]: it seems that when I close the app, it doesn't let me open it again. (.NET framework Initialization: Unable to find a version of runtime to run this application.) I think this is because it automatically updates when opening it again, is there a way around that?
Update problem seems to be gone now (not exactly sure how, but I did change to stable/latest version if that was related).
posted
You can try pressing CMD + TAB and it will switch the applications. Then you can swipe to the side.
posted
You guys can use a VM (Virtual Machine).

For example buy (or crack) or try it for 14 days "Parralels Desktop" or something like this.
If you want follow these instructions.
1. Download (or crack) or try the newest version of "Parralels Desktop" (older versions don't work with Mac OS High Sierra)
->https://www.parallels.com/
2. Download the Windows installer with from the Windows-website.
-> https://www.microsoft.com/de-de/software-download/windows10ISO
3. Open "Parralels Desktop". It will ask you to install a OS.
4. Choose "install Windows oder another OS from DVD or Image file"
5. "Parralels Desktop" should display your OS-installers. If Windows isn't there then click on select and choose your .iso image.
6. Then click on continue and Windows will ask you wich OS settings you need.
7. If you have that finished Windows will install. This will take a few minutes. (this works faster if you have a SSD-disk)
8. You are done. Have Fun with Windows on Mac and working osu!.
If you have a low framerate in osu! then choose another skin that works fine. :)
For tablet users: Your VM detect your tablet as a mouse so it does weird things.
Simply move you mouse up to your menu bar and choose devices. And choose your tablet. (For me it was "Tablet Monitor")
If you want you can try the new osu!latzer (scroll down and choose "install.exe")
-> https://github.com/ppy/osu/releases

I hope I could help you. ;)
If you have any questions then reply on this tweet.
posted
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
posted

a0206021 wrote:

There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
Works perfectly!!! Thanks so much!!!
posted

a0206021 wrote:

There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
No, don't works :c
posted

a0206021 wrote:

There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
It worked! Thank you so much!
posted

a0206021 wrote:

There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
Thank you!!! It works!
posted

a0206021 wrote:

There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
Does it matter what version of osu i'm using? I'm currently using the alpha release from 2016...
posted

frankengwenny wrote:

a0206021 wrote:

There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
Does it matter what version of osu i'm using? I'm currently using the alpha release from 2016...
No it doesn't.
posted
god bless PixelArray
posted

a0206021 wrote:

There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
mine doesn't work either.... :(
posted

Gerardoesp wrote:

a0206021 wrote:

There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
The above method works. Porting Kit is also useful to update the WineSkin version. WS9WineStaging2.16 works for me. Once Porting Kit is downloaded, use PixelArray's methods through 1,2,3,3 to download the newest wineskin. Then, go to the original osu!.app, right click-> Show Package Contents -> Double click on "Wineskin" -> Advanced -> Tools -> Change Engine Used -> Select "WS9WineStaging2.16" -> OK. Wait to complete. Finally, follow a0206021's method. This should work.
Please sign in to reply.