1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
To start off my problem, it seems that even though my AMD Radeon R9 200 graphics card is on the latest driver and my computer has DirectX 12, osu! requires me to run Open GL because I apparently don't have and Shader Model that is 1.1+ (Even though AMD Radeon R9 200 and DirectX 12 should have Shader Model 5/5.1...). I didn't think this was a problem but, when I opened osu! it told me I was on the latest fallback, it still didn't seem like a problem...I signed in and it asks for verification so I verify my account...it asks for verification again...I verify my account...it asks for verification again-you get the point lol. I decided, it's maybe just a glitch and it will fix itself in time. So I go to play solo since I can't play online without account verification, and I notice when I get back to the main menu ^^; a bit of the...everything is missing. I exit the game and decide to re-open, and it says the same stable fallback click here to update sign into your account stuff. I decide maybe clicking the change to stable latest would help, so it downloads the files and I reopen osu!...it says its on fallback again...I download the files again...it says its on fallback again...I download the files again ^^; it was becoming more redundant...I read in another post on here that it could be my graphics card drivers but everything turned out okay, so I decided to post here after opening osu! with shift to change somethings. I realized that opening osu! with DirectX wouldn't work so I put Open GL, fullscreen, and Stable (latest). I opened fine and said it needed to update so I update osu!. It opens...on fallback. I do the open osu! with shift thing again and this time, when I choose Stable (latest) it doesn't let me open the game ^^; please help I would very much like to fix the redundant updating and verifying and dxdiag running :cry: This worked on my previous computer, same OS, AMD Radeon as well.

osu! version: b20160403.6
Are your Graphics Drivers properly installed and updated? They could be borked. I'd look into updating / reinstalling them maybe.
As i have stated, the drivers are on the latest update. I could try to uninstall them and then reinstall the drivers.
Nothing has changed. It will only allow me to use Open GL and Stable (Fallback) and I get the same error when trying to use DirectX. Reinstalling hasn't effected it very much... :(
Please sign in to reply.