1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
when i launch the game, it says ''Can't find the name of Intel icd OpenGL driver''

here is the error thing: OpenTK.Graphics.GraphicsContextException: [EGL] Failed to create window surface, error BAD_NATIVE_WINDOW.
en OpenTK.Platform.Egl.EglWindowInfo.CreateWindowSurface(IntPtr config)
en OpenTK.Platform.Egl.EglContext..ctor(GraphicsMode mode, EglWindowInfo window, IGraphicsContext sharedContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
en OpenTK.Platform.Egl.EglAnglePlatformFactory.CreateGLContext(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Boolean directRendering, Int32 major, Int32 minor, GraphicsContextFlags flags)
en OpenTK.Graphics.GraphicsContext..ctor(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
en #=qH8MHUwc4s4AIOP8embIm_LZVJ1hcXHmXvQ4kbKKaWdXEAILiwIKAGYcIN5xQJXaQ.#=qqvWHIjTJ11kNQjXagY2F3Q==(Int32 #=qziYoDwk$PYjdOkqhyQIonw==, Int32 #=qAxkx7SJqQSowL0CnPp7gGg==, GraphicsContextFlags #=q0r5I1MdApGtJ54aGgOdCjQ==)
en #=qJlnuD_UcXRoElpm2icUN$xv4mHIVbAIXw0qJaXX4M17Nt6UwoiS1Agm0IcyQ69sI.OnHandleCreated(EventArgs #=q3m$_0fTukzAo40eVgKKt8A==)
en #=qmcB6XnfGcdT$_fSIuP8CBToueKpBlR5PlfKTI7deIJL42oV_a3A$j0BVEdXueDJp.OnHandleCreated(EventArgs #=q3m$_0fTukzAo40eVgKKt8A==)
en System.Windows.Forms.Control.WmCreate(Message& m)
en System.Windows.Forms.Control.WndProc(Message& m)
en System.Windows.Forms.ScrollableControl.WndProc(Message& m)
en System.Windows.Forms.Form.WmCreate(Message& m)
en System.Windows.Forms.Form.WndProc(Message& m)
en #=qi17YWq5DpjzsdfsVCMbOCKlTKzi5JL1aNh1uHTzjAi0=.WndProc(Message& #=qKFgFOP_7pGMr0NtKdRHygA==)
en System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
en System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


osu! version: 20170222.3 (latest)

Dntm8kmeeatu wrote:

This is only a Temporary workaround.

Go into your osu!.PCNAME.cfg file and change Fullscreen from 1 to 0. Save, and then relaunch osu!

Playing without fullscreen is normally not recommended due to how Windows forces DWM buffering and creates a feeling of input delay.

If you are 7 or Vista, you can disable this by disabling the Windows Aero theme. It's completely forced on 8 and 10 and cannot be disabled.
See if that don't do the trick for ya;
I don't know if this will work for you or not, but for me it work perfectly fine.

Go to where you locate your osu! game file, then you will see two .cfg file one is 'osu!.cfg' another one is 'osu!.(your PC name).cfg'. Click on the 'osu!.(your PC name).cfg open it with notepad. Next click 'Edit' on the top then click 'Find...' type in 'CompatibilityContext' then click find next after that you will see 'CompatibilityContext 1' change it to 0 then click 'save'.

then I start the game and it run perfectly fine :)

Hope this help you
(sorry for my bad English xD)
well, it worked, but i rebooted the pc and the cfg file was blank, then i decided to reinstall osu, but the error continues
Looks like there isn't an actual solution to this by now
Try installing with the old installer
8-) I have the same problem and same error code here.
i got that after my lastest Intel Graphic driver auto update.
I try both solutions but it still not work. :o:o:o
Looking for help!!!

ha_jinjin wrote:

8-) I have the same problem and same error code here.
i got that after my lastest Intel Graphic driver auto update.
I try both solutions but it still not work. :o:o:o
Looking for help!!!
Try downgrading your driver version or rolling them back if possible.
WELL, it actually worked, and for the newcomers, it's a problem with the updated Intel graphics 520 driver you just need to roll them back

THANKS Dntm8kmeeatu
Hey, so I got the same error, but I have no idea where my game file or my files for the game are located, what should I do? I just wanna play, but it shows 2 of the same error, then crashes.

Your osu! folder is located in this path by default: "C:\Users\<Username>\AppData\Local\osu!"

Try following this:

Death wrote:

Please make sure your Intel graphics drivers are up to date. Intel released a fix for this specific issue in all of their driver versions 15.46 and higher. If you get your graphics drivers through a computer manufacturer, they may use a different versioning scheme and their most recent drivers may still have this issue. It is good idea to download them directly from Intel's website.

Temporary solutions include: Running osu! with integrated graphics and disabling compatibility mode if applicable. It is highly recommended you fix this issue permanently by downloading up to date drivers.

If you believe you have enabled compatibility mode, navigate to your osu! folder and edit the file "osu!.pcname.cfg". Verify that the line "CompatibilityContext" is set to 0. If it is not, change it and save the file. Otherwise, this was not the cause.
If you are still having issues, please make a new thread instead of bumping one that is a year old.
Please sign in to reply.