1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
Problem Details:Obs will not stream osu! regardless what settings i try. Obs' render is already set to Direct X 11. I have tried game capture and all i get is a black screen. I have tried window capture but i don't even get the option of selecting osu. I assume unless i drop a crap-load of cash into a streaming program (which i can't afford) then i can forget about streaming this game? I've googled left and right how to resolve this issue and most have been lucky and all they had to do was just switch to direct x because they were using openGL but in my case i'm already using direct x so..

Video or screenshot showing the problem:

osu! version: 20170222.3 (latest)
Are you sure you've it as capturing game? Have you setted osu! window when you click right mouse button on your source?
Yeah i'm positive. Black screen with every mode and i'm highly annoyed by it.
I sometimes need to reset the game capture for osu!, auto detect seems to work for me but it takes time to detect it, but I get a black screen too on OBS for a short time regardless of how I set it before it displays. Have you waited around 30 seconds or so after toggling into osu! to see if it displays on OBS?
Please sign in to reply.