osu! (OS X) beta release

posted
Total Posts
1,387
show more
ShinzuiSin
The .dmg file is not working because the image is not recognised. Can anyone help me? I'm on the mac osx 27 inch/
Agrrox
Message has been deleted.
Agrrox
Message has been deleted.
mdr

Agrrox wrote:

Fucboi wrote:

Hello, since the Yosemite update Osu has been capped to 60FPS and the cursor is like laggy. However, sometimes, at the start of Osu, it does start at 120FPS which is the value I chosed, but after like 20 seconds, it goes back to 60FPS with the "laggy" cursor. I'm pretty sure the problem is from Yosemite because it's since this update that I got the problem, for info I'm playing on a Macbook pro 15" Retina from late 2013 with Intel Iris Pro Graphics

Have any of you experienced the same problem?

Thanks
try this

right click osu application found in finder.
click open package contents.
click on wineskin.
click on "advanced" option
click on "tools" option
click on "update wrapper"
once thats done click on "Test Run".
Thanks for the answer, my wrapper was already updated so there was no new update, however I did some research and found that the same problem also occurred on CS:GO, and probably more other games. I guess we'll just have to wait for a fix from Apple since a downgrade isn't possible
Twikzer
I have a Mac Boock pro Retina 13¨ end 2013 top of line (i7 2,8 GHz, 500G SSD PCI, (8G DDR3 1600 MHz), and with a wacom into pend an touch, and the game is imposible to play, is full of lag. But in a iMac medium size early 2009 or 2008 (i5 or i3, 8G kingston DDR3, 350 G HDD), i not remember now, it work perfect, and with the same wacom, but with old osu.



Edit:
ok, i try in a hackinthos with a i7-5960X 3,5 GHz, HyperX Predator (4x8G) 32G DDR4 2133 MHz, 2x GTX 780 DCII OC, booting in a seagate barracuda 1T 7200 rpm and it was the same results tan the mac book.

but in a windows 7 ultimate x64 with i7-5960X oc 5,2GHz, HyperX Predator 32G DDR4 3000 MHz, 2x GTX 780 DCII OC, booting in a HyperX 3K SSD 120G, but osu in a seagate barracuda 3T 7200 rpm it work perfect
xypherwaru

Fucboi wrote:

Hello, since the Yosemite update Osu has been capped to 60FPS and the cursor is like laggy. However, sometimes, at the start of Osu, it does start at 120FPS which is the value I chosed, but after like 20 seconds, it goes back to 60FPS with the "laggy" cursor. I'm pretty sure the problem is from Yosemite because it's since this update that I got the problem, for info I'm playing on a Macbook pro 15" Retina from late 2013 with Intel Iris Pro Graphics

Have any of you experienced the same problem?

Thanks
Same thing on mine. When I updated to Yosemite, Osu just capped to 60fps all of a sudden. I'm not really sure if Apple is even aware of this issue. I just hope it can be fixed by a client update or something. Maybe a wrapper update? Well, I tried to update mine but it just gives an error and tells me to just do a manual update. I really don't want to mess with anything cuz things might get chaotic.

Sometimes if I'm lucky it does go back to 120fps. But most of the time it's capped.
Kurogamii

Twikzer wrote:

I have a Mac Boock pro Retina 13¨ end 2013 top of line (i7 2,8 GHz, 500G SSD PCI, (8G DDR3 1600 MHz), and with a wacom into pend an touch, and the game is imposible to play, is full of lag. But in a iMac medium size early 2009 or 2008 (i5 or i3, 8G kingston DDR3, 350 G HDD), i not remember now, it work perfect, and with the same wacom, but with old osu.



Edit:
ok, i try in a hackinthos with a i7-5960X 3,5 GHz, HyperX Predator (4x8G) 32G DDR4 2133 MHz, 2x GTX 780 DCII OC, booting in a seagate barracuda 1T 7200 rpm and it was the same results tan the mac book.

but in a windows 7 ultimate x64 with i7-5960X oc 5,2GHz, HyperX Predator 32G DDR4 3000 MHz, 2x GTX 780 DCII OC, booting in a HyperX 3K SSD 120G, but osu in a seagate barracuda 3T 7200 rpm it work perfect
hahaha, hackintosh...
my 21" late 2013 iMac is better than hackinthos with a i7-5960X 3,5 GHz, HyperX Predator (4x8G) 32G DDR4 2133 MHz, 2x GTX 780 DCII OC, booting in a seagate barracuda 1T 7200 rpm, never mind

it crashed after i added some beatmaps to "osu! ▸ Contents ▸ Resources ▸ drive_c ▸ Program Files ▸ osu! ▸ Songs"
Teduh
Since updating to yosemite, my Osu just won't open. It shows the icon in the dock for 2 seconds and then disappears. Activity monitor says it's still running though...

EDIT: Downloaded new installer and updated wine same problem. Except after it says updating installer the icon just sits there now. Waited 10 minutes nothing popping up .-.
Mulle
this works pretty good, why the 120fps cap tho?
Agrrox
Message has been deleted.
LuCy200131
It is working in android too ? If in andoroid now goodbye for my laptop :3
Novixion
I haven't had any issues with Osu! since the update to OS X Yosemite.

Mulle wrote:

this works pretty good, why the 120fps cap tho?
You have to manually configure another frame limit in the config folder.
Teduh
Heh, am I the only with issues then? .-. I've tried reinstalling the game so many times and nothing seems to be working.

Also what are the osu!.desktop and osu!.lnk files supposed to be?
Invinciblejo
Hi, I would like to create a beatman but when i click on the edit button my screen turns blue. I waited 10 minute but nothing happened. Can somebody help me ?
Agrrox
Message has been deleted.
Invinciblejo

Agrrox wrote:

AbootCanada wrote:

Heh, am I the only with issues then? .-. I've tried reinstalling the game so many times and nothing seems to be working.

Also what are the osu!.desktop and osu!.lnk files supposed to be?
Delete those files, they belong to windows and not to mac osx.

Invinciblejo wrote:

Hi, I would like to create a beatman but when i click on the edit button my screen turns blue. I waited 10 minute but nothing happened. Can somebody help me ?
Osu beatmap editor works only in windowed mode, this true for both windows and mac.
Thanks for help .
senorturtle
Help!
I have the newest version of OS on my macbook air 13 inch and im getting the following error (never played osu! on my mac):

ERROR! cannot write to Info.plist, there are permission problems, or you are on a read-only volume.

This cannot run from within a read-only dmg file.

Can someone help?
Thanks
Teduh

Agrrox wrote:

AbootCanada wrote:

Heh, am I the only with issues then? .-. I've tried reinstalling the game so many times and nothing seems to be working.

Also what are the osu!.desktop and osu!.lnk files supposed to be?
Delete those files, they belong to windows and not to mac osx.

Invinciblejo wrote:

Hi, I would like to create a beatman but when i click on the edit button my screen turns blue. I waited 10 minute but nothing happened. Can somebody help me ?
Osu beatmap editor works only in windowed mode, this true for both windows and mac.
I've deleted those files but Osu! still refuses to launch aside from the updater.
lnjohn
seems like that it doesn't fit for OS X Yosemite :o
I updated my Operation System recently, and found that it shows error:
Novixion
With the latest release for CuttingEdge, I really really love the new update and the new style of Osu!

Bug to report: Constantly asking for a client restart despite clicking on them all the time.
Won't allow reversion to Stable.

Otherwise everything is fine.
Running Yosemite
show more
Please sign in to reply.

New reply