1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
show more
posted
Maybe this update could be the problem
posted
I have found a lot of threads that concern the KB3197954 update, and most of those problems were addressed with another game throwing in the same error.
The difference is what fixed it was through updating Java which I don't think helps here, since osu! Doesn't heavily rely on Java.
I have also taken note that there isn't a really definitive fix for this, since it's really specific in a certain degree.

OBDavid wrote:

Maybe this update could be the problem
Translation: Update Installed Successfully
I have found articles that relate to updating of drivers obtained through Windows Update and the error appearing.
Yet it was for a failed update, and the articles are really old.
https://m.reddit.com/r/vaio/comments/3y ... iver_help/

average_mitch wrote:

I factory reset my computer because it just wasn't up to snuff and I wanted to make sure everything had been properly installed, etc. Anyway, I bought it with Windows 8, so a few updates were required (23). After successfully installing 22 of the 23 updates, one would not install...
  1. Intel HD Graphics Family / 4400 Update, Version 10.18.10.3316

A message appeared with the title:
"Can't find the name of Intel ICD OpenGL driver"
Followed by the message:
"Intel HD Graphics Family / 4400 Update, Version 10.18.10.3316 did not update"
https://github.com/LWJGL/lwjgl/issues/119

4rz0 wrote:

I can confirm Case 2.
Specs:
  1. Windows 10 Pro release, most recent (10.0.10240)
  2. JRE 1.8.60 x64
  3. Intel HD Graphics 3000
  4. Intel drivers from May 2015, obtained trough Windows Update (9.17.10.4229)
Take note that they are really old articles, with the case of updates being the sole cause. Since they're old, you can't say that the problems caused in the links are the same exact here. However, I have reason to believe it could have caused it again.
t/518686

cherrypie01 wrote:

I have tried everything there but those didn't help. It seems for some reason my Intel graphics driver deleted itself or something. I recovered to a week ago and the problem seems solved. Maybe a Windows update caused it? Anyway thanks for your help.
The cases above and the circumstances are very close, with the same OS version and with Intel HD

feedthebeast wrote:

I took a stab in the dark and shut off the Xbox Game bar integration by turning off the DVR options completely. Low and behold, it worked. It seems that there may be an issue for some people that when the DVR is enabled (which it is by default)

NeVe12p4wNeD wrote:

Kao wrote:

See if this thread helps
t/518686
Are you serious? Really?

You wanted me to start another thread only to be redirected to the same one I was on? REALLY??????

Please go away. You're not helping at all.
This link was for OBDavid, sorry if that looked like I was tricking you. But the log shown was same of that thread.
His problem is the same now in that thread. With the problem caused by an update.

Pawsu wrote:

Huh. This seems to be an occurring error lately.
Hold shift while opening osu!, and when the recovery dialog opens, try enabling the option "compatibility mode". This do anything? If not, try switching to Stable(Fallback). Any luck there?

OBDavid wrote:

Same problem


Processor: Intel i5 6300HQ
Graphiccard: Nvidia Gtx 970M
Windows 10
I don't think this is the same problem. I'd make a new thread for your problem.
I think they're the same t/518686 this thread where OP first posted and the OP from that link itself throw in the same error, in which OBDavid had the same log.
Could NeVe12p4wNeD post their crash log (if any) here aswell?

Within said thread, the log means this
The runtime throwing a NullReferenceException always means the same thing: you are trying to use a reference. The reference is not initialized (or it was initialized, but is no longer initialized).
This means the reference is null, and you cannot access members through a null reference.
This could be referenced to the ICD Driver not being found.

Bottom line?
I really can't pinpoint a real fix to this anymore. But since it's caused by updates, rolling back updates until new updates that (hopefully) fixes these are addressed.
This has been spreading suddenly, and they're always concerned with a recent update.
Try restoring to a previous version or update.
posted
if windows update is the main cause, why don't you try to update it again? mine on KB3199986 and doing fine.
posted
Thanks for the reply Kao. I'll try updating it again as Nub1 suggested, if not I'll rollback.
posted
I just installed an older Intel® HD Graphics 530 driver and now my osu works.

Maybe this works for you too https://downloadcenter.intel.com/downlo ... duct=88345
posted

OBDavid wrote:

I just installed an older Intel® HD Graphics 530 driver and now my osu works.

Maybe this works for you too https://downloadcenter.intel.com/downlo ... duct=88345
Confirmed works on my laptop. Downgrading the Intel Graphics Driver fixed the problem. I don't know why though because I'm running it off dGPU in the first place...
posted
I'm really glad you were able to solve it. This was certainly a weird problem. Thanks, OBDavid! I'll make sure to keep this in mind next time this error pops up.

Marking as resolved. You don't have to manually mark it yourself -- a support team member or lurking GMT will do so.
posted
Glad to see my hardwork of research was correct ;)

This is interesting, but I'm sure Intel will do an update very soon and will fix the problems
posted
I too had this problem and when I installed the older versions, osu worked again

However, after sleeping my computer and waking it up the next morning, it seems the error is back
posted
Since this is resolved, you should make a new thread instead.
posted

Kitsunex wrote:

I too had this problem and when I installed the older versions, osu worked again

However, after sleeping my computer and waking it up the next morning, it seems the error is back
Windows probably installed the new version by itself. Disable the updates for that or do a rollback to a previous version for only that update and Windows should ignore said update in the future.
posted
Had this problem happening on a fresh Windows 10 install (10.0.14393) on a laptop with Intel HD Graphics 530 (driver 21.20.16.4542) and a NVIDIA GTX 960M (driver 375.95, Optimus). I had the NVIDIA GPU set to be used by-default in NVIDIA's graphics control panel, and osu! thus used the NVIDIA GPU to start. If I start osu! on the integrated Intel graphics however, it starts fine.

osu! has no profile in NVIDIA's driver, so in my case, I just created a program-specific profile for it from the control panel and set it to use Integrated Graphics: https://sli.mg/q9PZDe

I didn't have to downgrade drivers (both drivers were the latest Intel and NVIDIA offered on their download page; not from WU), and disabling Game Bar didn't help. I have all available W10 updates installed and I'm not on a preview build currently.
posted

Espionage724 wrote:

Had this problem happening on a fresh Windows 10 install (10.0.14393) on a laptop with Intel HD Graphics 530 (driver 21.20.16.4542) and a NVIDIA GTX 960M (driver 375.95, Optimus). I had the NVIDIA GPU set to be used by-default in NVIDIA's graphics control panel, and osu! thus used the NVIDIA GPU to start. If I start osu! on the integrated Intel graphics however, it starts fine.

osu! has no profile in NVIDIA's driver, so in my case, I just created a program-specific profile for it from the control panel and set it to use Integrated Graphics: https://sli.mg/q9PZDe

I didn't have to downgrade drivers (both drivers were the latest Intel and NVIDIA offered on their download page; not from WU), and disabling Game Bar didn't help. I have all available W10 updates installed and I'm not on a preview build currently.
If this is a problem, then you should open a new thread, since this is already resolved.

However, osu! Should work when you run it with the GPU
I had my nvdia drivers make a custom profile for osu! To run with the GPU and it made 7ms input lag to 2ms.
So GPU > Integrated Graphics
It's probably because you have a bad configuration of your drivers
posted
same problem, but i have fixed it.

first i tried download and install the newest intel and nvidia graphic drivers, no help.

then i uninstalled them both, just clicked on the 'uninstall' button in the driver properties, no 3rd soft was used. after that i can open osu! and it performed an update.

then i installed the newest intel and nvidia drivers again, and osu! run fine.

at this point i don't know if the update or uninstalling drivers that fixed the problem.
posted
This error happened to me today as well, but I have found much easier solution for all of you guys, who will ever face this issue again! You are welcome :)

Solution:
Open Device Manager, click Start > Control Panel > Device Manager
Expand Display Adapters
Double-click on your Intel® display device
Select the Driver tab
Click Roll Back Driver to restore
posted
Don't bump old marked threads please. It's quite old, the solution is likely irrelevant
posted
Seems like I have same issue, but your url is invaild now...
So can you find an vaild method to me? thanks!
Details avaliable in viewtopic.php?f=5&t=549058

Espionage724 wrote:

Had this problem happening on a fresh Windows 10 install (10.0.14393) on a laptop with Intel HD Graphics 530 (driver 21.20.16.4542) and a NVIDIA GTX 960M (driver 375.95, Optimus). I had the NVIDIA GPU set to be used by-default in NVIDIA's graphics control panel, and osu! thus used the NVIDIA GPU to start. If I start osu! on the integrated Intel graphics however, it starts fine.

osu! has no profile in NVIDIA's driver, so in my case, I just created a program-specific profile for it from the control panel and set it to use Integrated Graphics: https://sli.mg/q9PZDe

I didn't have to downgrade drivers (both drivers were the latest Intel and NVIDIA offered on their download page; not from WU), and disabling Game Bar didn't help. I have all available W10 updates installed and I'm not on a preview build currently.
posted

Scorpy wrote:

This error happened to me today as well, but I have found much easier solution for all of you guys, who will ever face this issue again! You are welcome :)



Solution:

Open Device Manager, click Start > Control Panel > Device Manager

Expand Display Adapters

Double-click on your Intel® display device

Select the Driver tab

Click Roll Back Driver to restore
Thanks! Really helped, now I can get back to clicking circles! :P
posted
I'm having the same problems as well. I just recently updated my intel drivers and now it does not work. I use the new Intel® Core™ i7-7700HQ Processor
posted
basicly. nvidia and osu dont work wel together. the problem is the graphic card
show more
Please sign in to reply.