[Archived] Oh no! OSU! crashed

Total Posts
Topic Starter
Problem Details:
System.DllNotFoundException: Unable to load DLL 'bass.dll': Invalid access to memory location. (Exception from HRESULT: 0x800703E6)
at Un4seen.Bass.Bass.BASS_GetDeviceInfoInternal(Int32 device, BASS_DEVICEINFO_INTERNAL& info)
at Un4seen.Bass.Bass.BASS_GetDeviceInfo(Int32 device, BASS_DEVICEINFO info)
at Un4seen.Bass.Bass.BASS_GetDeviceInfos()
at #Cg.#fo.#x3b(String )
at #Lg.#Ng.#pI()
at #Lg.#Ng..ctor(String )
at #Lg.#mp.#Hyb(String , Boolean , Boolean )

Video or screenshot showing the problem:

osu! version: 20130815
Check if osu!.exe is flagged as "run as Administrator".
Topic Starter
it's normal run, not run as admin, but I tried running as admin and it didn't work.
It says "Invalid access to memory location.". Can you check if the osu! folder is there and has not been blocked or deleted by an antivirus?
Looks like you are missing the bass.dll file in your installation folder.
Run the installation repair/updater (press shift while launching the game to access it)
Topic Starter
there was no indication that avast! blocked anything during installation and the folder and files are there, just not the bass.dll
EDIT: I'm trying the installer run now. I misread the instructions and thought to launch the game itself and hold shift for the options.
I derp'd hard :P
UPDATE: Did not work. Still same crash issue even after repairs.
YET ANOTHER UPDATE: did some checking on the files and made hidden files appear. EVERYTHING is in its proper place, but refuses to locate it
Copy your game client to another location aside from the default one.
It might be an issue with the file permissions.
Topic Starter
this as well didn't work
looks like OSU! doesn't like me anymore T_T
Are you sure the .DLL file is still there?
Try disabling your antivirus first
Then run osu! In administrator mode

If that still didn't work you could try fixing the permissions
There's a separate program in the osu! Folder named "Fix permissions"
Try running that and see if problem persists
Topic Starter
Very odd. OSU! installed just fine on a computer running Windows 7 64-bit yet won't run on Windows 7 32-bit system. I'll try the solution mentioned when I can.
Topic Starter
I'm using the latest installer to install the game and it ends up installing it to the appdata folder
I checked EVERYTHING and everything's in its place, but it keeps with the error and there's no "fix permissions" folder
avast! allows it to install without detecting any viruses, so it's not that, and I've tried running in admin mode before and STILL nothing.
Oops, I meant the "Repair osu!" Shortcut
Have you tried downloading the old installer instead?!install.exe
It solves most of permission related problems. Make sure to install in C:/Program Files/ and not in Appdata. This could be the reason

But if you have osu! Already installed, replace it with this!.exe and try again
Method 1: Launch Repair Dialog
  1. Hold down the Shift key on your keyboard.
  2. While holding Shift, double click the osu! icon on your desktop.
  3. Continue holding Shift until you see the recovery dialog prompt.
  4. From there, click on the "Repair osu!" option

Method 2: Shortcut
If you have the "repair osu!" Shortcut, opening that also works.

Method 3: Text document
You can also force the updater to run by creating a new text document in your osu! folder called "help". Right-click in an empty space in your osu! folder, and choose New > Text Document.
Name it help and then run osu! to start the updater in forced maintenance mode.
Topic Starter
and it didn't work at all
even the repair options failed
I get this

System.DllNotFoundException: Unable to load DLL 'bass.dll': Invalid access to memory location. (Exception from HRESULT: 0x800703E6)
at #=qb0LsIiqlkHhYkORGuJVLyFcm7CFoEz9JtVHLsdwXX18=.#=qxnRyqInBiHH0IdTAfxbp6PvHe7QvuU01Fm1jQ13R7zs=(Int32 #=qJZGlH5n5MQRdPqluY6gTwg==, #=qwgcg$M9Z$DtcUsJVXVQ_f_SyGNmXEQCxv_c7XoDWirDEAlDcqEOMviU0m7janIFd& #=qZRdjHF3b5mTW9_iYQY6nWA==)
at #=qb0LsIiqlkHhYkORGuJVLyFcm7CFoEz9JtVHLsdwXX18=.#=q8NHr2M_sHKu3t4BkXEpqm5Pk3WjWFeO7bHQV8Cy2hd0=(Int32 #=qJZGlH5n5MQRdPqluY6gTwg==, #=qjwmYzOX9wTt9ExHTboy6SbwAVWlTBm6mgNSp2jjDc4M= #=qZRdjHF3b5mTW9_iYQY6nWA==)
at #=qb0LsIiqlkHhYkORGuJVLyFcm7CFoEz9JtVHLsdwXX18=.#=q8NHr2M_sHKu3t4BkXEpqm5Pk3WjWFeO7bHQV8Cy2hd0=(Int32 #=qJZGlH5n5MQRdPqluY6gTwg==)
at #=qb0LsIiqlkHhYkORGuJVLyFcm7CFoEz9JtVHLsdwXX18=.#=qVPHy6vx76a5g3y4o3XA$09NdWQP68mw9YqJoyh0AFC0=()
at #=qo6DdFPKHBZVW8677kbcY9lhnWwlpbXVdR7_lpR6qTWw=.#=qlW8XlXwnzoSl90QJDqX8lQ==(String #=qsLJYonwCbXCFz91D9CWV4fC1mlY2jvzdaVPnekhyEnk=)
at #=qIfXIf0SKSpQQAXZCE$yp6A==.#=qwGtyZ1Mgv8My0NG2ZgZxnD3dewDSMRWuATCiR7dKrmk=()
at #=qIfXIf0SKSpQQAXZCE$yp6A==..ctor(String #=qW5L1MMz_2Sj$hT7ffupKLw==)
at #=q1bCUI36vwMdhEbhWfPV0dQ==.#=qWcafXn$bOwt1N2ZsJ$z6EA==(String #=qyvGUpObIEv6IRSiwc7hfTw==, Boolean #=qKlU0gg$Vrv6JmzKTi_WK_$eW8_kdUMfy3ZlZ2H079Ig=, Boolean #=qZjiItrxz$3PEmJ8lpniybA==)
Have you tried the old installer instead?!install.exe
Back up your songs first before reinstalling though!
Are you completely sure your antivirus isn't interfering?
Scan for viruses first (Just in case) then disable it. It's worth a shot
Referencing from the log, (Exception from HRESULT: 0x800703E6)
Using this as a source ... 29cf8100aa

Stephen Boots wrote:

I believe that this error means that there was a problem with the expanding of the downloading update files for installation.
I could only see it as an external program blocking osu! And preventing it from running properly.
If the above still didn't help, could you take a screenshot of both task manager (processes) and the error dialog? (Include the window of it, I wanna know which application gave the error)
Please sign in to reply.

New reply