1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Problem Details:
So the way I grip my pen, my fingers are right at the top of the top button on the pen, and when I play, I sometimes accidentally press the buttons on the pen and sometimes (about 1/3 of the time) it will move my cursor to the top of the screen for as long as I hold it messing up my aim. This is becoming a major issue where it messes up would-be FCs or other things. Basically it's very annoying and I was wondering if there was someway to fix this. Thanks in advance.


osu! version: 20160821.1 (latest)
posted
Disable the pen buttons.
posted
-_- That was so helpful. Don't you think I've already tried to search how to do that?
posted

Kurojou wrote:

-_- That was so helpful. Don't you think I've already tried to search how to do that?
No need to be rude, He just didn't realize that you couldn't figure out how to disable the buttons, it wasn't exactly implied that you had already tried that :)

To disable the buttons:
1) Download the drivers for your tablet. assuming you have osu tab, it actually works out of the box without drivers, so if you have the osu!tablet or the huion h420, you can get the drivers Here
2) Once the driver is installed, navigate to the "Button" tab of your driver as shown Here
3) For each of the Barrel button 1 and Barrel button 2 drop-downs, you want to set the Mouse Command drop-down to No Action

This should resolve your problem. If i misunderstood the problem, please feel free to correct me and i can attempt to help further.
posted

electricbullet9 wrote:

Kurojou wrote:

-_- That was so helpful. Don't you think I've already tried to search how to do that?
No need to be rude, He just didn't realize that you couldn't figure out how to disable the buttons, it wasn't exactly implied that you had already tried that :)

To disable the buttons:
1) Download the drivers for your tablet. assuming you have osu tab, it actually works out of the box without drivers, so if you have the osu!tablet or the huion h420, you can get the drivers Here
2) Once the driver is installed, navigate to the "Button" tab of your driver as shown Here
3) For each of the Barrel button 1 and Barrel button 2 drop-downs, you want to set the Mouse Command drop-down to No Action

This should resolve your problem. If i misunderstood the problem, please feel free to correct me and i can attempt to help further.
You got the problem correct, but the issue is that even though I have the correct pen driver installed, I cannot access the configuration menu at all. There is no EXE for me to run that would open that anywhere, not on the desktop, not on the files, not on the control panel, nowhere. Any ideas?
posted
I assume you are using the h420 pen that is nonrechargeable? If thats the case i recommend you just remove the the buttons. I held the pen in a way that also made me press the buttons and it become frequent when i was tensing up at high combos. So i just removed them. It feels a little weird in the beginning but i got used it it in about a couple hours. And yes you can put the buttons back on if you want to :^)
posted
When you installed the HUION drivers, you should've gotten an application called TabletDriver. Run it as an administrator, and try selecting the buttons to "none button"
Works for the battery powered and rechargable pen.
posted
I'm having a problem with the latest drivers as of now. I have a dragging play style when it comes to tablet so when I try to drag now it does some long press action and I can't seem to find away to disable it. It was possible in the old drivers to change it so I find it a bit odd to remove it. The only reason I updated my drivers because my old drivers had problems detecting when my pen was in use. Is there anyway to disable it before I go back to try reinstalling my old drivers?
posted

ronaldonater wrote:

I'm having a problem with the latest drivers as of now. I have a dragging play style when it comes to tablet so when I try to drag now it does some long press action and I can't seem to find away to disable it. It was possible in the old drivers to change it so I find it a bit odd to remove it. The only reason I updated my drivers because my old drivers had problems detecting when my pen was in use. Is there anyway to disable it before I go back to try reinstalling my old drivers?
Please make a new thread. Do not bump old, marked threads.
Please sign in to reply.