1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Hi, I can't seem to solve this issue so here's my problem:

In fullscreen mode I have about 8,4 ms input delay. In borderless it's 0,44ms +- 0,05. I have no idea why and I can't seem to solve this with playing around with the settings, nvidia settings or whatsoever.
I'd play in borderless if any steam message wouldn't make the game super choppy
Any suggestions on what I could try/do to fix this? D:

CPU: i7 2600k 3,4ghz
GPU: Nvidia GTX 770 4gb
OS: Windows 10
120hz
Driver version 361.43
Huion h420

Screenshots showing the problem (bottom right corner, huge delay difference):



osu! version: 20151228.2

Edit:
Found out that if switch to the Stable (fallback) build and use DirectX, there is no problem. OpenGl also works better than the latest build for some reason. Problem here is that there's no letterboxing in the fallback build and running osu on 1440p fullscreen is kinda weird
posted
Then just keep borderless and don't use FS!
posted
Also remember to disable Steam popups if you keep playing borderless.
posted
My problem is not the steam pop up, it's literally the "new message flashing" on my 2nd monitor on an unfocused tab whenever I get messaged that kills any performance even though it's still running at 120fps+ (you could describe it as choppy).
posted
Sometimes I notice that Aero in windows 10 goes through osu!'s fullscreen mode. It happens when the volume meter on the upper left of the window while adjusting appears even on fullscreen. If it appears, there you will feel the slight input lag. Restarting seems to fix my issue with it.
Please sign in to reply.