1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted

Marblelemons wrote:

Tried the method suggested by Death. Didn't work.

Edit: Never mind. Seemed like it worked. Thanks!

I still have the problem with the ~1500 beatmap limit though
https://www.youtube.com/watch?v=3lT8om-2kfE try this
posted
Worked. Thanks!
posted
Osx high sierra, osu isn't opening at al!
posted
Likewise, upon downloading High Sierra the application will not open. No error messages, no crashing, it appears to not open whatsoever.
posted
Not opening on high sierra for me also. Using the alpha build from http://osuosx.tumblr.com/.
posted
Can confirm osu! not opening on macOS High Sierra, both the Stable and Alpha versions from http://osuosx.tumblr.com
posted
Seems like High Sierra hates Wineskin :|
posted

Cloudcrusader wrote:

hey guys, i have just downloaded osx version of osu and everytime I begin to play a beatmap, osu instantly crashes and gives me this error:

System.Exception: Your graphics card has run out of memory blah blah custom skin .. use default skin! any help is greatly appreciated!
Try updating ur graphics card
posted

Tyler Evans wrote:

Try updating ur graphics card
Wat
posted
I see some of you are also having trouble with osu after updating the OS, is there anything I can do about it?
posted

WhiteFoxToast wrote:

I see some of you are also having trouble with osu after updating the OS, is there anything I can do about it?
Try using updating the wrapper The Porting Kit, this method used to work when Wineskin wont work with Sierra
posted
The wrapper doesn't work on High Sierra, it only opens an Xterm :P


So I ended up just using wine from Terminal (install Homebrew first!)

Get wine packages if you don't have them yet
brew install wine
brew install winetricks
If you didn't use wine yet then
WINEARCH=win32 winecfg
and configure what you want and press OK

I don't know if it's required (because I misconfigured wine, no programs started, so I ended up installing these packages), but
winetricks gdiplus
winetricks dotnet20
Then install dotNOT 4.0 with
winetricks dotnet40
If you wanna install other dotNOT versions then install those first (like dotnet20, dotnet35, or dotnet45), but due to a bug(???) osu! will fail to launch, so we'll need to repair dotNET 4.0 with
winetricks --force dotnet40
And then it's easy as chdiring into the osu! folder, and doing
wine osu\!.exe
Now here comes the tricky part... idk if it happens with others, but if you hover over a "checkbox" then osu will softlock, and even if you try to scroll the options screen using the touchpad or some sort of scrollwheel then it'll also freeze, so make sure to avoid all checkboxes, and scroll by clicking the touchpad and scrolling like you would a phone, again, avoiding checkboxes.
Now switch the release stream to Cutting Edge (as anything else seems to be a softlock galore), and if it fails then switch it back to Stable and quickly switch it back to Cutting Edge, and WAIT, DON'T DO ANYTHING while it's downloading! After it says "osu! needs to be restarted" then click that, and it should go into Cutting Edge now.
Now change some settings around, mainly disable fullscreen, and disable raw input if it's enabled (I'm using an existing installation of osu!, but it also works from a new start, just make sure to delete your cfg file if there's an username collision).


Here are some caevats (which are known, but I'll just list them anyways):

  • - don't spam your arrow keys in the music selection menu, it'll softlock
    - don't switch to another application, the graphics and mouse input will softlock (you can still exit by spamming ESC and 1)
    - if you have letterboxing enabled with a resolution smaller than the native then start the first beatmap you come across, and wait for the screen to fix itself, then quickly press ESC if you don't wanna play that beatmap (this is needed because upon starting the game the letterboxing resolution seems to be ignored, resulting in a weird clipped rendering error)
    - scrolling using the scrollwheel still seems to softlock, but it's no longer a 100% chance
    - BE PATIENT! if you're unpatient then osu! will softlock ;)


Edit:
found another issue! Sometimes the game doesn't start up with a "BAD_ALLOC" error... The fix is easy, just rename your current config file, and let the game create a new one for you :P idk why it happens, but luckily it was an easy fix ^w^

This is all I know
posted
Hi!

I just discovered OSU recently and more specifically OSU!Mania and I'm having lots of fun with it!
As a guitar player it kinda irked me that a lot of the metal beatmaps are nothing like how that songs are actually played on guitar, so I figured I'd write my own take on them!

However I have a very annoying sync issue when using different playback rates on mapping.

I would start with 25% playback rate and map it perfectly, but when I switch to 100% playback rate to test, all the notes are out of sync with the music.

More specifically, the notes appear on the screen a fraction of a second before they're actually supposed to, or perhaps the music plays a fraction of a second later than when it's set at 25% playback. So far the delay seems linear, so it's just the song starting to play a bit later at 100% than it does at 25%.

Only "settings" i've done is setting the BPM to a constant 162. I haven't changed anything else.

Any tips on how to combat this? Mapping it to 25% then shifting all the notes two notches afterwards seems really cumbersome and difficult to map and test at the same time.

I'm using the latest stable Mac build from 2015.
posted
Can confirm that osu is not launching since upgrading to High Sierra. Please fix<3
posted

Nakano Yuko wrote:

Can confirm that osu is not launching since upgrading to High Sierra. Please fix<3
how is it not launching? did you read my post above? it should include workarounds I tested and is the way I'm running osu! on High Sierra
posted
Its still possible to run it, but you need to configure it(?)
posted

Jeni-Desu wrote:

Its still possible to run it, but you need to configure it(?)
yes, kinda

there's no universal workaround, it depends on the crash(es)/malfunction(s) you get
posted
terminal doesnt find osu when i use wine osu\!.exe even though i have osu and did all the previous steps thonk
posted
When i run osu! on mac os x El capitan osu! show me : oh no! with a blank screen please help me !
posted
When I launch it there is the image of the logo osu! which is displayed but the game does not run
Please sign in to reply.