1. osu!community
  2. osu!
  3. Help
posted
For some reason, I can't update osu! while using mac, I've been stuck on fallback for a while now. It might be that osu! is detecting my computer can't run the latest build and is coming back to Fallback, as Kao said.

The updater runs, and at the very end it says "your osu is up-to-date", however it stays at Fallback. Help would be greatly appreciated!
posted

Jyn wrote:

For some reason, I can't update osu! while using mac, I've been stuck on fallback for a while now. It might be that osu! is detecting my computer can't run the latest build and is coming back to Fallback, as Kao said.

The updater runs, and at the very end it says "your osu is up-to-date", however it stays at Fallback. Help would be greatly appreciated!
That would be correct, it is detecting it can't run the latest if you have already seen "your osu! Is up to date" message, but you're still in fallback.
Try running the game in compatibility mode
Method 1: Launch Repair Dialog
  1. Hold down the Shift key on your keyboard.
  2. While holding Shift, double click the osu! icon on your desktop.
  3. Continue holding Shift until you see the recovery dialog prompt.
  4. From there, under Renderer, check "Compatibility mode"

*This will only appear when the selected stream is Stable(Latest)
posted

Kao wrote:

That would be correct, it is detecting it can't run the latest if you have already seen "your osu! Is up to date" message, but you're still in fallback.
Try running the game in compatibility mode
Method 1: Launch Repair Dialog
  1. Hold down the Shift key on your keyboard.
  2. While holding Shift, double click the osu! icon on your desktop.
  3. Continue holding Shift until you see the recovery dialog prompt.
  4. From there, under Renderer, check "Compatibility mode"

*This will only appear when the selected stream is Stable(Latest)
My release stream won't update either, so the repair dialog doesn't launch.
posted

Jyn wrote:

For some reason, I can't update osu! while using mac, I've been stuck on fallback for a while now. It might be that osu! is detecting my computer can't run the latest build and is coming back to Fallback, as Kao said.

The updater runs, and at the very end it says "your osu is up-to-date", however it stays at Fallback. Help would be greatly appreciated!
The stable release of October last year is stuck on Stable (Fallback), It is intentional though.
posted
I just wish that Stable (Fallback) would support newer versions of osu!, especially with the addition of Score V2 and the Hidden update to sliders, as b20160403.6 doesn't have those features, and that release is so old now. Like seriously, the current release is like b20170103.2. Peppy, can you please fix this
?!? :o
posted

Suicune3 wrote:

I just wish that [...]
The reason why it doesn't support that because Fallback is supposed to be used on (very) old computers that can't run Latest. Adding those features would likely make those (old computers) unable to run Fallback anymore (probably on Mac this would be the case.)
Fallback isn't supported anymore and won't be updated.
posted
Hey guys~,

After updating to the latest update (I'm guessing the Chinese New Year update), I'm getting an error with wine.
It says:

"Unable to find a version of the runtime to run this application."

Any help is appreciated, thanks~
posted
Hello ;)
posted
Hey I have an issue where every time I go to put in a new beatmap, osu gets stuck on the "Looking for new beatmaps" screen and just sits there forever. This first happened when I attempted to load a ton of beatmaps at the same by shift clicking them and opening them all at the same time, and now it happens on all new files. If someone could please help that would be great. I'm on macOS sierra running the lastest stable version of osu mac.

There a chance this glitch can be recreated by attempting to add a large amount of beatmaps at the same time. :)
posted

tripl3ag3nt wrote:

Hey I have an issue where every time I go to put in a new beatmap, osu gets stuck on the "Looking for new beatmaps" screen and just sits there forever. This first happened when I attempted to load a ton of beatmaps at the same by shift clicking them and opening them all at the same time, and now it happens on all new files. If someone could please help that would be great. I'm on macOS sierra running the lastest stable version of osu mac.

There a chance this glitch can be recreated by attempting to add a large amount of beatmaps at the same time. :)
I am having the same issue only it started when I added only one new beatmap. I tried re downloading osu (the old version not the Alpha release because that won't run for me) and moved all my songs from the old to the new. Now the "beatmap processing" screen is stuck forever. I was able to move skins, but not songs. I'm on macOS sierra 10.12.3.
I kind of messed up the old version so now I can't play osu at all...
posted
Temporary fix for the mac bug thing is to take all executables/osz files that aren't folders out of the songs folder in osu, this does mean that you can't dl any new maps though :(
posted
Osu just updated for me (automatically- the thing on the bottom had a "click here to restart") and now it won't load- every time I try to boot it up on my mac an error window pops up.
Here's an image of the error
It says:
"osu!.exe - .NET Framework Initialization Error"
"Unable to find a version of the runtime to run this application."

Do I need to re-download Osu, or is there a way to fix this bug?

(Edit: I'm playing on a Macbook pro with OS X El Capitan (10.11.6) and using xQuartz to play Osu.)
posted
Please help with this glitch
posted

Ateliesta wrote:

Osu just updated for me (automatically- the thing on the bottom had a "click here to restart") and now it won't load- every time I try to boot it up on my mac an error window pops up.
Here's an image of the error
It says:
"osu!.exe - .NET Framework Initialization Error"
"Unable to find a version of the runtime to run this application."

Do I need to re-download Osu, or is there a way to fix this bug?

(Edit: I'm playing on a Macbook pro with OS X El Capitan (10.11.6) and using xQuartz to play Osu.)
I experienced that problem too, you should re-download your osu! client. Then put osu!installer.exe file that can be found out in the Download page in osu.ppy.sh if you need to do so.
[ADDITIONAL]If there are any of the songs that you want to keep it, you should take it out from the package file you can see when you right-click apps, then back-up to another folder or drive in order to save it.
If it is reinstalled, maybe there can be one more crash(It happened to me, which my computer is OS Sierra), then you will need to login then manually put the song back. Then you can enjoy the game. Sorry that my English is not that fluent.
posted
Hey I'm new to osu so excuse me if this isn't the right place to post.

I just downloaded osu for the mac osx and I've been downloading beatmaps, but for some reason, the beatmaps do not show up in my lists in game and I have no way to play them. I've put them in the osu!/drive_c/osu!/Songs folder (nowhere else) just for reference.

Thanks for the help!
posted

Quatzil wrote:

Hey I'm new to osu so excuse me if this isn't the right place to post.

I just downloaded osu for the mac osx and I've been downloading beatmaps, but for some reason, the beatmaps do not show up in my lists in game and I have no way to play them. I've put them in the osu!/drive_c/osu!/Songs folder (nowhere else) just for reference.

Thanks for the help!
Did you try to press fn key and f5 key together? That is the way to restore your lost beatmap.
posted
I got the problem which is making me get .NET Framework error(map is not restored even when I put backup file manually), or just opens Wineskin app.
posted
Reading this thread just makes me sad. I personally have three issues that doesn't really need to get fixed but if anyone's experiencing the same problem, hopefully this post would create some kind of empathy or something.
1. Taking screenshots in-game. It's either a good or bad; the screenshot is either fine or a black screen.
2. After 3-5 hours of play, sometimes the skin gets glitched out. Something like this. Some sliders turn transparent lmao.

3. Sometimes the game lags and the approach circle kinda glitches out. This one's pretty annoying.

Still using 2015 ver. Unstable release ver just doesn't work for me.
posted
There is an issue on mac where it will start receiving keypresses outside of osu! instead of inside. This happens mid-map too, so it is very annoying. The only thing I have been able to do to keep them in-game is try to tap with my pen on the tablet or click with my mouse at every possible chance. This needs fixing, strongly
posted
I have had many of these same issues:
1. Keypresses randomly registering outside of osu mid song (particularly bad in mania)
2. When attempting to load a new map, it just infinitely loads and I have to manually delete the map from within osu to be able to play again
3. Random crashes on song select
4. Pretty severe input lag
5. Certain maps having wrong thumbnail or wrong C/B/A/S/SS ranks associated with them at select
6. The worst of them all, after updating from within client, the entire game gets broken with the .NET framework error and must be redownloaded :(

I've found a fix for #2 however, the issue is caused by a certain number of maps being skeletons (that is to say that they have a folder within the game, and they have a .mp3 and a background, but no .osu beatmap file). One of the ways that skeletons get created is by choosing the "Delete all visible beatmaps" at song select, but I'm sure there are others. Choosing this option will create skeletons of all the maps that you want to delete (I'm pretty sure other deletion options are fine). If you have a certain number of skeletons, new maps will not load. Here's how get rid of skeletons:
1. hit f5 at song select
2. If the song that starts playing mysteriously does not have a beatmap associated with it, then you have a skeleton
3. look at the name of the song playing in the top right corner of the main title screen, the song name should be the name of the .mp3 in the skeleton, this will help you find it
4. Go to your appilcations, right click on osu, click "Show Package Contents" then navigate to your songs folder and search for that .mp3 file's name
5. Once you find the beatmap, double check to make sure it's a skeleton (no .osu file inside) then manually delete
6. Hit f5 again to repeat

I once had to delete 50+ skeletons, not fun. Hopefully this will help some people and hold them over until lazer. (But seriously fuck the .NET framework init error, 4th time having to redownload this game)
Please sign in to reply.