1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
  • Information.


  • This thread is for confirmable or confirmed bugs with only the OS X version of osu!.
  • Known issues.

  1. When using fullscreen and switching window (by clicking a link in chat for example) you get stuck on a black screen.
  2. Certain fonts are missing or not rendering, causing missing icons in the main menu, and squares for asian languages, for example.
  3. Other monitors are black when osu! is in fullscreen on a setup with multiple monitors.
posted
I've heard from other Mac users that the sound comes before the beats, despite their offset being at 0.
Info here: https://m.reddit.com/r/osugame/comments ... e_fix_osu/ I do know other people who use OS X and have the same problem.
We'll have to wait for speficics I suppose.
posted
Sliderendcircle substitution doesn't work on OS X build with custom skins. I have made a blank sliderendcircle.png file for my skin as well as try some other skins with blank slider end circles, however it still has them for me. I tried to confirm the issue with sending the skin to my friends and they reported back to me that they do not have the end circles with my skin, but I do.

I have no way to confirm whether the bug occurs with stable or cutting edge releases for me as current OS X build is locked to fallback release.
posted
Blame wineskin not peppy, this is just windows osu running under wine, it will not work properly this way.
This wine build is also limited to Stable (Fallback) so latest performances fixes are not available.

There is big input delay. When my friends tried to play on my macbook they said that hitsounds are not sync with music but they are. They are just not use to this delay. Just need to move cursor or click button earlier to get proper timing.

What i think is that there is no way you can fix this problem on osx wine version. Sound latency was always issue on wine. Solution would be native client, and even if this osx has just terrible drivers...
But we can hope that if peppy finishes all the important stuff, he may release native osu for mac.
posted
Can't tell if this is just me but my left click button is broken (E), I know this isn't just my keyboard because I can type E on the internet and osu!, I also tried to switch my left click to T,D, and F and all they are all the same. My mac is running on OS X Yosemite right now.
posted
hey guys, i have just downloaded osx version of osu and everytime I begin to play a beatmap, osu instantly crashes and gives me this error:

System.Exception: Your graphics card has run out of memory blah blah custom skin .. use default skin! any help is greatly appreciated!
posted
Having a giant problem with osu running on my 2014 macbook, whenever i press a circle the game sets my mouse sensitivity to really low, making me miss a lot of notes. i've tried using another mouse but the problem is still there. it's only like that for like 2 seconds, then it turns back to normal. The game worked fine until two days ago, when i updated it. Already tried reinstalling osu.
posted
I'm using the osx version and im only able to get the settings nice and comfortable to use when its in 800x600 without fullscreen but whenever i put my mouse in the window it goes offscreen when i move it to a certain point past the middle of the screen. I'm not using wine or anything im just using the download for mac.Is there anything to do to fix this without going fullscreen, because then its a pain when going in multi to exit to chrome because sometimes it crashes when i comebackto the osu window,it also cuts off the bottom of the screen in fullscreen so I'd rather not use it.
posted
For me it all works fine, except that there's a weird lag/framerate bug. It's like the tempo speeds up and down and the notes teleport forward and backward a bit occasionally.

I tested this on easier songs to make its not just me being bad, but it's definitely there. I'm guessing it has something to do with frame rate, although it doesn't feel like my frame rate dips. It's more like osu slows down/speeds up the songs for whatever purpose (lag compensation?). It's always on and off too, sometimes it's not there at all and sometimes it is. I often restart it to get rid of it but it gets a little annoying.
posted
Mapping tablet raw input to osu also does not work, which is made worse by Huion's drivers not supporting changing the tablet area while keeping the same aspect ratio.
posted
Mac is less stable and there still building that version dont rish them it will take the its apple and there new os releases that cause sound problems. :)
posted
I'm using the OS X version and it won't let me get any beatmap packs? Like I can download and run individual songs and download the pack but the pack won't run
posted
Using the latest osu mac dmg on 10.6.8. Game starts with black screen but the games startup music menus cant be accessed via the keyboard either. Also noticed the game does not generate a osu!{username} config.
posted
I've been trying to open Osu! but I can't seem to...
I open the app and then it freezes at Wineskin and gives me a blank "Oh no!" screen, it stays frozen like that until I force quit it.
I tried updating Wine and installed the newest version of the program through Winery (as suggested in an old bug error post), so I'm using WS9Wine1.2.9 right now; it still won't open. I'm at a loss because it was working completely fine up until 2 weeks ago, I didn't download anything new so I'm really confused about why my app won't work... Any help is appreciated!
posted
if you have older system you may need to use older wine engine or wrapper version.
posted
I have Os X 10.10.5 (Yosemite) and I still experience this, forcing me to use the power button on the back of my Mac.
posted
less than a minute ago
My problem is that my dad updated the mac to the latest version of El Crapitan. Now, whenever I try to open osu, all I get is this: [url]file:///Users/Andrew/Desktop/Screen%20Shot%202016-03-24%20at%208.20.22%20PM.png[/url]
Copy and paste that if you need to ^ (without the [url]and[/url])

It's been doing this for about 3 weeks now, and I'm really beginning to miss osu...

Anyone know why it's doing this and a way to fix it?

-Vaarka

EDIT: I found my resolve by trying this: t/346222/start=15
"ITS WORKING ON EL CAPITAN BUD WITH A BUG BUD THAN ITS FULLY WORKING FOLLOW MY STEPS :

1.Download Osu again bud dont drag it in your application folder open it straight ahead
2. Now it will say its not working there is a problem right? ( if thats so your on the right way)
3.NOW drag Osu in your Application folder like they show you right now and than open it once then they will say its broken than open again and its WORKING!

NO PROBLEM I LOVE THAT GAME SOOOO MUCH!"
Credit goes to SyTron24 for making the above post ^
posted
Im on a mac (10.9.5), and when I tried to make a GD for a map, I couldn't find a way to open a file which needed to be edited so that I could upload it.
posted
Engine Used: WS9Wine1.9.8
Hardware:

Hardware Overview:

Model Name: Mac mini
Model Identifier: Macmini5,1
Processor Name: Intel Core i5
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 16 GB
Boot ROM Version: MM51.0077.B10
SMC Version (system): 1.76f0

Graphics/Displays:

Intel HD Graphics 3000:

Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Displays:
HP S2031:
Resolution: 1600 x 900 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: 3CQ047NVYG
Mirror: Off
Online: Yes
Rotation: Supported
Adapter Type: Analog VGA Or Analog Over DVI-I
Adapter Firmware Version: 0.00
ASUS VS238:
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: EALMTF169287
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Television: Yes

Engine Used: WS9Wine1.9.8
Hardware:

Hardware Overview:

Model Name: Mac mini
Model Identifier: Macmini5,1
Processor Name: Intel Core i5
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 16 GB
Boot ROM Version: MM51.0077.B10
SMC Version (system): 1.76f0

Graphics/Displays:

Intel HD Graphics 3000:

Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Displays:
HP S2031:
Resolution: 1600 x 900 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: 3CQ047NVYG
Mirror: Off
Online: Yes
Rotation: Supported
Adapter Type: Analog VGA Or Analog Over DVI-I
Adapter Firmware Version: 0.00
ASUS VS238:
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: EALMTF169287
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Television: Yes

Here's a follow up, this is the information/logs I got after I tried to update the engine and run it again; still not working...
I really hope this gets resolved soon, I miss Osu! so much...
posted
I have the black screen problem when switching windows on Windows. I reported this before, but maybe the fix for that on Mac will also fix it on my PC.
Please sign in to reply.