Mouse input lag

posted
Total Posts
37
Topic Starter
Rijads
How do I minimize mouse input lag, it's almost as if I can feel it lagging behind.
I have sensei raw, and it shows 20+ms in menus and when joining the game, after that when the game starts it is around 8.3-8.4 ms, I have raw input on, no acceleration in windows 6/11 and I used markC fix for windows 10 x64.
Can anyone help me, and what is the usual lag that oyu should have ?
FieryLight
Up your pollling rate to 1000hz in the settings for your sensei raw. If your computer isn't very strong, you may want to use 500hz instead and you definitely do not want raw input on (because it'll effectively lower the polling rate to that of your osu frame rate).
KanoSet
are you playing in windowed mode ? it cause input lag specially if you are playing on a laptop
if so pls go for full screen
FieryLight

KanoSet wrote:

are you playing in windowed mode ? it cause input lag specially if you are playing on a laptop
if so pls go for full screen
Oh yeah, this is really good info too! You should use letterboxing if you like windowed mode or if you have windows 7, do some research and figure out how to turn off windows aero.
Topic Starter
Rijads
I have set my polling rate to 1000mhz from 500, removed raw input and fullscreen was already on, but no changes, it still shows 8.4ms :/
EDIT: I am playing on PC 4770k, vi hero mb, 8gb ddr3@2400mhz, 560ti gpu, etc, etc, I don't think pc is having any issues hardwerwise.
neatoneet
Oh! 8ms, EIGHT! That's some significant lag you've got there, must be unplayable.
KanoSet
maybe something heavy is runing in the background
if you are using beta ot cutting edge version try to go for the stable latest or fall-back
other wise i'm out of ideas

edit: if you have any other mouse try it.. maybe it's the mouse it self
Topic Starter
Rijads

neatoneet wrote:

Oh! 8ms, EIGHT! That's some significant lag you've got there, must be unplayable.
I don't know if trolling or not, but especially in counter strike I can feel the lag compared to my old G5 mouse (which sadly died after 7 years), it must be higher then this, I am just saying how much it is in osu, because I can see it in there.
Topic Starter
Rijads

KanoSet wrote:

edit: if you have any other mouse try it.. maybe it's the mouse it self
I just tryed some 2$ mouse, it is having exactly the same input lag as my sensei raw, 8.4ms....
Endie-
I remember having this probem although i can't remember how i fixed it...
THERE IS A SOLUTION
Topic Starter
Rijads

erikG wrote:

I remember having this probem although i can't remember how i fixed it...
THERE IS A SOLUTION
I am thinking of reinstalling windows 7 if I don't find solution soon.
Endaris
I don't think reinstalling W7 will help at all.
I don't think that's the issue but in case your mouse uses the PS/2-plug instead of USB there's naturally some noticeable input lag.
test
Topic Starter
Rijads
I wouldn't be reinstalling windows 7, I would be Deleting Windows 10, and making clean isntallation of Windows 7 with which I have never had any problems like this, though I have never used this mouse on windows 7.
It doesn't, I have tried usb 2.0, usb 3.0 on the back of the motherboard, even on the front of the pc usb 2.0 which should have some higher lag by default, but nope, all of them still show 8.4ms.
ZenithPhantasm
Turn off desktop composition.
Turn off HPET.
Uninstall mouse druvers.
buny
shit dude bet you can feel the delay from typing with your keyboard too huh
ZenithPhantasm

a loli wrote:

shit dude bet you can feel the delay from typing with your keyboard too huh
Yes
but razer kb has 25ms delay
TakuMii
Sounds like you're only getting 120fps... your framerate is probably capped. Maybe try setting the in-game frame limiter to Unlimited?

(Also, don't listen to everyone telling you to disable raw input. Osu polls your input every frame regardless of whether it's on or off, so turning it on will only allow osu to bypass the Windows input functions and therefore reduce input delay. Besides, you should be getting framerates in the thousands/frametime below 1ms with that CPU, so the whole "limiting your polling rate to your framerate" thing doesn't really make sense)
ZenithPhantasm
You shouuld only use frame limiter if your computer cant churn out a stable 1000 fps. Stable input lag is better than inconsistent lag.
KanoSet
he is using cmark fix.. it won't work if raw input is on
better leave it off
TakuMii

KanoSet wrote:

he is using cmark fix.. it won't work if raw input is on
better leave it off
That's not how the MarkC fix works at all...

The purpose of the MarkC fix is to fix games that relied on the Windows 'Enhance pointer precision' acceleration curve in order to control or disable mouse acceleration (aka Windows 95-era FPS games). Since those games force-enabled EPP and relied on the linear acceleration curve of older OSes, they'd run into issues when trying to manipulate the mouse settings and the exponential mouse acceleration curves used by any version of Windows after XP. MarkC fixes this by making the curve flat again, and taking it a step further by adjusting the curve to make mouse movement 1:1 when EPP is turned on.
This fix is practically irrelevant nowadays (unless you still play Counter-Strike 1.6 or something), since most modern games don't even bother with touching this curve, so you can achieve the same effect in modern games by simply leaving EPP off.

But that's besides the point. osu! is not a first-person shooter from the 1990s, so it doesn't need this fix. Raw Input has absolutely nothing to do with this curve anyways, since the whole entire purpose of raw input is to bypass Windows's mouse functions and allow the game to handle the inputs directly from the mouse/tablet. With Raw Input on, that curve is completely meaningless to the game and it doesn't even matter if you have 'Enhance pointer precision' enabled or not.


ZenithPhantasm wrote:

You shouuld only use frame limiter if your computer cant churn out a stable 1000 fps. Stable input lag is better than inconsistent lag.
On the topic of consistency: I'd also advise keeping a polling rate of 500Hz instead of 1000Hz. From my experience, 1000Hz isn't that stable on most mice I've tried, and it could also potentially cause your games to stutter.
show more
Please sign in to reply.

New reply