1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
Problem Details:
In the beatmap editor, when playing the map on the grid, the game crashed at about 50.7% through the map. Not sure whether the correlation is between the percentage or the time, but it happened in the same place multiple times. The first time it crashed, I was prompted on whether or not to save the beatmap before closing. In my shock, I hit "Cancel". The second time through, the game crashed again at the exact same spot. I opted to save the beatmap before it closed. Now, when attempting to open the difficulty that was saved, the game crashes immediately upon selecting it. On a different difficulty, at the exact same time, rather than crashing the game simply froze for several seconds before notifying me that "an error has been reported" and osu! would "attempt to keep running." Nothing like this has ever happened to me before, and I have not changed any settings or environment except updating to the latest stable version just before this incident occurred.
Edit: Opened another map and the game crashed at 50.7%; unable to get a video because again, while attempting to open that difficulty once more, the game now crashes immediately (as seen in second video below)

Video or screenshot showing the problem:
Game freezing on different map
Game crashing on attempt to open saved map from previous crash

osu! version: 20151120.6 (latest)
I have the same problem. Editor is crashing when it is nearing (starts of) breaks (gray parts in the timeline).

When I open the beatmap again in the editor it attempts to continue playing from the spot it crashed, causing it to crash again.

Also at some breaks it crashes everytime, but at other breaks the screen freezes for about the time of the break part (sound is continuing) and I get
"an error has been reported" and osu! would "attempt to keep running."
osu! version: 20151120.6 (latest)
same here, it always crashes on pauses in the map. Tried several maps with pauses and I get the same result.

Happens on Stable, CE and Beta. Only fallback works for me
same here, now it always crashes whenever i try to click the map
Same here. Tried on Stable Latest and CE. Confirming.

System.NotSupportedException: Specified method is not supported.
at #=qnUFOQKAgEHOUWmsjCCvAN1fs4XqUaSzdF02XYTmQ0nY=.#=qCxsm5Je1V$PJ2JcxaVArWw==(#=q3_QWp7YghheTcIIpBn9721nulpFhrw3CpUONJMz$WT8= #=q_fgMEb38pjvFU$Wu0fAm1A==)
at #=qnUFOQKAgEHOUWmsjCCvAN1fs4XqUaSzdF02XYTmQ0nY=.#=q$ahR6mgLMjFqO4aSFtD9JQ==()
at #=qUU5X8cUMuq0LcWtC2ouZhG2OPhZhoNNjgygeLj7sHzu1QPQWoCxlgKxZfype3zVD.#=qKlR4$suNr8vDpX8mWBfs2w==()
at #=q5tew3WI6DFM1iBvko77BnclGXr9WGfQGRCKXaNMckx4=.#=qKlR4$suNr8vDpX8mWBfs2w==()
at #=q5tew3WI6DFM1iBvko77BnclGXr9WGfQGRCKXaNMckx4=.#=qrQiygAoBNLZXmEMA0dTQyw==()
at #=qjejbjpHySzvxZhMU7$9rGQ==.#=qr$r$FDv4jKrYga$DLbmb6g==.#=qk0NvuejaRkTkIZj$36ychS$jliku8v1oq6UPq8K9lDk=(#=qSuxEfuobyeNUHz2RcKPhkn22K11muf9j8iPyEIy1QNY= #=qTRs7MMpAm5znhwSDeCrgvQ==)
at System.Collections.Generic.List`1.ForEach(Action`1 action)
at #=qjejbjpHySzvxZhMU7$9rGQ==.#=qxQ2GJdeBm5UfVAl8IjIzzlKMM1Yje5iGR9rKtu7TexM=()
at #=qSS90MOU6nxxQ0ERiwpGcxvECWOxwHT2rKEJ548Gy3Ts=.#=qhNsv7Jpjvau__S6EiJlNFQ==(#=qwJroj2Vy5G0KU7KmSf4qbnHpM6VmQ0vD$GXCNNjdJoOKi8J4$17oCpghxsTy$D1l #=q6BLUEywVFiko1IWnLJTYng==)
at #=qjejbjpHySzvxZhMU7$9rGQ==.#=qrQiygAoBNLZXmEMA0dTQyw==()
at #=qpDi7RnCMjgIJfwSvdcP79_yFmsFM_NdrMzmsEPvcEWc=.#=qSbvL1z6xjHX9aRvNbs89Eg==(Object #=qV8l0g1xAKsBzqljT6PmfAw==, EventArgs #=qhouUqlULaRVjBlJf_2654g==)
at #=qqhDYf$$0YMCk2iz$Fk3P4KmyC66ESN7eu8l9tht3LX4=.#=q$CxbiEfQtXK$wBd8Q2Mf0A==(Object #=qV8l0g1xAKsBzqljT6PmfAw==, EventArgs #=qCfzUMRqw_XszD4XsIOq9Mw==)
at #=q5YgLQn4mKlmqSvJCLamK7CGep_j75CbpKnRNoFP1jsI=.#=q0CCpT1BZHErY$tnsxkuBHh55bLi8LD5m9pI7Xc590Qs=(Object #=qV8l0g1xAKsBzqljT6PmfAw==, EventArgs #=qhouUqlULaRVjBlJf_2654g==)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at #=q5YgLQn4mKlmqSvJCLamK7CGep_j75CbpKnRNoFP1jsI=.#=qar4DJyURc6XscCKJRieCew==()
at #=qpDi7RnCMjgIJfwSvdcP79_yFmsFM_NdrMzmsEPvcEWc=.#=qar4DJyURc6XscCKJRieCew==()
at #=qu7aP5ED3_9olFh0eSJGBVw==.#=qf3vvzghY8aHBVyUXEYaQRQ==(String #=qtG6qb73TiNnRvV0XgRq5Hg==, Boolean #=qaB9W52_xKIt7Wu81pIm8jj1lSuyQ$$eyVbJ36NZhS0o=, Boolean #=qQDWFhCNF$5OstBHJlYUFRw==)
Yes same happening to me, it was fine until a certain number of hitobjects and then it crashes whenever i place a single circle past that point.

Only happens on the new versions, Fallback version works fine but once i save the map on Fallback it will always crash on Latest and CE when I try to open it.
I hope it will be fixed soon. I have to work in my storyboards :(
yeah same problem too, well kinda weird but yeah this should be fixed
fallback works without problems for me, so change to that if you have something important to do in the editor
nooo I wanted to continue with my map ;A;
same problem here
Now I cannot edit my maps pls fix it ;w;
Thank you very very much
same here ;w;
same :C
show more
Please sign in to reply.