1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
show more
posted
From latest builds, cuttingedge and stable latest, i'm also having some fps stutter during play randomly.




- What kind of performance problems are you seeing? Low framerate throughout the game? Lag spikes? How often? How long do the spikes last?
Fps stutter during play and also sometimes drops from 240 to 220ish and increased input latency from 4.2ms to 4.6/4.8ms for a really short duration, like 0.3s, and happens quite a lot.

- Is compatibility mode turned on in options? Can you turn it off?
I always have it on because it reduces a bit the frequency of the stuttering

- What GPU are you running on? Do you have two GPUs in your PC? Have you tried both?
Using a GTX 750, only 1.

- Are you running fullscreen? If not, please try this before posting.
Been playing at 1440*900 windowed for years, in fullscreen the problem doesn't seem to happen.

- Provide gl_info.txt from your osu! folder.
Can't locate that file.

- Switch to cutting edge and wait for the lag spikes, then include performance.log from the Logs folder in your osu! folder.
Performance.log

Disabled the "threaded optimization" from nvidia control panel didn't solve the problem, also this is happening in all osu! build.

Other pc specs:

Windows 7 SP1 64-bit
i5 4670k
8GB (2x 4GB) DDR3 ram
GTX 750
500GB 7200rpm HDD
posted
i dont have any problems with lags fps or anything my problem is i cant stream anymore i made a short video that shows the problem i cant do anything about it cuz osu just close itself and thats it.csgo aion league of legends everything is running fine but osu is dying.It happens at min 01:58. i show the whole play from starting osu to the crash so u can see everything is ok unti min01:58 just watch the video and u will see it.
https://www.youtube.com/watch?v=UgQd5sWUaho
posted
I posted on the reddit community about this, and thought I'd share this with you, here is a copy/paste from the thread:
Hey r/osugame, I'm having issues where when I play Osu! I notice that my input is delayed ever so slightly (doesn't happen when on desktop), and I was curious about why this is happening or if any of you have some tips. I've seen the video by HappyStick saying to use an older driver but personally I don't see a reason to use that driver as it's only an issue with Osu!
https://www.reddit.com/r/osugame/commen ... ay_in_osu/
posted
Performance issues: Itermittent lag spikes which bring me down from my average happy 700-1250 fps down to 0 for around 20-250ms at a piece.

Is compatibilty mode turned on: No.

What GPU are you running?: One NVidia GT 740, 4GB Dedicated.

Are you running fullscreen?: Yes. Does it both in borderless and fullscreen mode.

Providing gl_info.txt: Not found.

Switching to cutting edge and waiting for the lagspikes. including performance.log from the logs folder: http://pastebin.com/4bsQUa3K

Other PC SPECS:

Windows 10 Home [Upgraded from Windows 8.1 Home {Windows SP 6.3.6900}
AMD FX-6300 Vishera Hex-Core Processor @ 1.44-4.2GHz
8GB (1x 8GB) DDR3 @ 1600MHz
NVidia GT 740 (4098MB Dedicated memory)
Primary disk: 1TB 7200rpm SSHD (1TB HDD + 16GB SSD)
Secondary disk: (OSU INSTALLED) 160GB 5600rpm HDD

Normally osu! runs at close to 800 fps when in a game, and 500 while in menus and such (IN FALLBACK VERSION).
posted
idk but I'm on Stable ( Fallback Version ) I have the issues

when I open the editor menu , I can't use "CTRL+Z" or sometimes when I try to rotate the slider pattern using "CTRL+G" it suddenly become a single note and idk why...
is this a bug or just a new update result from Fallback version?
posted
OpenGL for osu? horrible idea

majority of us run osu on windows not mac

why bother changing the game render to OpenGL only?

Stable(Latest) is fine only if it supports DirectX

using this ver, my screen goes really choppy heading back to stable fallback version GG
posted

peppy wrote:

We are well aware that there are performance issues for a minority of users out there using our new OpenGL-only release. If you are, try closing it and report back if it helps.

First, check if you are running any of this software:
- F.lux
- Shadowplay (disable desktop recording mode)
- Raptr

Please post here if it affects you, with AS MUCH detail as possible.

Minimum you should post:
- What kind of performance problems are you seeing? Low framerate throughout the game? Lag spikes? How often? How long do the spikes last?
- Is compatibility mode turned on in options? Can you turn it off?
- What GPU are you running on? Do you have two GPUs in your PC? Have you tried both?
- Are you running fullscreen? If not, please try this before posting.


Extra things you can do:
- Provide gl_info.txt from your osu! folder.
- Switch to cutting edge and wait for the lag spikes, then include performance.log from the Logs folder in your osu! folder.
- Video showing exactly what you are experiencing.

If you'd like to take the next step, join us on slack in #cuttingedge and we can try and give you help in real-time.
Here:
-I got no F.lux
-Shadowplay is always turned off
-Don't got Raptr don't know what this is

-In compatibility mode the lags are much better but I got higher latency and no fullscreen then


PC-Stats:

CPU: Intel Xeon e3-1231v3
GPU: Asus Strix GTX 960 OC 4GB
RAM: 2x8GB 1600MHz
Mainboard: Gigabyte H97-HD3
Soundcard: Asus Xonar DX 7.1
CPU-Cooler: be quiet! Dark Rock Advanced C1
Power supply: 530 Watt be quiet
HDD: 1000Gb (650Gb not used)

Osu:

1000 FPS limit (I could go higher but I don't need more)
60Hz Monitor
1920x1080
Fullscreen
Everything disabled (Video, Background, efects, etc.)
01.01.2016 running latest stabil version of Osu

Problem:

DT is lagging on CTB for me.(Tried everything reduce droipped frames, compatibility mode, changing FPS)
I got hard perfromance problems on Catch the Beat at fast Stream maps.
Befor I got this pc I got a way more worse pc and I could run Stream maps without hard lags.
It looks like 30 FPS on Streams but I got 1ms mouse delay and FPS counter says 0.8ms in right corner.
Osu is also looking ugly to me if I use unlimited FPS instead of limited 1000. (With ugly I mean laggy)
HELP I really can't play Stream maps because it's lagging hard!
Examples:
https://osu.ppy.sh/p/beatmap?b=698254&m=2 The ending of this map (last 300 fruits) are legging for me.

https://osu.ppy.sh/p/beatmap?b=144026&m=2 Whole map is hard lagging

https://osu.ppy.sh/p/beatmap?b=107875&m=2 Strange example (only lagging at the non-stream parts)

https://osu.ppy.sh/s/128645 Lagging hard the whole time

Maybe these examples got something similar at these parts.

HELP HELP HELP HELP
posted
Shaders. 'nuff said. DirectX please? :x

(Yes, I know that screenshot is of cuttingedge, but it happens in stable and beta as well.)
Processor: Intel(R) Celeron(R) CPU 925
Graphics card: Mobile Intel(R) 4 Series Express Chipset Family
posted
Guys! I have serious problems running osu!.

At first I liked the "Stable (Latest)" version of osu!, but the problem is, that it has serious frame drops and neither of the options can fix it. And that is not the bigest probem: after returning to the "Stable (Fallback)" version it had the same thing. Now I can not play neither of the versions, that means I can not even play osu! anymore!

I have tried everything and in game and outside the game, I did only worse.

I'm on Windows 7 SP2 64bit with 4gb RAM.

Help me please!!
posted
I Did it i Fixed the High Ms problem =DD
I uploade some screenshots from my Options,basically i change the [Updates Release Stream]to:[Stable Fallback] and it worked.!
I USE FULLSCREEN JUST WINDOWED IT FOR SCREENSHOTS!

Options:
http://puu.sh/mrGjv/8bf51be8ec.jpg
http://puu.sh/mrGkV/3ef070a601.jpg
http://puu.sh/mrGlT/9042a963e5.jpg
http://puu.sh/mrGmR/3ec57142f8.jpg
http://puu.sh/mrGnT/4f0d12f516.jpg
http://puu.sh/mrGoA/7329fadcae.jpg

I Realy Hope this will Help u guys.Try it! ;)
posted
I got Frame drops on stable(latest) from 2000FPS down to 40FPS at CTB on random maps! (Captured frames with Fraps)
Often at DT playing!
posted
Problem Details

Hello,

I'm currently playing Osu! on a Macbook and whenever I play mania mode with quite a bit of notes falling down in one screen (usually hard or insane difficulty maps), I suffer intense lag.

The lag doesn't occur when I'm in auto mod/spectator mode but does occur whenever I press down a key to hit the notes during the gameplay.

I was/am only able to play easy/normal difficulty mania maps due to this problem.

The intensity of lag goes up if I lower the resolution of the game and even if I change any graphical settings, it always resets back to its original settings when I re-run Osu.

The game still lagged when only Osu! out of all the applications installed on my laptop was running.

My Mac Os X is up-to-date as well as my Osu! game, so the root of this problem doesn't seem to be the lack of my laptop's performance.

I wish to play Osu! smoothly without any frame drops on Mac OS X (I refuse installing Windows).

Help me please :(


osu! version: b20151228.3 (Stable Fallback) - latest
posted
Lately i'm getting some weird stuff.
I only need to use the option to reduce drop frame in the first hours of osu, after that it is not needed.
posted
Hey everyone i have a big problem!!!!

After the new update i have on the stable Latest version only ~4300maps and that are only maps from 0-3 star maps. But when i play on the Stable Fallback version i have all my beatmaps (~12000). I have only on the fallback version all my maps. How i get back all my maps on the Stable Latest version????
posted

DevilJiro wrote:

Hey everyone i have a big problem!!!!

After the new update i have on the stable Latest version only ~4300maps and that are only maps from 0-3 star maps. But when i play on the Stable Fallback version i have all my beatmaps (~12000). I have only on the fallback version all my maps. How i get back all my maps on the Stable Latest version????


Check that.
posted
-I am experiencing lag spikes when playing. Gameplay feels choppy and my cursor seems to be teleporting or freezing in place and slowing down when the lag spikes occur. The "Reduce dropped frames" option doesn't help. Frame rate is also much lower and more unstable than in stable fallback. 230-370 in stable latest, and around 700 in fallback.

-Compatability mode is off

- I'm running the game on:

ATI Mobility Radeon HD 4650
Inter Core 2 Duo P8800
4GB RAM
Windows 7 64-bit

-I'm running the game on full screen + letterbox

-performance.log
posted
GPU: Geforce GTX 760
OS: Windows 10 Pro
Ram: 32gb
CPU: AMD Phenom II x4 3.4ghz
System Parts list: http://pcpartpicker.com/p/fhTz23
Main Display: LG 29UM55-P (2560x1080) 21:9 ratio 60hz using a hdmi cable
Secondary Display(for osu): Dell p780 17" CRT box monitor (800x600) 4:3 ratio 120hz using DVI to VGA adapter to connect VGA cable from the monitor
Tablet: CTL-460 Bamboo

My issue is with any other build besides fallback, even tho the game is running in fullscreen 800x600 120hz fullscreen mode and reports it is displaying 120fps, it only visually displays 60fps because my primary display is 60hz, changing my primary display to 75hz allows the game to display 75fps, seems OpenGL limits its framerate based on your primary display and not the display the game is running on.

Update: changing my primary display to my CRT display does fix the fps delay, but it also creates other issues with my operating system, because my primary display is now an 800x600 monitor, some programs will always open on the primary display.
-Changing my primary display is only a temporary fix I will not consider it a solution.
posted
I just uninstalled my drivers and GeForce experience and used the windows update (on win10) to download and install the drivers, it fixed almost everything for me.

I have NVIDIA GeForce GTS 250, I still have some minor shuttering, so here's the performance log http://puu.sh/mTNFj/1be6270769.rar
It works quite better on stable(lattest).

I know it doesn't make much sense but well u can always try.
posted
I had Performance Issues on Latest/Beta/Cutting Edge Builds. The music and fps were laggy.
With compatibility mode activated, everything worked fine, but there was a clear input delay :/ The fallback version worked also fine.

Then I've turned Raptr off and everything ran smooth again!
posted
PC Specifications:
Intel Core i3-3220
GTX 650 Ti
8GB DDR3
Windows 10 Professional

I have issues with latency, in which osu! on Stable(Latest) as well with other builds does not go completely full screen, but on Stable(fallback) seems to have no issues with latency at all. My attempts on solving the issue is restarting the PC, and run osu! afterwards but still the latency issue still occurs in the later hours of usage, probably when browsers are opened etc.

I noticed when the game is not completely go on fullscreen, changing the Windows volume through keyboard commands, the volume meter appears on the upper left while when it's on the intended fullscreen it does not appear like other games running on fullscreen. Example image provided below. Thank you very much.

show more
Please sign in to reply.