1. osu! forums
  2. osu!
  3. Development
show more
posted
Hey,
Thanks for having written this - and keeping up to date.

That said, it doesn't seem to work on my side - under Debian stable (stretch).
I've tried so many tutorials but I'm really stuck. Since I wiped my Windows partition in December, I didn't find a way to play osu! again and it's quite troublesome to me.

Here's a video showing my problem, just dumbly copypasting your commands :
https://youtu.be/_cDb7CYPcjE

As usual, wine is going nuts and I don't have a clue of what's happening.
I know your tutorial isn't especially designed for Debian systems, but if you have any idea of where I can start digging to have a chance to make it run, please let me know.
Thanks for your help.
posted

Neil Watts wrote:

Hey,
Thanks for having written this - and keeping up to date.

That said, it doesn't seem to work on my side - under Debian stable (stretch).
I've tried so many tutorials but I'm really stuck. Since I wiped my Windows partition in December, I didn't find a way to play osu! again and it's quite troublesome to me.

Here's a video showing my problem, just dumbly copypasting your commands :
https://youtu.be/_cDb7CYPcjE

As usual, wine is going nuts and I don't have a clue of what's happening.
I know your tutorial isn't especially designed for Debian systems, but if you have any idea of where I can start digging to have a chance to make it run, please let me know.
Thanks for your help.
thanks for debugging my guide

looks like I made a copypaste mistake, the osu!install command is supposed to be
WINEPREFIX=~/osu-wine WINEARCH=win32 wine ~/Downloads/osu\!install.exe


other than that it looks like the other steps went fine
posted
Oh my god, seriously, thank you.
https://i.imgur.com/SZHfiTV.png

I was thinking the installation failed because of all the errors wine was throwing in the console, without even trying to understand why there was a command attempting to open osu!install.exe with regedit.

Can't thank you enough, I'll be able to click circles again now.
Feel free to contact me if you need to debug anything under Debian.
posted
hello there. i have got arch linux. i was about to throw this away because no internet connection on wine. but now i figured how to fix that. write "sudo pacman -S lib32-gnutls" and i guess your issue will be fixed.
posted
https://osu.ppy.sh/ss/10759611 do you think i can do anything with this?

specs: HP ProBook 450 G1 (arch linux + KDE)
processor : i5-4200M @ 2.50 ghz
graphics: intergrated
ram: 3.7gb
thats all sadly.

i have got better performance on win.
posted
posted
posted

snowbliss wrote:

you messed up a lot of the links when you edited the post to newest revision



they turned out like this . . " https://github.com/Francesco149/loli-ov ... sound.conf "

" https://wiki.archlinux.org/index.php/Ad " --> ur alsa arch wiki link lol

newcomers might be confused
uhh I think that's the new forums' fault, I'm pretty sure I pasted the links correctly lol will try to fix

EDIT: fixed them, thanks for the info

snowbliss wrote:

wine staging is updated for wine 3.5 / 3.6 now

staging might improve quality of gameplay as it offers improvements for "realtime" and "I/O heavy" games/apps
good to know! but staging never affected performance on osu for me and I think arch is the only one that has up to date wine staging so i decided to leave it out

EDIT: guess I'll add that staging is fine too if desired

[Vanilla Coke] wrote:

hello there. i have got arch linux. i was about to throw this away because no internet connection on wine. but now i figured how to fix that. write "sudo pacman -S lib32-gnutls" and i guess your issue will be fixed.
ah, I thought arch had fixed this by now, guess I'll readd this to the guide, thanks for testing

[Vanilla Coke] wrote:

https://osu.ppy.sh/ss/10759611 do you think i can do anything with this?

specs: HP ProBook 450 G1 (arch linux + KDE)
processor : i5-4200M @ 2.50 ghz
graphics: intergrated
ram: 3.7gb
thats all sadly.

i have got better performance on win.
if you already tried everything on https://wiki.archlinux.org/index.php/intel_graphics I recommend trying a barebones window manager like jwm ( https://wiki.archlinux.org/index.php/JWM ) or a lightweight DE with no fancy effects like lxde

KDE plasma is gpu accelerated and might be eating fps

if that still doesn't help, most likely the intel drivers aren't quite as good for your gpu :[ you can also try installing a cutting edge kernel and mesa for newer drivers but from what i can see the stock arch packages for those are already quite cutting-edge
posted
posted

snowbliss wrote:

after a bunch of testing wine 1.8.3 still seems to offer far superior audio latency with winetricks sound=alsa flag


idk how to change winealsa.drv on newer versions of wine, i'm guessing that's the problem ? ?
well, we had a bug report on wine's tracker about it and never managed to figure it out even though I remember bisecting commits and finding exactly which commits broke it

idk, maybe it's cause I'm on pure alsa now but 3.5 latency feels the same as what I had back when I was on 1.8.3 and pulseaudio
posted
posted
posted
Just came back from eternal slumber. Wine 3.0.1 seems to have neat and good compatibility though.

Ubuntu 18.04 with Artful build of Wine. Running it with generic kernel gives me usual latency and lag, while with low-latency kernel gives me better gameplay but... crappy sound (especially when it comes to hit sounds).
posted
Hi,
I have question about the dsound regedit setup, I'm lost on how it suppose to be set up exactly in wine regedit. I've done everything else and it all works except for the audio latency issue. I'm using Manjaro kernal 4.14.

Any help will be appreciated.
posted
regedit: No such file or directory

regedit: Unable to open the file 'dsound.reg'.


I guess you can manually use regedit to add i
posted
I'm using i3wm and I cant open .osk files. I tried xdg-mime but I don't know how to get it to work. thank you for help.

edit: i know that i can drag it to the window with osu or install firefox to open it but that just takes time. i liked how it worked on my xfce or kde.
posted
Suggestions:
1. Install `cabextract`: `sudo apt install cabextract`
2. Install Wine (I mean, you told me to add the repository WITHOUT installing wine?!) `sudo apt install winehq-stable`
3. On Bionic (18.04), you probably don't need the repository (no bionic in repo): `sudo apt install --install-recommends wine-development`
posted
nvm, i figured it out.

btw i use arch. in aur repository is a package named mimeo so install that. you also should install xdg-utils and perl-file-mimeinfo from official repositories.

then download some skin and beatmap (their file extensions must be: .osk and .osz) and in terminal write:
# replace the directory with your directory with these files.
cd directory
# now we'll use the tool we installed. change file.osk with the name of the actual file.
mimeopen -d file.osk
# now it will say if you want to open it with smth so select other if it's there. then write just osu and it will open osu with that file and also it will set as default. if #you don't have an option other in mimeopen then select osu!.
#
#now we'll do this same with .osz extension
mimeopen -d file.osz
# now it will say if you want to open it with smh so select other if it's there. then write just osu and it will open osu with that file and also it will set as default. if #you don't have option other in mimeopen then select osu!.
sorry if it's not clear. i hope that francesco will rewrite this to actual guide. be free to ask me for smth
posted
fps drop. playonlinux is better oon performance. can help me increase fps?
posted
It should noted that the hovering issue on Wacom tablets has been fixed upstream since input-wacom version 0.41.0 and kernel 4.18.
See this github issue: https://github.com/linuxwacom/xf86-input-wacom/issues/14
show more
Please sign in to reply.