1. osu! forums
  2. osu!
  3. Development
show more
posted

SebDaMuffin wrote:

RaidMax wrote:

What's the process to put it in compatibility mode?
There's a checkbox in the options menu.

However I use the closed source nvidia drivers and note no difference with compatibility mode. I get 1k+ fps regardless. osu is perfectly playable for me now on linux because of the delay being fixed, but I've never had fps issues. I had a geforce 8800 gts before and switched to a gtx 660. I'm not sure what the problem would be here but I can report extremely good fps performance with the closed source driver and those 2 cards. Not that I think it matters much but I'm using wine staging 1.7.51 patched with Francesco's winepulse on arch linux and nvidia drivers 352.41. Working sweet on stock kernel 4.1.8 and ck kernel too. Also works fine on both beta and cutting edge release streams for me. Are you sure the wine prefix is setup correctly?
I have about racked my brains trying to fix this issue. I really think it's the wine prefix, so I'm going to try deleting it and starting again. I have a NVIDIA GeForce GTX 670. I locked 902 fps on windows, so I should be getting acceptable performance on here. Using nvidia-346 drivers and and 3.19.0-28-lowlatency for Ubuntu. I have literally done EVERYTHING to get OpenGL to see the 32bit libraries, so I really think it's wine. Will report back.
posted
AT LAST. After untold hours, close to destroying my PC, I have succeeded! It ended up being the wine prefix. I had reset it previously, but for whatever reason something was still screwed up. Since I'm at work I wasn't able to play, but getting 120fps capped on the menu was 100x better than stable, so fingers crossed it will be nice and smooth :). Thanks for your help!
posted
Runs perfect on Debian 8 with XFCE. i5-4690k and AMD R9 280x. Interestingly, setting it to unlimited fps matches my monitor refresh (60Hz), but it runs 240 fps just fine. However, in winecfg, with winealsa.drv running, the test sound option did not work. The dmixer terminal test and osu sound just fine though, so it is just the winecfg.
posted
Hey dude, I appreciate the guide, but at the step where we fix the bancho disconnecting, I follow your exact instructions of replacing the user name with my own user and executing the command ALSA_DEFAULT_PCM="plug:dmixer" WINEPREFIX=~/.wine WINEARCH=win32 wine '~/.wine/drive_c/users/<your username>/Local Settings/Application Data/osu!/osu!.exe' leads to Ubuntu saying wine cannot find this. I have replaced my user name, and i have checked to see whether the directory was correct and it indeed was correct. I dont know what is causing this issue but it is preventing me from playing online, any helpful advice would be appreciated.
posted

Jmart wrote:

Hey dude, I appreciate the guide, but at the step where we fix the bancho disconnecting, I follow your exact instructions of replacing the user name with my own user and executing the command ALSA_DEFAULT_PCM="plug:dmixer" WINEPREFIX=~/.wine WINEARCH=win32 wine '~/.wine/drive_c/users/<your username>/Local Settings/Application Data/osu!/osu!.exe' leads to Ubuntu saying wine cannot find this. I have replaced my user name, and i have checked to see whether the directory was correct and it indeed was correct. I dont know what is causing this issue but it is preventing me from playing online, any helpful advice would be appreciated.
try ~/.osu/drive_c/users/<your username>/"Local Settings"/"Application Data"/"osu!"

note that your username is your linux username, not osu username
posted
hey i've followed your tutorial and got osu running which is nice 8D thanks for the guide

The thing i'm not able to do however is get OpenGL to work. I must say though trying to change the release stream from stable(fallback) to cutting edge doesnt stick. it goes back to stable fallback immediatly and says osu is up to date. Got any idea whats going wrong?

Cheers
Zaros
posted

ZarosTenjin wrote:

hey i've followed your tutorial and got osu running which is nice 8D thanks for the guide

The thing i'm not able to do however is get OpenGL to work. I must say though trying to change the release stream from stable(fallback) to cutting edge doesnt stick. it goes back to stable fallback immediatly and says osu is up to date. Got any idea whats going wrong?

Cheers
Zaros
Exact same for me, and I also seem to have problem that RaidMax had, I get 50~ fps on nvidia gtx 770 and proprietary drivers, so I think it is not using proper driver or somehow
posted
Dude, awesome! I tried to set up osu! on Linux in the past but I never got it to work fully (either there was too much sound latency, input lag or low fps, etc). I followed your guide on a clean Xubuntu install and performance seems to be on par with Windows (at least at a first glance).


(don't mind the screenshot artifact)

My specs:
AMD Athlon II x4 620
ATI RadeonHD 6850
8GB ram

to ZarosTenjin and kaiske, I had the same problem, whenever I click on Cutting Edge the game would automatically go back to Stable (fallback). What I did is start the game in Windows, set it to Cutting edge there and then just copy the files over to the Linux partition, worked like a charm for me.
posted
rev.6
added arihosu's advice for problems with switching to cutting edge
changed polling rate to 500hz because 1000hz can cause xorg to lag even on good cpu's
posted
hey, I have problem when I must connect to buncho.
I have that massage - what I can do if I don't have that? :o
http://i.imgur.com/f2lac6q.png
Someone could help? ;o
posted

TheTanadu wrote:

hey, I have problem when I must connect to buncho.
I have that massage - what I can do if I don't have that? :o
http://i.imgur.com/f2lac6q.png
Someone could help? ;o
try
~/.osu/drive_c/users/<your username>/"Local Settings"/"Application Data"/"osu!"/"osu!.exe"
posted
exe not found :o but.. I do all of this in your post my master :D
http://imgur.com/WTGFf6g
Just crsor is like if I must something write. ;-; :D
posted

TheTanadu wrote:

exe not found :o but.. I do all of this in your post my master :D
http://imgur.com/WTGFf6g
Just crsor is like if I must something write. ;-; :D
forgot to replace the wine profile
~/.wine/drive_c/users/<your username>/"Local Settings"/"Application Data"/"osu!"/"osu!.exe"
posted
I have one problem with osu, the audio skips,pops, crackles and ive followed the guide. maybe you can help me? remotely or something.
posted
;_; I try but when I make that, I got "bash" to write something - first time I have problem with wine ;-; :D
http://imgur.com/zrNhuRd
or I'm stupid ;-;
posted

TheTanadu wrote:

;_; I try but when I make that, I got "bash" to write something - first time I have problem with wine ;-; :D
http://imgur.com/zrNhuRd
or I'm stupid ;-;
Try This.
'~/.wine/drive_c/users/<your username>/Local\ Settings/Application\ Data/osu\!/osu\!.exe'
posted

TheTanadu wrote:

;_; I try but when I make that, I got "bash" to write something - first time I have problem with wine ;-; :D
http://imgur.com/zrNhuRd
or I'm stupid ;-;
remove the single quote at the beginning
posted

TheAussie wrote:

I have one problem with osu, the audio skips,pops, crackles and ive followed the guide. maybe you can help me? remotely or something.
does it also crackle during alsa audio tests?
posted

Franc[e]sco wrote:

TheAussie wrote:

I have one problem with osu, the audio skips,pops, crackles and ive followed the guide. maybe you can help me? remotely or something.
does it also crackle during alsa audio tests?
No, it was when i switched to PulseAudio for OBS, but i have configured settings a bit different since then and it doesn't seem to be happening.
posted
Can't get ce or beta run on wine :<

What I had installed in osu's prefix:
nat@nat ~ % ./winetricks list-installed       
baekmuk
corefonts
dotnet20
dotnet20sp1
dotnet30sp1
dotnet35
dotnet40
dotnet45
eufonts
gdiplus
gdiplus_winxp
msxml3
takao
unifont
wenquanyi
./winetricks list-installed 4.95s user 2.81s system 87% cpu 8.899 total

But when I try to switch to ce or beta, it automatically switch back to stable fallback. So I switch that on Windows as suggested. osu! did update itself to ce on Windows, but when I try to run it with wine, osu!update shows up and 'update' osu to stable fallback version... :I

I am not on linux, but OS X, not sure if that matter.
show more
Please sign in to reply.