[resolved] Windows 10 mouse stuttering even after regedit fix

posted
Total Posts
10
Topic Starter
Railander
Problem:
osu! stutters whenever i move my mouse.

No combination of the following makes any difference:
125 Hz / 500 Hz / 1000 Hz (it does lag considerably less at 500 and 125 Hz).
stable / beta / CU
windowed / fullscreen
raw input / normal input
dpi display scaling compatibility / win7 compatibility / win 8 compatibility / normal compatibility
with regedit fix / without regedit fix

Did not have the problem on Win 7.
Did a full format a few months ago to 8.1 and the problem started. Did another full format a month ago for win 10 and still the same problem as win 8.1.

running a pretty high-spec PC with fully updated drivers.
problem happens in a few other games as well, "fixed" reducing the mouse polling rate to 125 Hz.

i did a long, in-depth search on the internet and every single place i can find points about the mouse system change on 8.1+ and how all you need is a registry edit, but it didnt work for me on 8.1 and doesnt work on 10 neither. would love if someone could give me some light onto this...
Arcane
What kind of stuttering is it? is it like 1 fps (Very heavy stuttering) mouse movement stuttering or is it more like input lag stuttering??
Topic Starter
Railander
no input delay, the game screen is just doing a lot of microfreezes.
sound is unaffected.
Arcane
well i dont know the problem sorry.. BUT! if it worked on windows 7 there might be something you can do about it :) but i dont know if it works
Follow these steps in windows:


  • - System
    - advanced system settings ( left side of the window )
    - Settings (Tab: Performance)
    -''adjust settings to increase performance''


i'd recommend you to turn one thing on there and that is something called : use templates instead of icons. or something XDD this will enable that when you go to : for example, your pictures that it will show a mini version of your picture and not the windows picture icon ^^

I hope this will work and other wise maby check your hardware or mother board there could be something wrong with the chipset divers or anything that has any relation to the USB ports

Good Luck!!!! :D
Topic Starter
Railander
no difference, still same problem.
Arcane
Hmm well could you make a video of it?

are your Temps right? Gpu, Cpu, etc. ?? maby thermal throttle??? + system specs
eugene0420
Have you tried switching renderer? I had stuttering using OpenGL.
If you're on cutting edge, check the compatibility option.
Topic Starter
Railander
directx/opengl made no difference either.
temps are just fine. like i said, the stutter only happens when i move the mouse.
Topic Starter
Railander
as in a miracle i tried, just for the heck of it, unplugging my tablet from the PC.

mouse stopped stuttering at 1k Hz, or at least enough to make the game playable. seems like it was the culprit somehow, even though i had no problem with that in win 7.

...dont ask why i have tablet and still use mouse.
Arcane

Railander wrote:

as in a miracle i tried, just for the heck of it, unplugging my tablet from the PC.

mouse stopped stuttering at 1k Hz, or at least enough to make the game playable. seems like it was the culprit somehow, even though i had no problem with that in win 7.

...dont ask why i have tablet and still use mouse.
OMG now you mention it .... i had the exact same thing ... but a long time ago!!!! but i dont know how i fixed it :/ or if i didnt it just dissapreared one day ... but yea you are right~ Thank you ^^ re-learned someting hahaha

edit: I Remembered how i fixed it!!! When i bought my new mother board the problem was gone~
Please sign in to reply.

New reply