[Archived] Osu Crashes when completing, restarting or exiting a beatmap

posted
Total Posts
3
Topic Starter
GranmasGotGame
Problem Details:

So whenever I try to complete, restart (retry), or exit a beatmap. Osu will give me the prompt "osu! has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

It then gives me the option to Debug or Close Program. Should I press Debug it gives me the prompt "No registered JIT debugger was specified. Click on retry to have the process wait while attaching a debugger manually. Click on cancel to abort the JIT debug request" - retry indefinitely suspends the program and cancel closes it completely.

This problem has only appeared in the past couple of days (08/13/2015) and has never happened before to this extent. The only time I encounter this problem, however, is when I complete, retry, or exit a beatmap. Here's the kicker. When I went to reinstall, because the uninstaller is run through OSU, I got the same error message and was unable to uninstall.

The thing I don't understand is that it doesn't always happen. It seems to happen randomly. Sometimes I can finish, retry, or exit multiple beatmaps without a problem. Then out of no where, "osu! has stopped working..." Other times I open up Osu! Break a combo on my first try, go to retry- "Osu1 has stopped working..."

Trouble Shooting that I've tried:

-Moving osu!.exe to its own folder and running that version.
-Moving osu!.Nathaniel PC.cfg out of folder, and back into folder
-System restore to before the problem occurred (08/11/2015)
-Deleting Osu!, and re-downloading/ installing

-Punching my screen
-Swearing up a storm
-Crying in frustration
-Praying to God
-Praying to Satan
-Praying to that OSU chick
-Sacrificing my sister
-Pouring my blood onto the keyboard
-Staring blankly at the screen

^^sorry, just having a little fun there. (my problem is real though :cry: )

Note ~ The only thing I'm suspicious of is whether or not the update has anything to do with my problem. OSU! auto updated when I started it up after the system restore, so it wasn't the exact same OSU! from the 11th. Though if I'm the only one having this problem then I doubt it has anything to do with the update.

Thanks for taking the time to read this
~Though if you didn't.............R.I.P

-Nate

Video or screenshot showing the problem:

1. ~ https://gyazo.com/b932baaeee827edadf75c2434514300b
2. ~ https://gyazo.com/442fa613172f8ddea852df30d067ffa8
3. ~ https://gyazo.com/da62db8979bd8fe115bc4dbca9541e4a
4. ~ https://gyazo.com/534867fc9e08f26fff2b198f69e5409c

All GIF's of the process, i have the full video if needed.


osu! version: 20150814.7stable
Arcane
Hello there, first of all XD i had a great laugh with your troubleshooting methods (sometimes i use the same methods) XDDD

Okay so, what i think that your problem is with the JIT debugger has probably something to do with the '' .Net '' version you are running. Try to update it to the latest version, this should fix the problem.

Does the happen with other games aswell??

if it still happens please tell me!! and if you see any error codes. NO MATTER WHICH ONE please list them in here.

I wish you good luck~
mcpower
I'm having the same problem. I've had it since b20150815cuttingedge, and still persists on the latest cuttingedge release today (b20150816.5cuttingedge). I'm interested in why GranmasGotGame has the crashing on a stable version of osu!, though. Switching to the beta stream (b20150814beta) fixes the problem.

Some more notes:
  1. occurs in editor preview, replays, gameplay
  2. it only occurs after a hit object has been hit. quitting before this point does not cause a crash
  3. persists while offline
  4. persists with windowed/fullscreen, shaders/nonshaders, any framerate limiter
  5. does not occur with compatibility mode on
  6. I have not updated my graphics card drivers. I'm currently on GeForce 337.88, but I will update to 355.60 now and see whether that makes a difference.


Edit: UPDATE YOUR DRIVERS. Completely fixed the problem for me.
Please sign in to reply.

New reply