1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Problem Details:

I seem to have a weird problem when I play Osu with my mouse. While I'm playing the regular Osu mode, my cursor kinda twitches a little. It's kinda hard to explain, but sometimes the cursor freezes for a split second and then warps to where it should be. Also, when I do spinners, the cursor suddenly stops out of nowhere while my mouse is spinning. I've tried to make sure that it wasn't my hand's fault and that other programs running weren't ruining my gameplay, but it still acts jittery. I run Windows 8 on a Dell laptop. I have about 4 GB of RAM as well.. And for my mouse sensitivity?
Raw Input: ON
Sensitivity: 1.6x

Oh, and my mouse brand is Logitech. I can't really find a dpi thingy for it though..

..A-any suggestions to fix my mouse lag? c: (I swear, I bet it's something simple, like "get a tablet instead" or something..)

osu! version: 20150414.2 (latest)
posted
Well, do you know if your mouse has a high polling rate (like, 1000Hz)? Some CPUs that are not so powerfull have problems with high polling rates and it could cause this type of mouse lag. Also, can you try to set your ingame sensitivity at 1 and see if it works properly? (I don't believe much in this, but give it a try).
posted
My mouse polling rate only gets to about 128Hz, nothing higher.. I'll try playing with mouse sensitivity 1 in a bit and see if it's still twitchy. ..But if I need it to be faster, what can I do besides changing the sensitivity in Osu settings?
posted

Notester82 wrote:

My mouse polling rate only gets to about 128Hz, nothing higher.. I'll try playing with mouse sensitivity 1 in a bit and see if it's still twitchy. ..But if I need it to be faster, what can I do besides changing the sensitivity in Osu settings?
Does your mouse have any kind of software to adjust DPI? And well, if it works nice with 1x, I guess you will adjust the sensitivity from Windows. Also, make sure that you have Windows mouse acceleration disabled.
posted

Trosk- wrote:

Does your mouse have any kind of software to adjust DPI? And well, if it works nice with 1x, I guess you will adjust the sensitivity from Windows. Also, make sure that you have Windows mouse acceleration disabled.
..My mouse doesn't have DPI settings.. ;~; I'm doing pretty well with 1x sensitivity though, so I'll just adjust my mouse speed in Windows settings.. Does this mean I have to turn raw input off so Osu can acknowledge my mouse's speed?
posted

Notester82 wrote:

..My mouse doesn't have DPI settings.. ;~; I'm doing pretty well with 1x sensitivity though, so I'll just adjust my mouse speed in Windows settings.. Does this mean I have to turn raw input off so Osu can acknowledge my mouse's speed?
Yes, you will need to disable Raw Input if you want osu! to detect a custom sensitivity on Windows.
posted

Trosk- wrote:

Yes, you will need to disable Raw Input if you want osu! to detect a custom sensitivity on Windows.
..Wow.. I've played through a couple maps and my mouse is working much more smoothly now.. :) Also turns out that the random spinner stopping was just me accidentally lifting up my mouse while I spun. ._.

Thanks for the help..
posted
my mouse doesnt stutter at sensitivity 1 but i play Hard or Normal So i cant keep up because the sensitivity is low, Anyway to fix the stuttering without making the sensitivity 1
Please sign in to reply.