[resolved] osu! randomly does not register me clicking on a slider

posted
Total Posts
5
Topic Starter
huu
Problem Details:
Everything is usually fine, but there are those random moments when osu! just doesn't register that I'm clicking on my keyboard.
This is only an issue with sliders, as hit circles and spinners work like they are supposed to.
It doesn't matter if I plug in my external keyboard or not (I play on a laptop), my clicks just sometimes randomly don't register and I have no idea what gives.
Although, I have to admit that this happens rarely.
If any of you will ask, no, this issue does not happen on any other game, it happens only with osu! from what I've gathered so far. Super Hexagon, CS:GO and Need for Speed World all register every single click of my button just fine.
Yes, I have tried rebinding my keys from Z and X to Q and W and then to NUM1 and NUM2, issue still there.

Video or screenshot showing the problem:
I do, however, have an instance of this recorded, where it happens while I'm playing a Knife Party Centipede map.
http://www.youtube.com/watch?v=MDkL6sujjzQ

osu! version: 20150305 (latest)
blahpy
I'm going to assume you used your second key for that slider since it was just after the first one. Have you turned your mouse buttons off by pressing F10? If a mouse button is being held down (or pen in contact with the tablet if you use that), then it'll override one of your keyboard buttons.
VeilStar

blahpy wrote:

I'm going to assume you used your second key for that slider since it was just after the first one. Have you turned your mouse buttons off by pressing F10? If a mouse button is being held down (or pen in contact with the tablet if you use that), then it'll override one of your keyboard buttons.
If that was the case his cursor would be constantly expanded.
I thought of posting "enable the key overlay in the options to give us a better way to check", at first,
but the cursor expand tells enough. So yeah...
Topic Starter
huu

blahpy wrote:

I'm going to assume you used your second key for that slider since it was just after the first one. Have you turned your mouse buttons off by pressing F10? If a mouse button is being held down (or pen in contact with the tablet if you use that), then it'll override one of your keyboard buttons.
My mouse buttons are indeed off.
Topic Starter
huu
Hey guys, I fixed the issue.
Turns out my keyboard drivers were out of date.

Updating them completely fixed this issue.
Please sign in to reply.

New reply