1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
show more
posted

BanchoBot wrote:

Issue(s) in this thread have been addressed by the following changes:
  1. Fix spinners being mispositioned when osu! is run at a 5:4 resolution. (peppy)


The changes will be applied to builds newer than b20151014.4cuttingedge.

Please follow up in this thread if you believe more work needs to be done to fix the mentioned issues. If they have not yet been resolved, please provide any new details that may have arisen after this build.
I'm running on b20151014.6cuttingedge. The spinner elements are messed up.




posted
Not really an issue, but:


Can we have this as a toggle or user-controllable setting of some sort? The search radius is inconsistent for me, and there are people who live in my city that I never see in my nearby list unless there are only 3 or less other people online in my neighbourhood.
posted
It will always include close people. If you don't see them, they are probably offline.
posted

peppy wrote:

It will always include close people. If you don't see them, they are probably offline.
I have people on my friends list that live in the same city, but I haven't seen them on my nearby list since 2013 (I'm assuming this is to blame on my ISP rather than osu! though, as I remember a time when I suddenly became alone in my nearby list with nothing in the changelog explaining why).
I can still see them online in my friends list, but I've only started to see them appear on my nearby list again whenever this search radius decides to increase itself. It would be nice if I had the option to permanently increase the radius like this, but right now it seems to rely on how many "close" people are online. I live on the outer reaches of my city, so I normally only see a few people in my nearby list anyways.
posted
Issue(s) in this thread have been addressed by the following changes:
  1. Fix remaining spinner alignment issues. (peppy)


The changes will be applied to builds newer than b20151016.1cuttingedge.

Please follow up in this thread if you believe more work needs to be done to fix the mentioned issues. If they have not yet been resolved, please provide any new details that may have arisen after this build.
posted

riktoi wrote:

I get occasional "disconnects" (can't really call them disconnects since it's more like the icon just showing up and going away) with this error message:

13.10.2015 18:37:29: BANCHO error: System.Net.WebException: Yhteyden muodostaminen etäpalvelimeen ei onnistunut ---> System.Net.Sockets.SocketException: Yhteyttä ei voi muodostaa, koska kohdekone ei salli sitä 141.101.112.193:443
kohteessa System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
kohteessa System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
--- Sisäisen poikkeuksen pinon jäljityksen loppu ---
kohteessa #=qFpJ7mYu0N56bzruZYCDMHh$Kv3qOSbSA$p$IC1LJuTo=.#=qfEULBnkOLWOSnU05e8OpkuVLhivWZEoIpbN8Kc0qL6g=()
kohteessa #=qAEYSVWenCExXoEZ1XzBV0EaVoDcGEWyOJoSH_BVkokE=.#=qczLKDFy7BTTfFmVQLSWiAA==(Boolean #=qov5S2_WdVpUesSjxtMRdsw==)
kohteessa #=qAEYSVWenCExXoEZ1XzBV0EaVoDcGEWyOJoSH_BVkokE=.#=qUrvekdHAx9e4odwNZFSVaw==()
still happening
posted

BanchoBot wrote:

Issue(s) in this thread have been addressed by the following changes:
  1. Fix remaining spinner alignment issues. (peppy)


The changes will be applied to builds newer than b20151016.1cuttingedge.

Please follow up in this thread if you believe more work needs to be done to fix the mentioned issues. If they have not yet been resolved, please provide any new details that may have arisen after this build.
I'm running on b20151016.2cuttingedge. It's still not good.







This is the list of spinner elements that I've noticed the alignment issues in the screenshots.
  1. spinner-metre.png
  2. spinner-glow.png
  3. spinner-clear.png
  4. spinner-rpm.png
  5. spinner-spin.png


I hope these will be helpful. :D
posted
I get many "disconnects" (even though they are only for 1 - 5 seconds): My Network-Log displays the following (sorry it's in german):
18.10.2015 10:06:23: BANCHO error: System.Net.WebException: Die Verbindung mit dem Remoteserver kann nicht hergestellt werden. ---> System.Net.Sockets.SocketException: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte 141.101.112.193:443
bei System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
bei System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
--- Ende der internen Ausnahmestapelüberwachung ---
bei #=qOqnn2py2PwnU6$uIXam5$1hXzS6UUieMPbkKDI_FVPc=.#=q$Bz1$LBsM96PprOLQ9E5__Q_74h1lBvci5dKAo1UTAo=()
bei #=qM_sMLwEooPizZhaXp7Xl7VKF4UtuhpKQmwS$eHLM$CA=.#=qdgnVfxXyE9duXHDbDpkxmw==(Boolean #=q1ocCHbkqEwatFzDdnT_mzg==)
bei #=qM_sMLwEooPizZhaXp7Xl7VKF4UtuhpKQmwS$eHLM$CA=.#=qCXneXgBcG5TjuIpFeEWoSg==()
posted
Kind of issue: If you select Target Practice and Relax you are still able to fail. I guess that is because some Players might want to play Target Practice without clicking all the time, but you're not able to select NF at this point. So you can't play TP without dying and clicking
posted
:D

Denro wrote:

I get many "disconnects" (even though they are only for 1 - 5 seconds): My Network-Log displays the following (sorry it's in german):
18.10.2015 10:06:23: BANCHO error: System.Net.WebException: Die Verbindung mit dem Remoteserver kann nicht hergestellt werden. ---> System.Net.Sockets.SocketException: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte 141.101.112.193:443
bei System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
bei System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
--- Ende der internen Ausnahmestapelüberwachung ---
bei #=qOqnn2py2PwnU6$uIXam5$1hXzS6UUieMPbkKDI_FVPc=.#=q$Bz1$LBsM96PprOLQ9E5__Q_74h1lBvci5dKAo1UTAo=()
bei #=qM_sMLwEooPizZhaXp7Xl7VKF4UtuhpKQmwS$eHLM$CA=.#=qdgnVfxXyE9duXHDbDpkxmw==(Boolean #=q1ocCHbkqEwatFzDdnT_mzg==)
bei #=qM_sMLwEooPizZhaXp7Xl7VKF4UtuhpKQmwS$eHLM$CA=.#=qCXneXgBcG5TjuIpFeEWoSg==()
I have the same issue. THought it's on my end.
posted
I tried compatibility mode after crashes I experience during osu!standard game-play, to find it completely black.



gl_info.txt

GL Version: OpenGL ES 2.0 (ANGLE 2.1.0.8afe1e1b8397)
GL Renderer: ANGLE (NVIDIA GeForce GT 220 Direct3D9 vs_3_0 ps_3_0)
GL Shader Language version: OpenGL ES GLSL ES 1.00 (ANGLE 2.1.0.8afe1e1b8397)
GL Vendor: Google Inc.
GL Extensions: GL_OES_element_index_uint GL_OES_packed_depth_stencil GL_OES_get_program_binary GL_OES_rgb8_rgba8 GL_EXT_texture_format_BGRA8888 GL_EXT_read_format_bgra GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_float GL_OES_texture_float_linear GL_EXT_texture_compression_dxt1 GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_depth_texture GL_EXT_texture_storage GL_OES_texture_npot GL_EXT_texture_filter_anisotropic GL_EXT_occlusion_query_boolean GL_NV_fence GL_EXT_robustness GL_EXT_blend_minmax GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_pack_reverse_row_order GL_OES_standard_derivatives GL_EXT_shader_texture_lod GL_EXT_frag_depth GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_EXT_debug_marker
GL Context: Index: 95731348, Color: 32 (8888), Depth: 16, Stencil: 0, Samples: 0, Accum: 0 (0000), Buffers: 2, Stereo: False

Strangely enough, it works fine on compatibility mode OFF, until I play osu!standard, where it sometimes crashes. And it's that mode specifically.
posted
Issue(s) in this thread have been addressed by the following changes:
  1. Fix flashlight is not updated at loading multiplayer match. (WujekGrzyb)


The changes will be applied to builds newer than b20151017cuttingedge.

Please follow up in this thread if you believe more work needs to be done to fix the mentioned issues. If they have not yet been resolved, please provide any new details that may have arisen after this build.
posted
Issue(s) in this thread have been addressed by the following changes:
  1. Fix samples are sometimes disposed too early in concurrent thread. (WujekGrzyb)


The changes will be applied to builds newer than b20151020cuttingedge.

Please follow up in this thread if you believe more work needs to be done to fix the mentioned issues. If they have not yet been resolved, please provide any new details that may have arisen after this build.
posted
Issue(s) in this thread have been addressed by the following changes:
  1. Fix download sprites not being cleared when download is canceled. (TheVileOne)


The changes will be applied to builds newer than b20151021cuttingedge.

Please follow up in this thread if you believe more work needs to be done to fix the mentioned issues. If they have not yet been resolved, please provide any new details that may have arisen after this build.
posted

Denro wrote:

I get many "disconnects" (even though they are only for 1 - 5 seconds): My Network-Log displays the following (sorry it's in german):
18.10.2015 10:06:23: BANCHO error: System.Net.WebException: Die Verbindung mit dem Remoteserver kann nicht hergestellt werden. ---> System.Net.Sockets.SocketException: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte 141.101.112.193:443
bei System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
bei System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
--- Ende der internen Ausnahmestapelüberwachung ---
bei #=qOqnn2py2PwnU6$uIXam5$1hXzS6UUieMPbkKDI_FVPc=.#=q$Bz1$LBsM96PprOLQ9E5__Q_74h1lBvci5dKAo1UTAo=()
bei #=qM_sMLwEooPizZhaXp7Xl7VKF4UtuhpKQmwS$eHLM$CA=.#=qdgnVfxXyE9duXHDbDpkxmw==(Boolean #=q1ocCHbkqEwatFzDdnT_mzg==)
bei #=qM_sMLwEooPizZhaXp7Xl7VKF4UtuhpKQmwS$eHLM$CA=.#=qCXneXgBcG5TjuIpFeEWoSg==()
I also experience this issue. Its really annoying as you cant play multiplayer without getting stuck in "Waiting for all players."
Also it is not my connections fault as any other game/program/connection is fine.
posted
Issue(s) in this thread have been addressed by the following changes:
  1. Fix remaining spinner alignment issues (osu! and taiko modes). (peppy)


The changes will be applied to builds newer than b20151021.1cuttingedge.

Please follow up in this thread if you believe more work needs to be done to fix the mentioned issues. If they have not yet been resolved, please provide any new details that may have arisen after this build.
posted
It worked perfect! There are no spinner alignment issues now. Thank you peppy.

I also read your blog, I feel sorry for I'm the one of them that still using 5:4 monitor.
posted
I just started my osu on cutting edge, and it auto-updated to a stable build (wtf), reset all my settings, and logged me out. I don't understand.
posted

Rickput wrote:

I just started my osu on cutting edge, and it auto-updated to a stable build (wtf), reset all my settings, and logged me out. I don't understand.
Well, are you actually sure that you didn't open a wrong osu! installation? Because osu! will not change your release stream and reset your settings automatically. Unless something goes extremely wrong.
posted

Trosk- wrote:

Rickput wrote:

I just started my osu on cutting edge, and it auto-updated to a stable build (wtf), reset all my settings, and logged me out. I don't understand.
Well, are you actually sure that you didn't open a wrong osu! installation? Because osu! will not change your release stream and reset your settings automatically. Unless something goes extremely wrong.
I only have one installation.

I got everything sorted out again, had to re-apply all my settings and log in again, set to cutting edge, etc. I don't know what happened, though.
show more
Please sign in to reply.