[Archived] Issues with Latest Cutting-edge Build (Post Here)

posted
Total Posts
2,521
show more
Low Snow
I got an error "The procedure entry point strnlen could not be located in the dynamic link library msvcrt.dll"

And now Osu! is running with a black screen.
innocencia

Tom94 wrote:

fujger wrote:

After latest update the game crashes when i'm trying to play any map. At first ten second i didn't see any problems but then FPS grew up from usual 1700 to unusual 2500-3400 and game was crashed. I can't even do screenshots, so
UPD: this issue happened only with two my skins, so i can't suggest what can be source of this trouble
It is possible that your GPU has an unstable clock and/or is overheating due to the additional frame rate it is pumping out with the new update. Try using a frame limiter to limit your FPS (you can adjust it to limit to 1500 or whatever you like in your osu! config) and see if it helps.

To do this go into your osu! folder, open "osu!.<your windows username>.cfg", then change "CustomFrameLimit" to whichever value you like.
Yes, it helped, but it never happened before, so i think that it's a new issue. Try to run any map with Azerino's skins.
Trosk-

Low Snow wrote:

I got an error "The procedure entry point strnlen could not be located in the dynamic link library msvcrt.dll"

And now Osu! is running with a black screen.
I actually don't think that is happening because of the Cutting Edge latest build... Hold Shift while opening osu! and change the release stream to Stable on the window that will pop up, to see if you can run it on Stable.

fujger wrote:

Yes, it helped, but it never happened before, so i think that it's a new issue. Try to run any map with Azerino's skins.
I don't think that the fact of playing with a skin will affect the performance...
lollllloro
Some beatmaps seem to fail without reason at the end and it's reproducible every time. I remember this happening a long time ago on stable too
example beatmap ../s/144010, at least on "Rare's Hard" and "Insane"
my crappily recorded and youtube's audiosyncscrewedup video: https://youtu.be/kJQF2r5QyzM
with nf it just stops at the end, this screenshot is from the "Rare's Hard" difficulty with build b20150814.5 :
http://54.213.154.174:777/B/nofail%20hang

I accidentally made this post about this earlier: p/4413391 ;_; what should I do?

EDIT:
Just figured out what causes it! It's somehow miscalculated length for the music, maybe related to the huge offset I have set in osu which is -112 ms. Appended ~6sec of silence to the mp3 file and it worked, reverted the changes and failed at full hp again.
commands used to fix it:
dd if=/dev/zero bs=1M count=1|sox -traw -esigned -b16 -r44100 -c2 - silence.wav
ffmpeg -i silence.wav -b:a 128k silence.mp3
printf "file 'kanransha.mp3'\nfile 'silence.mp3'\n" >tmptext
ffmpeg -f concat -i tmptext -c copy joined.mp3
mv kanransha.mp3 kanransha.mp3.b
mv joined.mp3 kanransha.mp3
Trosk-

lollllloro wrote:

Some beatmaps seem to fail without reason at the end and it's reproducible every time. I remember this happening a long time ago on stable too
example beatmap ../s/144010, at least on "Rare's Hard" and "Insane"
my crappily recorded and youtube's audiosyncscrewedup video: https://youtu.be/kJQF2r5QyzM
with nf it just stops at the end, this screenshot is from the "Rare's Hard" difficulty with build b20150814.5 :
http://54.213.154.174:777/B/nofail%20hang

I accidentally made this post about this earlier: p/4413391 ;_; what should I do?
Can't replicate on the map you linked. Also, this is known.

Related thread: t/145370
Tom94

fujger wrote:

Yes, it helped, but it never happened before, so i think that it's a new issue. Try to run any map with Azerino's skins.
As I said, since you got a higher frame rate your GPU was under more stress. This is not a "new" issue, rather we optimized osu! to be able to go faster, which made your PC stumble. Please upload the skin in question, though, then I can check for myself if it causes problems for me.
Low Snow

Trosk- wrote:

I actually don't think that is happening because of the Cutting Edge latest build... Hold Shift while opening osu! and change the release stream to Stable on the window that will pop up, to see if you can run it on Stable.
Cutting edge still running with a black screen
Stable has an issue with my skin.ini
Beta seems fine
Trosk-

Low Snow wrote:

Cutting edge still running with a black screen
Stable has an issue with my skin.ini
Beta seems fine
Issue with skin.ini? What? I believe that nothing has changed on skin.ini from Stable to Beta and Cutting Edge...

And regarding the black screen on CE, I don't actually know. Could you try to run it with the new Compatibility mode enabled? Close osu!, go to your "osu!username.cfg" and change the line "CompatibilityContext" to: CompatibilityContext = 1 (change it while osu! is closed)
Tom94
Low Snow, could you try downloading and installing http://www.microsoft.com/en-us/download ... x?id=40784 (select "vcredist_x86.exe" ), then restarting your computer and then checking if the problem is solved?
Low Snow

Trosk- wrote:

And regarding the black screen on CE, I don't actually know. Could you try to run it with the new Compatibility mode enabled? Close osu!, go to your "osu!username.cfg" and change the line "CompatibilityContext" to: CompatibilityContext = 1 (change it while osu! is closed)
Tried, and doesn't work :/

Tom94 wrote:

Low Snow, could you try downloading and installing http://www.microsoft.com/en-us/download ... x?id=40784 (select "vcredist_x86.exe" ), then restarting your computer and then checking if the problem is solved?
I tried first to run osu CE without reboot, blackscreen but no error message this time
After reboot, the error message came back and the blackscreen still here
Tom94
Can you try https://www.microsoft.com/en-us/downloa ... px?id=5555 , https://www.microsoft.com/en-us/downloa ... aspx?id=29 and https://www.microsoft.com/en-us/downloa ... x?id=48145 too? Please let me know if one of them works, and if yes, which one. Your error message sounds like one of these is mis-installed on your machine.
Shizuyi

Shizuyi wrote:

Besides what i posted earlier now osu! starts crashing randomyl while playing. Its only since the latest update. Did not happen before. Osu itself doesnt give a note of crashing but Windows does.

Quelle
osu!

Zusammenfassung
Nicht mehr funktionsfähig

Datum
‎08.‎08.‎2015 01:14

Status
Der Bericht wurde gesendet.

Beschreibung
Pfad der fehlerhaften Anwendung: D:\Program Files (x86)\osu!\osu!.exe

Problemsignatur
Problemereignisame: APPCRASH
Anwendungsname: osu!.exe
Anwendungsversion: 1.3.3.7
Anwendungszeitstempel: 55c4f93d
Fehlermodulname: nvoglv32.DLL
Fehlermodulversion: 10.18.13.5362
Fehlermodulzeitstempel: 55b031c2
Ausnahmecode: c0000005
Ausnahmeoffset: 008d4b6d
Betriebsystemversion: 6.3.9600.2.0.0.768.101
Gebietsschema-ID: 1031
Zusatzinformation 1: 5861
Zusatzinformation 2: 5861822e1919d7c014bbb064c64908b2
Zusatzinformation 3: a10f
Zusatzinformation 4: a10ff7d2bb2516fdc753f9c34fc3b069

Weitere Informationen über das Problem
Bucket-ID: 098318bfcc7b93bc0a6b78831f4fcf29 (107509696050)

Seems to be soemthing with the new vertex buffer on OpenGL. Maybe my gl_info belwo will help. :)
GL Version:                 4.5.0 NVIDIA 353.62
GL Renderer: GeForce GTX 780 Ti/PCIe/SSE2
GL Shader Language version: 4.50 NVIDIA
GL Vendor: NVIDIA Corporation
GL Extensions: GL_AMD_multi_draw_indirect GL_AMD_seamless_cubemap_per_texture GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_bindless_texture GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compatibility GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_compute_shader GL_ARB_compute_variable_group_size GL_ARB_conditional_render_inverted GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_derivative_control GL_ARB_direct_state_access GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_ES3_1_compatibility GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4 GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_indirect_parameters GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_NV_internalformat_sample_query GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multi_draw_indirect GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_query_buffer_object GL_ARB_shader_storage_buffer_object GL_ARB_shader_subroutine GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_include GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_sparse_buffer GL_ARB_sparse_texture GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transform_feedback_overflow_query GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXTX_framebuffer_mixed_formats GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset_clamp GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_shader_objects GL_EXT_separate_specular_color GL_EXT_shader_image_load_store GL_EXT_shader_integer_mix GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback2 GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_vertex_attrib_64bit GL_EXT_import_sync_object GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KHR_context_flush_control GL_KHR_debug GL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_KTX_buffer_region GL_NV_bindless_multi_draw_indirect GL_NV_bindless_multi_draw_indirect_count GL_NV_bindless_texture GL_NV_blend_equation_advanced GL_NV_blend_square GL_NV_command_list GL_NV_compute_program5 GL_NV_conditional_render GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_float GL_NV_depth_clamp GL_NV_draw_texture GL_NV_ES1_1_compatibility GL_NV_ES3_1_compatibility GL_NV_explicit_multisample GL_NV_fence GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4 GL_NV_gpu_program4 GL_NV_gpu_program4_1 GL_NV_gpu_program5 GL_NV_gpu_program5_mem_extended GL_NV_gpu_program_fp64 GL_NV_gpu_shader5 GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_coverage GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object GL_NV_parameter_buffer_object2 GL_NV_path_rendering GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_shader_atomic_counters GL_NV_shader_atomic_float GL_NV_shader_atomic_int64 GL_NV_shader_buffer_load GL_NV_shader_storage_buffer_object GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_multisample GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_transform_feedback GL_NV_transform_feedback2 GL_NV_uniform_buffer_unified_memory GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_attrib_integer_64bit GL_NV_vertex_buffer_unified_memory GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render GL_NVX_gpu_memory_info GL_NVX_nvenc_interop GL_NV_shader_thread_group GL_NV_shader_thread_shuffle GL_KHR_blend_equation_advanced GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum GL_WIN_swap_hint WGL_EXT_swap_control
GL Context: Index: 8, Color: 32 (8888), Depth: 24, Stencil: 0, Samples: 0, Accum: 64 (16161616), Buffers: 2, Stereo: False
This issue is fixed since the latest CE. :) Im happy about it!

What im not happy about is that since the update my FPS went down about 10-20%. Is this intended since the Renderer got updated again?
Trosk-

Shizuyi wrote:

This issue is fixed since the latest CE. :) Im happy about it!

What im not happy about is that since the update my FPS went down about 10-20%. Is this intended since the Renderer got updated again?
Well, the intention was to increment the performance, not to reduce it. So, probably there is still something wrong.
Tom94

Shizuyi wrote:

This issue is fixed since the latest CE. :) Im happy about it!

What im not happy about is that since the update my FPS went down about 10-20%. Is this intended since the Renderer got updated again?
Did you by any chance enable compatibility mode? FPS should not have decreased unless you enabled compatibility mode. An exception is if you run osu! on a laptop with a discrete graphics card, in which case choosing the compatibility mode and forcing osu! to use the discrete graphics card may help.
sgtgs42
I'm having issues with the new cutting edge build. It keeps crashing a few seconds into a song I try to play. Windows 7. Any ideas?
Tom94

sgtgs42 wrote:

I'm having issues with the new cutting edge build. It keeps crashing a few seconds into a song I try to play. Windows 7. Any ideas?
Does using a framelimiter help? (e.g. in the options, select 120 FPS)
lollllloro
p/4424287

this is caused by my offset! I played it with nofail and offset 0 and it didn't hang at the end, set my offset back and it hanged again!

Can someone confirm this happens when you set your offset below -112 or something?
Low Snow

Tom94 wrote:

Can you try https://www.microsoft.com/en-us/downloa ... px?id=5555 , https://www.microsoft.com/en-us/downloa ... aspx?id=29 and https://www.microsoft.com/en-us/downloa ... x?id=48145 too? Please let me know if one of them works, and if yes, which one. Your error message sounds like one of these is mis-installed on your machine.
Thank you, but the error message and the blackscreen still here :c
Trosk-

lollllloro wrote:

https://osu.ppy.sh/forum/p/4424287

this is caused by my offset! I played it with nofail and offset 0 and it didn't hang at the end, set my offset back and it hanged again!

Can someone confirm this happens when you set your offset below -112 or something?
Can replicate now... By the way, happens on all release streams, not only on CE.

Go to 1:35 on the video.

Tom94

Low Snow wrote:

Tom94 wrote:

Can you try https://www.microsoft.com/en-us/downloa ... px?id=5555 , https://www.microsoft.com/en-us/downloa ... aspx?id=29 and https://www.microsoft.com/en-us/downloa ... x?id=48145 too? Please let me know if one of them works, and if yes, which one. Your error message sounds like one of these is mis-installed on your machine.
Thank you, but the error message and the blackscreen still here :c
o_O that's really weird. Can you try going into your osu! folder, opening "osu!.<your windows username>.cfg" and changing "CompatibilityContext = 0" to "CompatibilityContext = 1"?
show more
Please sign in to reply.

New reply