[Archived] Issues with Latest Cutting-edge Build (Post Here)

posted
Total Posts
2,521
show more
power007

Tom94 wrote:

Did you already try enforcing your dedicated GPU in the nvidia control panel?
Yes I've tried. Identical behavior of osu!. For example Borderland 2 using 7-10% of Intel GPU and 99% of NVidia GPU.
Default
In the editor, clicking on the song setup tab while in fullscreen mode makes the game lag and it sends me to desktop. Windowed mode fixes it.
bobbybobsenpwned
While on cutting edge (or beta) I can't alt-tab out of the game. It seems as if I actually do switch to another window, when i do so, but the image from osu persists and prevents me from seeing the other window i've switched too. The problem exists both when in fullscreen, or borderless

It seems the problem is only there, when I use my max resolution (1600x900), or have letterboxing activated.

My computer is a laptop, ASUS N76VJ, with windows 8.1, And here's the specs I could find about my computer
GhostFrog
I have the "Prefer no-video downloads" option selected, but osu!direct is still downloading videos by default. I've only tried it with 2 maps that have video (this and this, in case it matters), but it definitely downloaded the video for both.
BanchoBot
Issue(s) in this thread have been addressed by the following changes:
  1. Never minimize osu! while in the editor due to issues with child forms. (Tom94)
  2. Fix viewport being 1 pixel off while in forced non-exclusive fullscreen mode. (Tom94)


The changes will be applied to builds newer than b20150709cuttingedge.

Please follow up in this thread if you believe more work needs to be done to fix the mentioned issues. If they have not yet been resolved, please provide any new details that may have arisen after this build.
Drayne

Drayyne wrote:

I realized, if I play on cutting edge I get frame drops over and over again. I play, framerate is fine at 800 or something and then suddenly it drops really low for just one second, then it's normal again, then it drops again... It seems like it's happening especially if I play doubletime. My computer is old, but i never had this on stable version.
Just found out that the framedrops are gone if I restart osu!. But they are cooming back after 10-20 minutes playtime
Tom94
Can you make sure your system is not overheating and throttling down as a consequence? This is likely in case you are running on a laptop. Try using a frame limiter to reduce your framerate and see if the drops are still as severe.

If this doesn't help, please try closing all background applications while playing osu!.
Drayne

Tom94 wrote:

Can you make sure your system is not overheating and throttling down as a consequence? This is likely in case you are running on a laptop. Try using a frame limiter to reduce your framerate and see if the drops are still as severe.

If this doesn't help, please try closing all background applications while playing osu!.
I don't play on a laptop and my system is not overheating. I tried to cap fps, but it didn't help. Also closed all background applications, still didn't help. But as I said i a previous post, osu! ran perfectly fine on stable version.
Tom94
Comparing it with stable is not valid in the case of throttling. CE makes more use of the GPU, usually resulting in higher temperatures, but also higher frame rates.

Either way, if you can rule out heat and throttling (this can also happen on desktops), then could you make a screenshot of how the frame time display looks like during the stutters and without stutters for you? You can toggle the display using Ctrl+F11.
Trosk-
If you move the osu! window while it is on the welcome screen, the menu-background of the skin won't load. This gets fixed by reloading the skin.

Doesn't happen on Stable release stream.

Drayne

Tom94 wrote:

Comparing it with stable is not valid in the case of throttling. CE makes more use of the GPU, usually resulting in higher temperatures, but also higher frame rates.

Either way, if you can rule out heat and throttling (this can also happen on desktops), then could you make a screenshot of how the frame time display looks like during the stutters and without stutters for you? You can toggle the display using Ctrl+F11.
Ok, osu! is running good again, the problem was that my computer couldnt handle some storyboard stuff (the framedrops I mentioned just happened again, disabled storyboard and it worked). But I noticed, that if I move my cursor fast the cursor is flickering. Not really a big problem, just wanted to say it.
Tom94
What do you mean by flicker? Tearing? It happens both on stable and on cuttingedge if you are running in fullscreen mode or have windows aero disabled while not using VSync. There is no way around it unfortunately.
Drayne

Tom94 wrote:

What do you mean by flicker? Tearing? It happens both on stable and on cuttingedge if you are running in fullscreen mode or have windows aero disabled while not using VSync. There is no way around it unfortunately.
Yes, ok didn't know that as i used to play on stable in windowed mode and now on CE in letterboxing + fullscreen. Letterboxing is really nice btw, i love it and can't play without it anymore :) So osu! is running fine again, problem solved.
Kuraiko55
Hello folks,

relating to this post I made almost a month ago I was now able to make a video of the issue that appears from time to time when I play osu!.

In short:
Sometimes while playing any map in osu! the game is jerking for a split second, i.e. it is not running smoothly for a little moment most likely throwing me outa the beat and messing up my play.

Video-Link: https://youtu.be/9Tehv34hiPA
I added further information in the video description.

I appolagize in advance if the video and/or sound quality should be bad, for this is the first time I tryed video editing ^^

Greetz
Kuraiko
lolcubes
Having issues with vsync on fullscreen. As you can see, with VSync enabled, the fps don't have a limit at all. Setting 120/240 sets to 120/240 normally.
Using Intel HD4000.

EDIT: woooops forgot the image.
Shizuyi
In the Nvidia Driver you also can disable VSync in the Control Panel of the Driver.
I do not know if this is possible for integrated Graphics. Did you tried that?
Also i am sure you did, when its possible, but i ask just to be sure.
abraker
CE still seems to have memory leak(s) after hours of mapping. I mapped a mania map for 4-5 hours and the mem usage rose from ~450 mb to 1.2 gb. The client risks being unusable if you decide to play without restarting beforehand, leading to a black screen with no signs of input or output or even a generic windows crash.
lolcubes

Shizuyi wrote:

In the Nvidia Driver you also can disable VSync in the Control Panel of the Driver.
I do not know if this is possible for integrated Graphics. Did you tried that?
Also i am sure you did, when its possible, but i ask just to be sure.
When you use Intel IGPU, the nvidia options are disabled. I have tried forcing it in Intel settings, without effect.
Bara-
Play a map with Nightcore mod
Watch the replay
Turn off Nightcore
The speed/pitch is correct, but you still hear the added sounds (claps/cymbals/beats etc.)

Also, if you watch a replay with NC, and set play back speed to 0.5, it'll be normal pitched, but if you disable NC, it'll be lower pitched
Even more: If you set play back speed to 2, with NC on it'll be incredibly high pitched (<3), with NC off it'll be pitched like NC normally

So many NC bugs O.o

Kinda off-topic, when was x2 replay speed supported for DT/NC?
Trosk-

baraatje123 wrote:

Play a map with Nightcore mod
Watch the replay
Turn off Nightcore
The speed/pitch is correct, but you still hear the added sounds (claps/cymbals/beats etc.)

Also, if you watch a replay with NC, and set play back speed to 0.5, it'll be normal pitched, but if you disable NC, it'll be lower pitched
Even more: If you set play back speed to 2, with NC on it'll be incredibly high pitched (<3), with NC off it'll be pitched like NC normally
I can reproduce it, but I don't know if this can be "fixed" or not, since the added sounds are added on the beatmap itself when you put NC on... So, maybe it's "intended".

And the pitch thing, I think it's normal behaviour.

baraatje123 wrote:

Kinda off-topic, when was x2 replay speed supported for DT/NC?
At the same time as the feature to disable mods on replays, I believe.
show more
Please sign in to reply.

New reply