[confirmed] Universal offset causes beatmap to skip at beginning

posted
Total Posts
7
Topic Starter
Redon
Problem Details:

The problem occurs when using an universal offset value other than 0, and affects all game modes.
The offset value has an effect on how early or late notes appear on the screen. Instead of adjusting the timing right away, the game seems to apply this offset change after the beatmap has started, and sometimes while notes are already on the screen, which causes these notes to 'skip' forward or back in time.
This is only observable on beatmaps that have early notes, like the example used in the video IOSYS - Cirno's Perfect Math Class.

While using a negative offset, the notes appear too late at first and jump forward at the beginning of the song. While using a positive offset, the notes appear too early and jump back.

Same issue as described in this thread, although that one has already been marked as resolved because "the problem solved itself", probably by resetting the offset.

Video or screenshot showing the problem:

I recommend you try this yourself, but here's an example:



osu! version: b20140410.5
Dexus
I can confirm this seems to happen on maps where there isn't a rest at the start, or the note is placed to where the map is started right away.
sheela
This affects to maps that has a lower audio lead-in. The map you posted has an audio lead-in to 0. So the map starts too early.
Topic Starter
Redon
Little bump.

sheela901 wrote:

This affects to maps that has a lower audio lead-in. The map you posted has an audio lead-in to 0. So the map starts too early.
I'm not sure what you're trying to say. That the beatmap is at fault? This problem affects many beatmaps, and I'll gladly give you a compilation of some examples if you need them. The point is that an offset adjustment should optimally be done right away, and not after the beatmap has already started.
Topic Starter
Redon
This was never fixed.
VeilStar
Moved this back.

Anyhow, I can confirm that this is an issue. Correct me if I'm wrong, but I think it's because osu! is synchronising the audio and beatmap, taking the offset values in mind as soon as the map starts.

Confirming...
Score_Under
Happens for me too. Was about to post a bug:
Problem Details:
If you give a map a low local offset, the first hit circle will appear, disappear, then appear again at the start of the map.

Video or screenshot showing the problem:
https://youtu.be/aTrJFGSK3Rk (Apologies for the sound quality, still recording from the hardware stereo mix and it's evidently not that good)
Pay close attention to the very first circle per try. It messes with my head a little in hidden. Map used: https://osu.ppy.sh/b/470315 (insane; with an offset of -280 ms)

osu! version: 20151024.5cuttingedge (tested on stable too)
This has been moved to low-priority but it affects gameplay (it's confusing), especially when using the hidden mod.
Please sign in to reply.

New reply