community forum

[resolved] [confirmed] Crash when spectating, playing, or retrying maps.

posted
Total Posts
217
show more
tsundoll

peppy wrote:

How much video memory do people have who are experiencing this? Maybe it is getting saturated?
I have 358 MB of Graphics memory. That doesn't explain why some times I can play for hours and sometimes it crashes on the first map I play though. If it always happened after extended play, saturation would make sense.
TheVileOne
512 MB VRAM
Karuta-
I don't think it's the memory, but the crash only happens when I retry too fast. It is less likely to crash when I pause a bit after hitting the escape button

I crashed on two different computers

Notebook: Intel graphics 1st Gen Core, DDR3 memory 2+2gb

Desktop: Asus GT520SL DDR2 1GB, DDR2 memory 2+2gb
Topic Starter
Niervaco
I'm looking at 1.5 GB of shared memory for graphics. it never gets used up even past 3/4 a GB.

tsundoll wrote:

I have 358 MB of Graphics memory. That doesn't explain why some times I can play for hours and sometimes it crashes on the first map I play though. If it always happened after extended play, saturation would make sense.
That just sounds like a really awkward memory number, and a bit small.
tsundoll

Niervaco wrote:

tsundoll wrote:

I have 358 MB of Graphics memory. That doesn't explain why some times I can play for hours and sometimes it crashes on the first map I play though. If it always happened after extended play, saturation would make sense.
That just sounds like a really awkward memory number, and a bit small.
Well, that's what's usable by the system, it's probably more. But hey, it's integrated. It's always worked fine in the past.
Topic Starter
Niervaco
I crashed recently while in editor mode making a new map. It prompted me to save first randomly, then when i said yes. BAM. Crash.
FlyingNeko
I just had a crash while playing a song but it seems to have a different crash code. I don't know if this is related.
It just happened once around the end of the last break (3:03).

Song: nano.RIPE - Real World (https://osu.ppy.sh/s/59269) with NoFail on

System.NullReferenceException: Object reference not set to an instance of an object.
at #Lm.#Mm.#qs()
at #Lm.#sp.#Ms()
at #1h.#0h.#Ms()
at #rb.#xb.#7s()
at #rb.#xb.#it(Object , EventArgs )
at #rb.#Bb.#Dt()
at #rb.#Rb.#Sv(Object , EventArgs )
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at #rb.#Rb.#ot()
at #rb.#xb.#ot()
at #1h.#np.#Iwb(String , Boolean )

This might be something minor though, I don't know.
Necro Neko
Just got this problem today and never had to deal with anything like that before. But it basically is just what other people have already said. Osu! crashes when trying to retry a map several times and this has only happened in Taiko for me.

System.InvalidOperationException: Begin cannot be called again until End has been successfully called.
at Microsoft.Xna.Framework.Graphics.SpriteBatch.Begin(SpriteBlendMode blendMode, SpriteSortMode sortMode, SaveStateMode stateMode, Matrix transformMatrix)
at Microsoft.Xna.Framework.Graphics.SpriteBatch.Begin(SpriteBlendMode blendMode, SpriteSortMode sortMode, SaveStateMode stateMode)
at #Lm.#sp.#8Fb(Boolean )
at #Lm.#sp.#Ms()
at #Vl.#Yo.#0tb()
at #5i.#4i.#Ms()
at #rb.#xb.#Ms()
at #1h.#0h.#Ms()
at #rb.#xb.#7s()
at #rb.#xb.#it(Object , EventArgs )
at #rb.#Bb.#Dt()
at #rb.#Rb.#Sv(Object , EventArgs )
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at #rb.#Rb.#ot()
at #rb.#xb.#ot()
at #1h.#np.#Iwb(String , Boolean )
Armx
So this is why I crashed :c

After retrying a map, osu crashed and what make me sad is that it didn't record a lot of new scores I managed to achieve :( My osu profile, however, does mention said new scores as I achieved new global rankings... is there any way to recover lost scores? Or do I need to restart again?

Thanks in advance~
DarkKanaki

Armx wrote:

So this is why I crashed :c

After retrying a map, osu crashed and what make me sad is that it didn't record a lot of new scores I managed to achieve :( My osu profile, however, does mention said new scores as I achieved new global rankings... is there any way to recover lost scores? Or do I need to restart again?

Thanks in advance~
Program Files > osu! > Data > r > sort by date > start double clicking the osg files...
Armx

DarkKanaki wrote:

Armx wrote:

So this is why I crashed :c

After retrying a map, osu crashed and what make me sad is that it didn't record a lot of new scores I managed to achieve :( My osu profile, however, does mention said new scores as I achieved new global rankings... is there any way to recover lost scores? Or do I need to restart again?

Thanks in advance~
Program Files > osu! > Data > r > sort by date > start double clicking the osg files...
Thank you a lot, and sorry if it was obvious ^^u
xasuma
I've had this crash about 15 times today (lol, i know..) . And from my experience, I believe it happens (in my case ast least) more often when I switch songs really fast - as in , I finish a song, and quickly press f2, f2, and play right away-.

It only happens after an input from me , never in the middle of a song. (sometimes right at the beginning of one though.)

I was also experiencing memory issues today- I dont know if that's got do to with it. But it seemed that it was coming from osu! , or something related to the game.


Hopefully it gets fixed. Ty :)

Pd: I have 16 gb of ram and 3gb gpu.
Sohma99
Yeah I've been crashing everytime I retry a map for the past hour....Guess I'm not the only one xD.
details:
System.InvalidOperationException: Begin cannot be called again until End has been successfully called.
at Microsoft.Xna.Framework.Graphics.SpriteBatch.Begin(SpriteBlendMode blendMode, SpriteSortMode sortMode, SaveStateMode stateMode, Matrix transformMatrix)
at Microsoft.Xna.Framework.Graphics.SpriteBatch.Begin(SpriteBlendMode blendMode, SpriteSortMode sortMode, SaveStateMode stateMode)
at #Lm.#sp.#8Fb(Boolean )
at #Lm.#sp.#Ms()
at #Vl.#Yo.#0tb()
at #5i.#4i.#Ms()
at #rb.#xb.#Ms()
at #1h.#0h.#Ms()
at #rb.#xb.#7s()
at #rb.#xb.#it(Object , EventArgs )
at #rb.#Bb.#Dt()
at #rb.#Rb.#Sv(Object , EventArgs )
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at #rb.#Rb.#ot()
at #rb.#xb.#ot()
at #1h.#np.#Iwb(String , Boolean )
ritsu101nightshade
. . . I changed my skins, and I can't help but realise how much LESS frequent it's crashing right now . . . A song that I could never play last time now works okay. I changed to Nexus Slate skin [with the same catcher]
Topic Starter
Niervaco

ritsu101nightshade wrote:

. . . I changed my skins, and I can't help but realise how much LESS frequent it's crashing right now . . . A song that I could never play last time now works okay. I changed to Nexus Slate skin [with the same catcher]
It could just be the Pseudocertainty effect, then again, sprite crashes are inconsisntent.
ritsu101nightshade

Niervaco wrote:

ritsu101nightshade wrote:

. . . I changed my skins, and I can't help but realise how much LESS frequent it's crashing right now . . . A song that I could never play last time now works okay. I changed to Nexus Slate skin [with the same catcher]
It could just be the Pseudocertainty effect, then again, sprite crashes are inconsisntent.
That beatmap is the one that ALWAYS crashes, no matter what I do [crashes from the start, not retry], but well, I shouldn't complain. Even if it was just mind over matter, it's a lot less annoying
Kurumi-Sama
I just crash once in a while as well, though i have no idea whats causing it. I've been experiencing it for quite a while ( 1-2 months)
Amianki
I have no idea if this issue is relevant to the one in this thread, but I generally have issues when talking to people while a map is loading. Usually it will say that an error has occured, but occasionally it will straight up crash the client.
TheVileOne
peppy is working on fixing this issue. It is very tricky to diagnose. Please be patient while he tries to figure out a solution.


You can use openGl in the meantime. This is a directX issue.
GitahMuttan

TheVileOne wrote:

You can use openGl in the meantime.
I'd re open osu for a hundred times instead of using opengl.
show more
Please sign in to reply.

New reply